Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto Z Phones - Mod CapableMoto Z Force
All Forum Topics
Options

5 Posts

07-30-2016

United States of America

6 Signins

45 Page Views

  • Posts: 5
  • Registered: ‎07-30-2016
  • Location: United States of America
  • Views: 45
  • Message 1 of 45

Speaker issue

2016-07-30, 3:40 AM

I'm having an issue where after streaming Spotify through Bluetooth in my car, when I switch back to the phone speaker it will make a popping sound before anything that plays a sound (ex. Icon clicks, keyboard sounds, YouTube etc), the only fix I can find is to reboot the phone and it will go away until I play music in the car. 

Reply
Options

57 Posts

11-15-2011

United States of America

59 Signins

695 Page Views

  • Posts: 57
  • Registered: ‎11-15-2011
  • Location: United States of America
  • Views: 695
  • Message 2 of 45

Re: Speaker issue

2016-07-30, 4:55 AM

Sorry: wish I had something to offer solution-wise here. But while my car does have bluetooth phone + text-to-speech for SMS (which seem to work fine), it doesn't let me stream music from my phone; so I cant test this to try and duplicate the problem.

 

I did notice oddly that when I imported my contacts to the phone and went through them to assign custom ringtones, as I selected a tone it played/demoed at a very low volume. I would have to tap twice to make it demo the selected ringtone at normal volume so I could be sure I chose the one intended. So I think mine's a different example to add with yours to indicate some issue software-wise in regards to the speaker..... Hipefully more people have experienced the same exact problem as yours & will comment so this will reach the attention of the experts so a fix can be identified..

Reply
Options

2 Posts

08-02-2016

United States of America

84 Signins

874 Page Views

  • Posts: 2
  • Registered: ‎08-02-2016
  • Location: United States of America
  • Views: 874
  • Message 3 of 45

Re: Speaker issue

2016-08-02, 15:45 PM

I notice my speaker makes a little "pop" noise whenever it starts to make a sound - even if the phone is on mute.   I do use my phone daily in my car with bluetooth, so I haven't considered this as a trigger to the noise.

I can get the noise to trigger consistently by pulling down to refresh inside the twitter app.  Is anybody else finding this result?

Reply
Options

5 Posts

07-30-2016

United States of America

6 Signins

45 Page Views

  • Posts: 5
  • Registered: ‎07-30-2016
  • Location: United States of America
  • Views: 45
  • Message 4 of 45

Re: Speaker issue

2016-08-02, 15:53 PM

That exactly the issue i was having... I also started having wifi connection problems where it would just drop out of wifi for a couple of seconds then reconnect every hour or so ... I ended up returning the phone and going back to my iPhone, I'll wait for the new iPhone in September instead.

Reply
Options

42 Posts

08-06-2016

United States of America

141 Signins

865 Page Views

  • Posts: 42
  • Registered: ‎08-06-2016
  • Location: United States of America
  • Views: 865
  • Message 5 of 45

Re: Speaker issue

2016-08-06, 4:29 AM

Ive had the same issue since day 1.  once it connects to bluetooth via car standalone speaker ect and plays audio(ive tried sirusxm app and google music)...then when disconnected the speaker will make a "snap" / "pop" before any sound is played be it music to even a notification sound. its any time the speaker would be activated. the  refresh pull down in the twitter app is the best way to test this as you can make the sound over and over.   Once phone is rebooted it goes  away until bluetooth is reconnected.    my girlfriend just got the  regular Moto Z ( none Force) and hers wont do it under the same exact conditions so  it looks like its a Force only issue weirdly enough.  Ive noticed while connected to bluetooth the phone itself does not make the snap sound its only FTER the bluetooth is disconnected and audio is reverted back to the phone speaker.  it will make the snap sound with all voume turned off and it makes it just the first time a the speaker would be activated. so you would ear it only at the first of a song or a video but its annoying  as it happens before all phone sounds so notifications or other phone tones really exaggerate the issue.

 

I called motorola tech support and reported the bug. they hadnt heard of the issue and escalated it to a higher department. they seemed appreciative of the report so after seeing others with the issue maybe they can easily replicate it. because of that  I see no reason in swapping out my phone  only to get another that does the same thing as it seems like an overall software glitch in the Force itself not just a bad phone I happened to unbox.   seems like a patch update is needed.

 

not sure what the cause is but one theory was something maybe with DRM but I dont know enough about that to say one way or the other. not sure how or why that would even affect the speaker.

 

only troubleshooting ive done was a network reset that cleared all the saved bluetooth but that did nothing.  havent tried a factory reset but my guess is its not going to do anything.

 

 

Reply
Options

1 Posts

08-07-2016

United States of America

1 Signins

19 Page Views

  • Posts: 1
  • Registered: ‎08-07-2016
  • Location: United States of America
  • Views: 19
  • Message 6 of 45

Re: Speaker issue

2016-08-07, 17:28 PM

I'm having the same issue except with my Bluetooth headphones. I use LG tones platinum for basically everything. My phone off a fresh boot functions fine. Once it connects to Bluetooth, even after I've disconnected from Bluetooth, my speaker makes a pop sound before playing a sound. Refreshing on Twitter will replicate this or clicking like on Facebook. 

 

I don't know if this is interrelated, but when doing a call through my Bluetooth headphones, I often have the phone disconnect and reconnect from Bluetooth. This did not happen with my droid turbo or my droid turbo 2 with the same headphones. I swapped sim cards and the issue still does not occur with my turbo. 

Reply
Options

20125 Posts

02-03-2016

United States of America

2600 Signins

65343 Page Views

  • Posts: 20125
  • Registered: ‎02-03-2016
  • Location: United States of America
  • Views: 65343
  • Message 7 of 45

Re: Speaker issue

2016-08-08, 15:15 PM

wrote:

Ive had the same issue since day 1.  once it connects to bluetooth via car standalone speaker ect and plays audio(ive tried sirusxm app and google music)...then when disconnected the speaker will make a "snap" / "pop" before any sound is played be it music to even a notification sound. its any time the speaker would be activated. the  refresh pull down in the twitter app is the best way to test this as you can make the sound over and over.   Once phone is rebooted it goes  away until bluetooth is reconnected.    my girlfriend just got the  regular Moto Z ( none Force) and hers wont do it under the same exact conditions so  it looks like its a Force only issue weirdly enough.  Ive noticed while connected to bluetooth the phone itself does not make the snap sound its only FTER the bluetooth is disconnected and audio is reverted back to the phone speaker.  it will make the snap sound with all voume turned off and it makes it just the first time a the speaker would be activated. so you would ear it only at the first of a song or a video but its annoying  as it happens before all phone sounds so notifications or other phone tones really exaggerate the issue.

 

I called motorola tech support and reported the bug. they hadnt heard of the issue and escalated it to a higher department. they seemed appreciative of the report so after seeing others with the issue maybe they can easily replicate it. because of that  I see no reason in swapping out my phone  only to get another that does the same thing as it seems like an overall software glitch in the Force itself not just a bad phone I happened to unbox.   seems like a patch update is needed.

 

not sure what the cause is but one theory was something maybe with DRM but I dont know enough about that to say one way or the other. not sure how or why that would even affect the speaker.

 

only troubleshooting ive done was a network reset that cleared all the saved bluetooth but that did nothing.  havent tried a factory reset but my guess is its not going to do anything.

 

 


I'll get someone to look at this. Can you post details of the car kits or car make and models?

 

I am not 100% clear on how often the popping sound occurs after the BT disconnect. Is it once, unless you deliberately do the Twitter refresh? Or does it happen all the time until a reboot?

Please do not PM me - if you have issues, search the forums for threads on your topic and post there, or start a new thread. Thanks!
Reply
Options

42 Posts

08-06-2016

United States of America

141 Signins

865 Page Views

  • Posts: 42
  • Registered: ‎08-06-2016
  • Location: United States of America
  • Views: 865
  • Message 8 of 45

Re: Speaker issue

2016-08-08, 17:13 PM

Hi.  ive  done even more investigating and ive now found out  so additional info.   the snap/pop sound will happen the first time sound is played until the reboot  so you can refresh the twitter 100 times and you will get the snap 100 times.

 

 it happens once certain streaming services are used like google play ( the radio stations and the SiriusXM app)   

 

I dont think it has to do with the actual bluetooth device itself as ive  connected to both my Nissan GTR and Nissan Juke but it did it with my totally unrelated Bose standalone speaker.   So I would ivestigate the relationship on the blutooth and the streaming services first since the snap sound once BT disconnects. I think its specifically streaming services like the google music and XM I mentioned.  the  person who started this thread said it did it with Spotify so the patten seems to be streaming music

 

I hope its a simple patch as its very annoying to have to reboot the phone ever time it disconncets to avoid a snap sound before any audio is played.  ive also confirmed the regular Moto Z does not do it under the same conditions  its specifcally the Force

 

hope this info puts you guys on the right track for a fix

Reply
Options

42 Posts

08-06-2016

United States of America

141 Signins

865 Page Views

  • Posts: 42
  • Registered: ‎08-06-2016
  • Location: United States of America
  • Views: 865
  • Message 9 of 45

Re: Speaker issue

2016-08-08, 18:30 PM

here is a video of the snap sound..

 

https://youtu.be/cHZ8jOQTj58

 

 

this is the exact process you do to create it... connect to BT   then  disconnect and it will stay around until a reboot

 

again im just using twitter as an example as it has a refresh sound but the snap is there any time a sound is made on any application or notification.   so at first you will here no snap sound then I connect to BT and quickly stream a song on XM.  once disconnected you will hear the sound even with all volume is turned off ( that is the key no volume is required)

Reply
Options

20125 Posts

02-03-2016

United States of America

2600 Signins

65343 Page Views

  • Posts: 20125
  • Registered: ‎02-03-2016
  • Location: United States of America
  • Views: 65343
  • Message 10 of 45

Re: Speaker issue

2016-08-08, 20:08 PM

wrote:

here is a video of the snap sound..

 

https://youtu.be/cHZ8jOQTj58

 

 

this is the exact process you do to create it... connect to BT   then  disconnect and it will stay around until a reboot

 

again im just using twitter as an example as it has a refresh sound but the snap is there any time a sound is made on any application or notification.   so at first you will here no snap sound then I connect to BT and quickly stream a song on XM.  once disconnected you will hear the sound even with all volume is turned off ( that is the key no volume is required)


Thanks. I can't seem to reproduce it myself. Can you do it with system apps vs. 3rd-party apps?

Please do not PM me - if you have issues, search the forums for threads on your topic and post there, or start a new thread. Thanks!
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms