Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Paper Tape
Posts: 2
Registered: ‎03-20-2017
Location: US
Message 1 of 4 (111 Views)

USB C Headset Problems

I have a cheap 3rd party USB C headset that works fine for my Moto Z (both the headphones and the microphone) but it doesn't work at all for my Moto Z Play. Another pair of USB C headphones (without microphone) works on both the Moto Z and the Moto Z Play. Is the implementation of the USB Audio different between the Z and the Z Play so that when a microphone is included it isn't handled the same? I cannot understand why the headset would work on Z but not the Z Play.

Motorola Admin
Posts: 15,105
Registered: ‎02-03-2016
Location: US
Message 2 of 4 (78 Views)

Re: USB C Headset Problems

Neither can I. Could you say a little more about the failure? No audio from any apps or functions at all, in either ear?

 

If you happen to have the make and model of the two headsets, that would also be helpful. 

 

- Matt

Motorola Admin
Posts: 15,105
Registered: ‎02-03-2016
Location: US
Message 3 of 4 (73 Views)

Re: USB C Headset Problems


MattForumsMngr wrote:

Neither can I. Could you say a little more about the failure? No audio from any apps or functions at all, in either ear?

 

If you happen to have the make and model of the two headsets, that would also be helpful. 

 

- Matt


Ugh -- I'm a dope. Forgot the Play has a 3.5 jack. I'm not sure it was ever intended to allow audio through the USB-C port. I suspect the fact that any USB-C headset works would be considered a bonus. So I will report this, but not sure if this would be considered a bug under the circumstances.

Paper Tape
Posts: 2
Registered: ‎03-20-2017
Location: US
Message 4 of 4 (65 Views)

Re: USB C Headset Problems

That probably explains it. I will try using a USB microphone to see if the microphone by itself is supported.  The cheap USB headset

Top Kudoed Authors