cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Idso
Fanfold Paper
Posts: 11
Registered: ‎01-22-2019
Location: NL
Views: 133
Message 1 of 4

Z2 Play USB not recognised by BMW

I have the "connected drive" service for my BMW X3. It mostly works with Bluetooth, but to get car statistics, etc. I need to connect with a USB connection. However the BMW will not recognise the USB connection of the Z2 Play. I have tried the different setting like MIDI, PTP, but that makes no difference.

 

Anyone have any suggestions ? Are there other settings I need to change on the Z2 Play ?

 

Thanks,

Idso.

Senior MotoAgent
Senior MotoAgent
Posts: 7,185
Registered: ‎03-05-2018
Location: US
Views: 93
Message 2 of 4

Re: Z2 Play USB not recognised by BMW

Hi Idso,

 

Thanks for posting. I'm not familiar with the car statistics, but do you Android Auto app installed on your phone? Have you tried using a different USB transfer cable? 

 

Best regards,
Rich
Motorola-Lenovo Support



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Idso
Fanfold Paper
Posts: 11
Registered: ‎01-22-2019
Location: NL
Views: 55
Message 3 of 4

Re: Z2 Play USB not recognised by BMW

Hi Rich,

 

I use it through the BMW app and not the Android Auto app as that is not supported by this version of the BMW (2012).

Yes, I have used different USB cables, but no diffirence there.

I have tried with BMW support, but they say it is a problem with the phone :-)

 

Thanks,

Idso.

Highlighted
Senior MotoAgent
Senior MotoAgent
Posts: 7,185
Registered: ‎03-05-2018
Location: US
Views: 31
Message 4 of 4

Re: Z2 Play USB not recognised by BMW

Hi Idso,

 

Thanks for further explaining. We checked the BMW website, Motorola isn't even included on the lists of compatibility chart. However, we will ask around and try to make sure of this. 

 

Best regards,
Rich
Motorola-Lenovo Support



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Top Kudoed Authors