cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
lemon389
Fanfold Paper
Posts: 7
Registered: ‎11-24-2016
Location: MX
Views: 1,285
Message 1 of 5

Moto Z: Android Auto do not connect (VW Golf 2016 stock radio)

Hello,

I kindly request your support for this issue. I can not connect my Moto Z (XT-1650-03, Type: M1B90) Android Auto to my VW Golf 2016.
- Stock Android 6.0.1, all related apps including the Play Services up to date.
- No system updates were available for my phone (yet).

I read that this could be a cable issue but I already tried 4 cables without success (including stock cable).

 

Question:
Am I missing something?

 

--------------------------------------------------------------------------

Behaviors:
- The phone is always charging while the cable is connected to the car.
- When the cable is connected, the car and the phone attempt to connect but the connection is broken afterwards. The car displays that the connection is on going and the phone prompts to me the connection type, after some seconds the connection is "broken" before it was finished
- Sometimes after several tries I can see my phone listed in the car for less than a second and then the connection is "broken".
- The default connection for USB is set for MTP in my Moto Z, but, the charging mode is always triggered first when connected.
- My phone came with a cable branded as Motorola which did not worked.

 

Cables:
All cables were Male USB Type A to Male USB Type C.
1. Moto Z Stock Cable:
The connection is started but never finished, the phone and the car keep trying to connect while the cable is connected.
2. Belkin USB-IF Certified 2.0: Same as the Moto Z stock cable. Bought from amazon:
https://www.amazon.com/gp/product/B00WJSPFOW/ref=oh_aui_detailpage_o05_s00?ie=UTF8&psc=1
3. Generic 'White' Cable: No connection at all.
4. Generic 'Black' Cable:
Similar to Moto Z stock and Belkin cable, the only difference is that this cable sometimes the connection was finished and the Moto Z was listed in the car phone list for a brief moment (~1 second).

All the cables are 3 Feet lenght but the Belkin which was 6 Feet lenght.

 

Additional Information:
I purchased the Moto Z one week ago, before this phone I had a Moto X 2nd (XT-1097) which was working correctly with my car. I tried several micro USB cables for the Moto X without any problem (stock and other brands).
Using the same car and my Moto X 2nd I tried two android versions:
- Stock Lollipop 5.x, worked OK but the contact pictures were not synced.
- Custom CM14.1 Nougat 7.1, worked OK (contact pictures synced correctly).

lemon389
Fanfold Paper
Posts: 7
Registered: ‎11-24-2016
Location: MX
Views: 1,228
Message 2 of 5

Re: Moto Z: Android Auto do not connect (VW Golf 2016 stock radio)

Any ideas?

My phone updated  to Android 7.0 yesterday but I have the same described behaviour.

lemon389
Fanfold Paper
Posts: 7
Registered: ‎11-24-2016
Location: MX
Views: 1,217
Message 3 of 5

Re: Moto Z: Android Auto do not connect (VW Golf 2016 stock radio)

Hello guys,

 

I already performed a factory reset with android 7.0 and I have the same issues, I followed the instructions from here:

https://motorola-global-portal.custhelp.com/app/answers/detail/a_id/112157

 

Two resets were performed, one via the android interface and the second one with the recovery.

My account details was skipped during the startup and I force a new configuration from zero; I logged in afterwards and installed android auto only. The car was also reset to its factory configurations and afterwards the phone was connected with the Motorola Cable but it did not work.

 

 

Additional Notes:

- In my phone I can see an upcoming notification about the car connection and then it disappears. This notification flashes every ~5 seconds.
- I can connect my phone with the PC and connect it as MTP to copying files and the connection is never lost (using the same cables).

- I read in many forums that the LG L4 had some issues too and it was related to the phone, not the car itself.

Since this issue is not repro with my Moto X I think a bug could be present or some configuration is missing.

- Stock Motorola cable is :"Designed by Motorola SKN6473A 16236 1126272"

 

lemon389
Fanfold Paper
Posts: 7
Registered: ‎11-24-2016
Location: MX
Views: 1,215
Message 4 of 5

Re: Moto Z: Android Auto do not connect (VW Golf 2016 stock radio)

Question?

Did I missed something? I noticed that my post is the only one without replies... 

 

I already looked into these forums and could not find similar issues (the piooner one was different), also, I could not find useful information for this topic in the FAQs or other links given.

lemon389
Fanfold Paper
Posts: 7
Registered: ‎11-24-2016
Location: MX
Views: 1,157
Message 5 of 5

Re: Moto Z: Android Auto do not connect (VW Golf 2016 stock radio)

Hello all,

 

If you are reading this I just wanted to share my experiencie with Lenovo/Motorola:

 

1. If you have an issue don't always expect Lenovo/Motorola to support you from the forums.

2. If you call to the warranty call center they will tell you that these forums are for the users only, they are not related to them, so, I suggest other forums like XDA.

 

3. The  most important thing:

In the warranty center (via phone) they will tell you that is your problem and that the issue is out of warranty.

Example: If the phone box do not have in an specific way X functionality, then, they are not responsible for that...

The box do not states that the phone works with Android Auto, then the phone should not work with android auto...

 

At least thats my experience with Lenovo/Motorola Mexico, if you buy something your are screwed! so, hope it works right out the box.

 

Welcome to our mexican warranty supports!

 

Top Kudoed Authors