cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Kry00
Punch Card
Posts: 17
Registered: ‎01-01-2018
Location: PL
Views: 715
Message 1 of 22

Problem with devices connected by Wifi.

Hello, 

I have a problem with my sport camera, dashcam and endoscope. All of them are connecting by Wifi, but when i'm connecting them i see "Connected, no internet" in details of the device on Wifi list.

Device is not working, until i turn off cell data transmission.  It's very annoying.

Anyone know what is the reason? It was happening on android 7.0, and also now after update to 8.0.

Senior MotoAgent
Senior MotoAgent
Posts: 5,397
Registered: ‎07-12-2014
Location: US
Views: 657
Message 2 of 22

Re: Problem with devices connected by Wifi.

Hi Kry00,

 

Thanks for reaching out to us. We are ready to help here, we just want a few more information. When you connect the auxiliary devices (sportcam, dashcam, endoscope) to your Moto Z, which one is not working? What exactly happens when they are connected to your phone?

 

Regards,
JM
Motorola Support

**Please don't ask me questions by Personal Message; questions belong in the forums.

Kry00
Punch Card
Posts: 17
Registered: ‎01-01-2018
Location: PL
Views: 640
Message 3 of 22

Re: Problem with devices connected by Wifi.

When i'm try to use one of this items, i have to connect them to the phone via WiFi. After connection i see information that "device is connected, but there is no internet connection". I have all the time turned on internet from my mobile, but after connection this device internet is not working (even if mobile internet is turned on). When i want to use app to use for example camera (it doesn't matter which app: from Xiaomi, from Navitel etc) device is not connecting to the app. When i turn off mobile internet everything is perfect. It's connecting very quick etc. It seems that Moto Z don't know what to do when will connect to device via Wifi which don't have internet connection.

Phone should connect to for example camera, check if it has internet, if not, connect to mobile internet. It's easy to solve.

 

I'm reading now that is problem with many Moto users. My old phones (Samsung and Meizu) didn't had this problem, everything was working great. 

Senior MotoAgent
Senior MotoAgent
Posts: 5,574
Registered: ‎03-05-2018
Location: US
Views: 599
Message 4 of 22

Re: Problem with devices connected by Wifi.

Hi Kry00,

 

Thanks for trying to connect it with cellular data instead, it looks like an issue with the WiFi. If the internet is not working on all the devices connected to the WiFi network, then chances are there is a problem with your router, try resetting your wifi router. Let's reset your network settings too (Settings > Reset > Network Setting Reset) - It will reset all your connected devices in Bluetooth and WFi, so you need to re-enter your wifi password and re-pair the Bluetooth devices you're previously connected with. 

 

Best regards,
Rich
Motorola Support

Kry00
Punch Card
Posts: 17
Registered: ‎01-01-2018
Location: PL
Views: 585
Message 5 of 22

Re: Problem with devices connected by Wifi.

Ok let this clear- 

Moto Z connected by WiFi with the device (for example camera), cellular data ON -> opening device app, app see device and connecting (on wifi list i can see

"device name - connected, no internet connection") and nothing happening. Apps connecting but can't connect.

When I'm turning off cellular data during this connection try, app is connecting to device imidiatelly and is working great.

 

Problem is with all devices connecting by WiFi.

 

My wife has also Moto Z and on her phone it's the same (she still has android 7.0, and I 8.0). It's obvious software problem. Please help, otherwise I have to send phone to Motorola for warranty repair because it's not normal phone behaviour.

Senior MotoAgent
Senior MotoAgent
Posts: 5,574
Registered: ‎03-05-2018
Location: US
Views: 547
Message 6 of 22

Re: Problem with devices connected by Wifi.

Hi Kry00,

 

Thanks for explaining. I wouldn't say for sure that this cause by the update. Have you tried connecting your device to another Wifi, like a public hotspot to see if you'll have the same error message? Let me know, thanks.

 

Best regards,
Rich
Motorola Support

Kry00
Punch Card
Posts: 17
Registered: ‎01-01-2018
Location: PL
Views: 536
Message 7 of 22

Re: Problem with devices connected by Wifi.

I don't see this message when I'm connecting to routers/hotspots which have internet connection. Problem is with connecting via WiFi to any devices which don't have internet connection but sending to phone data (for example camera) via WiFi.

Hard resets and any other resets are not helping. I read that this is problem of many users with Moto phone.

 

How it's possible that Motorola can't solve such a big problem with software. 

Senior MotoAgent
Senior MotoAgent
Posts: 5,574
Registered: ‎03-05-2018
Location: US
Views: 529
Message 8 of 22

Re: Problem with devices connected by Wifi.

Hi Kry00,

 

Thanks for the reply, I'm not sure if I understand you correctly, you clarified that you can connect to a wifi with an internet connection, but your phone can also connect to a wifi which doesn't have an internet? 

 

Best regards,
Rich
Motorola Support

Kry00
Punch Card
Posts: 17
Registered: ‎01-01-2018
Location: PL
Views: 524
Message 9 of 22

Re: Problem with devices connected by Wifi.

Xiaomi Yi 4k is connecting with phone via Wifi. Camera don't have internet connection, so when mobile will connect to camera, it can't have internet connection. It's obvious. On Moto I can see in WiFi setup "connected, no internet connection", but on other phones there is "connected" and mobile can connect to device (in this case camera). Moto Z is connecting only when I turn off mobile internet.

This is just an example, it's happening with all devices connected by WiFi. They are connecting only when i turn off mobile internet. 

Senior MotoAgent
Senior MotoAgent
Posts: 5,574
Registered: ‎03-05-2018
Location: US
Views: 491
Message 10 of 22

Re: Problem with devices connected by Wifi.

Hi Kry00,

 

Thanks for explaining, are you only having internet with WiFi when you turned off the mobile data? 

 

Best regards,
Rich
Motorola Support

Top Kudoed Authors