Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto Z Phones - Mod CapableMoto Z
All Forum Topics
Options

84 Posts

09-18-2017

Poland

206 Signins

888 Page Views

  • Posts: 84
  • Registered: ‎09-18-2017
  • Location: Poland
  • Views: 888
  • Message 1 of 16

Warranty service - quality andy my feedback

2018-01-08, 18:14 PM

Hi Folks,

 

I just got my phone from warranty service (poor battery life).

I sent phone with perfect screen - always protected by foil, I don't like any scratches etc on screen, it just annoys me so I can change this glass every 2-3 months to have it in good condition. There were some small scratches on alloy frame, made when using attached bumper (some small particles got between) but still nothing on screen.

Except battery and few related parts my phone had screen and front camera replaced - don't know why, but don't care untill it's not worse than I had.

And here comes my problem - phone came wrapped with some plastic (see picture) and there is a scratch on screen around 4cm long (see part of it above lamp on photo). I don't get how it's possible to do such "upgrade" when my screen was ok? Can I have it back as it was sent for WARRANTY repair?

Tom
Reply
Options

84 Posts

09-18-2017

Poland

206 Signins

888 Page Views

  • Posts: 84
  • Registered: ‎09-18-2017
  • Location: Poland
  • Views: 888
  • Message 2 of 16

Re: Warranty service - quality andy my feedback

2018-01-10, 19:01 PM

I've left this phone on charger since yesterday and today BT does not work.

Fortunately needed a restart to enable it, but does not look promising after two warranty repairs...

Tom
Reply
Options

84 Posts

09-18-2017

Poland

206 Signins

888 Page Views

  • Posts: 84
  • Registered: ‎09-18-2017
  • Location: Poland
  • Views: 888
  • Message 3 of 16

Re: Warranty service - quality andy my feedback

2018-01-10, 21:16 PM

It stopped working again - cleared cache in recovery and BT was enabled after boot.

I've tried to pair Fossil Q watch with Moto and encountered problems. I put several devices into discovery mode and found nothing on Moto...

So here is screenshot which devices are visible by Lenovo Tab (Left) ant Moto Z (right).

Who can spot a difference?

Small hint - this phone just got back from warranty service and Lenovo?Motorola quality check!

Tom
Reply
Options

28 Posts

11-12-2017

South Africa

48 Signins

410 Page Views

  • Posts: 28
  • Registered: ‎11-12-2017
  • Location: South Africa
  • Views: 410
  • Message 4 of 16

Re: Warranty service - quality andy my feedback

2018-01-13, 0:23 AM

Hi,

 

What version of Android does your device currently have?

 

I have a similar situation where my bluetooth has suddenly stopped working, and i am suspecting it is one of the recent software updates that seems to have caused this issue.  I am currently on 7.1.1 with the December update, and i feel it may have been caused by the October or November security update.

 

Thanks,

Regards,

Saajid

Reply
Options

84 Posts

09-18-2017

Poland

206 Signins

888 Page Views

  • Posts: 84
  • Registered: ‎09-18-2017
  • Location: Poland
  • Views: 888
  • Message 5 of 16

Re: Warranty service - quality andy my feedback

2018-01-13, 9:44 AM

I have latest update.
Interresting is that after factory reset without logging to google account BT works well - I was able to send 430MB file from my laptop without issues. But phone is usseless without all the services.
But when I log in to google account, even without enabling app backups etc after a while BT will not see any devices and MotoZ is not visible by other devices. If I switch BT off then it cannot be enabled.

Sometimes BT works for a while after reboot or clear cache but generally same story.

If i perform factory reset and skip all without putting gmail data it will work perfectly.

 

I called support, they asked technician about it and he said that this issue was already resolved by SW update, I shall go through troubleshooting steps from Moto website and if it will not help I shall send phone for repair (again). Support was really nice, I even asked about oreo test builds but they don't know anything and oreo shall be everywhere not later than July (probably latest step of distribution).

Tom
Reply
Options

28 Posts

11-12-2017

South Africa

48 Signins

410 Page Views

  • Posts: 28
  • Registered: ‎11-12-2017
  • Location: South Africa
  • Views: 410
  • Message 6 of 16

Re: Warranty service - quality andy my feedback

2018-01-13, 11:28 AM
Thats odd...my device the bluetooth didnt even work after the factory reset (tested it first before setting up Google Play etc), network reset, and all other troubleshooting steps.
Didn't even work when i booted android into safe mode.

Right now, i have tried everything...and only option left is waiting for Oreo, which hopefully comes soon to see if that resolves the issue. If not, then i will need to book the device with customer service to get this resolved.

Hoping Oreo is sooner as the soak tests where apparently in December.
Reply
Options

84 Posts

09-18-2017

Poland

206 Signins

888 Page Views

  • Posts: 84
  • Registered: ‎09-18-2017
  • Location: Poland
  • Views: 888
  • Message 7 of 16

Re: Warranty service - quality andy my feedback

2018-01-13, 11:31 AM

In this case don't wait for Oreo, just send it for repair. My case could be a SW issue, I but yours is not - I had this problem after purchase of moto and service center fixed it.

Tom
Reply
Options

28 Posts

11-12-2017

South Africa

48 Signins

410 Page Views

  • Posts: 28
  • Registered: ‎11-12-2017
  • Location: South Africa
  • Views: 410
  • Message 8 of 16

Re: Warranty service - quality andy my feedback

2018-01-13, 11:35 AM
I am considering that now...once i get a response from the service agents here in my country.

Bluetooth worked fine until one of the software updates...i even booted up to the factory mode, ran the CQAtest app and it crashes on Bluetooth...so not sure what to make of that.
Reply
Options

84 Posts

09-18-2017

Poland

206 Signins

888 Page Views

  • Posts: 84
  • Registered: ‎09-18-2017
  • Location: Poland
  • Views: 888
  • Message 9 of 16

Re: Warranty service - quality andy my feedback

2018-01-13, 11:44 AM

This is more like hw issue, I do not hesitate to send it. 

I will try safe mode test maybe today - did factory reset 7th time in last 3 days.

Generally needed to do factory reset over 50 times since purchase :(

Tom
Reply
Options

4 Posts

01-15-2018

United Kingdom of Great Britain and Northern Ireland

9 Signins

46 Page Views

  • Posts: 4
  • Registered: ‎01-15-2018
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 46
  • Message 10 of 16

Re: Warranty service - quality andy my feedback

2018-01-15, 22:34 PM
Hi I had the same problem with my phone, in as much as the back was scratched, and the camera lens was also scratche, i would recomend that you check the ime znumber is the same as the one you sent off, as they just refurbished an old phone, aften i complained vigoursly they send me a new phone, saying it was policy to send an old refurbished phone
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms