cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
macsxxx
Paper Tape
Posts: 2
Registered: ‎11-13-2016
Location: IR
Views: 7,277
Message 1 of 12

incipio offgrid power pack not charging

so i bought the power pack a couple of days ago and it was fine when i attached it to the phone and charged the phone normally but i didnt try to charge it so i dont know how it was then, so today i after i attached it to the  phone it didnt charge it and battery efficiency option is gone and althugh im using the motorola charger it came with the power pack isnt charging even after the phone getting to 100%, i tried holding the power pack battery indicatior button to reset it but after nearly 10 seconds a red light blinks once. does anyone know whats up?

Senior MotoAgent
Senior MotoAgent
Posts: 3,431
Registered: ‎10-05-2016
Location: PH
Views: 7,209
Message 2 of 12

Re: incipio offgrid power pack not charging


@macsxxx wrote:

so i bought the power pack a couple of days ago and it was fine when i attached it to the phone and charged the phone normally but i didnt try to charge it so i dont know how it was then, so today i after i attached it to the  phone it didnt charge it and battery efficiency option is gone and althugh im using the motorola charger it came with the power pack isnt charging even after the phone getting to 100%, i tried holding the power pack battery indicatior button to reset it but after nearly 10 seconds a red light blinks once. does anyone know whats up?


Hi macsxxx,

 

Have you tried to check through Settings if the mod is being charged? Go to Settings then look for Moto Mods. This will tell you if the mod is being charged. See FAQ to know more about this mod.

 

Regards,
Jess
Motorola Support

macsxxx
Paper Tape
Posts: 2
Registered: ‎11-13-2016
Location: IR
Views: 7,176
Message 3 of 12

Re: incipio offgrid power pack not charging

the only thing i see in moto mods is "incipio offGRID power pack connected" and about this mod which doesnt have any thing listed as the mod being charged
Senior MotoAgent
Senior MotoAgent
Posts: 3,431
Registered: ‎10-05-2016
Location: PH
Views: 7,148
Message 4 of 12

Re: incipio offgrid power pack not charging


@macsxxx wrote:
the only thing i see in moto mods is "incipio offGRID power pack connected" and about this mod which doesnt have any thing listed as the mod being charged

Hi macsxxx,

 

Based on the FAQ, if your phone is the Moto Z, it charge as:

Moto Z using Turbo Charger: Both the phone and Moto Mod are charged at the same time.

Moto Z using standard charger: The phone will charge to 100%.  Once the phone reaches 100% charge, the Mod will start to charge.

Moto Z Force using Turbo Charger: The phone will charge to approximately 80%.  Then, the charge will be split between phone and Moto Mod.

Moto Z Force using standard charger: The phone will charge to 100%.  Once the phone reaches 100% charge, the Mod will start to charge.

 

So, if your phone is Moto Z using the turbocharger that came with the phone, the mod will be charged at the same time with the phone. See this link on how to get there on Mod's Settings.

 

Regards,
Jess
Motorola Support

 

 

 

 

 

kkula9999
What's DOS?
Posts: 1
Registered: ‎12-07-2016
Location: HK
Views: 7,073
Message 5 of 12

Re: incipio offgrid power pack not charging

what about moto z play?

coz when I charge with normal charger, even phone charged to 100%, the moto battery mod still not going to charge, it status " waiting for charge"

KT-2109
What's DOS?
Posts: 1
Registered: ‎11-28-2017
Location: US
Views: 4,628
Message 6 of 12

Re: incipio offgrid power pack not charging

Not sure if you got an answer/solution . Here's what did it for me. I have the moto z force with the Incipio power pack mod (bought a week ago). I was getting the "waiting to charge" message.  The Motorola supplied TurboCharger 30W wall charger wouldn't charge the battery mod. Today, I connected the power pack, reset the mod, turned off the phone, plugged the charger up, and now I see two charging circles (one for phone, one for mod) when i tap the power button. Once both circles were fully charged, I turned on the phone and it says the mod is at 100%. Nothing in the instructions said to turn the phone off to charge the mod. Anyway, I hope this helps someone.

Tahazeina
Punch Card
Posts: 9
Registered: ‎01-20-2018
Location: US
Views: 4,004
Message 7 of 12

Re: incipio offgrid power pack not charging

Hello I have Moto Z and the Incipio power. It was charging before with phone with the type c charger which come with box but now I don't know the reason the Incipio doesn't charge !! Could you please advise?
Tahazeina
Punch Card
Posts: 9
Registered: ‎01-20-2018
Location: US
Views: 4,003
Message 8 of 12

Re: incipio offgrid power pack not charging

 
Tahazeina
Punch Card
Posts: 9
Registered: ‎01-20-2018
Location: US
Views: 4,003
Message 9 of 12

Re: incipio offgrid power pack not charging

Is there any way to formate or install new sw for the Incipio power. I can see it on the settings for the mods with 0% power even it is connected to the charger so it doesn't charge ?

Trent_Meier
Paper Tape
Posts: 1
Registered: ‎02-08-2018
Location: US
Views: 3,728
Message 10 of 12

I have a morphie power pack also not charginh

Have a morphie power pack for my Moto z. It won't charge connected to the phone. Also tried off the phone to charge, Its charging lights come on showing that it's charging but putting it back on the phone and there's no charge. Shows it's connected but nothing else. 

Top Kudoed Authors