cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ajayw6
Paper Tape
Posts: 1
Registered: ‎07-03-2012
Location: India
Views: 586
Message 11 of 18

Re: Moto Z3 play + Moto Power pack disconnecting multiple times while charging

Hi,

 

I am also facing the same issue for more than a month. I amnusing moto z2 play. What should I do?

Msi242
What's DOS?
Posts: 1
Registered: ‎05-26-2019
Location: US
Views: 564
Message 12 of 18

Re: Moto Z3 play + Moto Power pack disconnecting multiple times while charging

I'm having the same issue on my Z2 Force. Thought it was a connection issue with my phone but it looks like i'm not alone here.

 

Any help is appreciated! 

elblat
What's DOS?
Posts: 1
Registered: ‎06-09-2019
Location: US
Views: 520
Message 13 of 18

Re: Moto Z3 play + Moto Power pack disconnecting multiple times while charging

This happens to both my wife and I, she with a Z2 play and me with a Z3. We both have the moto Turbo Power Pack. When the problem happens, it makes a loud sound and vibrates in the middle of the night.

Highlighted
KatieC
Ctrl-Alt-Del
Posts: 26
Registered: ‎05-26-2012
Location: US
Views: 484
Message 14 of 18

Re: Moto Z3 play + Moto Power pack disconnecting multiple times while charging

Motorola replaced the battery. IMO it is cheaper to RMA a battery than a phone + have an unsatisfied customer. since i got the new battery i had zero problems. all issues decribed above were resolved. yes the process was hard... 2 phone calls, and multiple escalation here but eventually i got a new battery
jdrought0916
What's DOS?
Posts: 1
Registered: ‎06-17-2019
Location: US
Views: 473
Message 15 of 18

Re: Moto Z3 play + Moto Power pack disconnecting multiple times while charging

So it was the battery in your actual phone which was kicking the mod on/off while charging?  

KatieC
Ctrl-Alt-Del
Posts: 26
Registered: ‎05-26-2012
Location: US
Views: 419
Message 16 of 18

Re: Moto Z3 play + Moto Power pack disconnecting multiple times while charging

since issue got resolved with a new battery, yes it was the battery and not the phone. for anyone that finds this post, note that when i had the issue, the reconnection would happen also with the phone turned off completely. of course there would be no noise since the phone was off but you can see a circle with the battery charge level and a second smaller circle for the external battery level. you could see how the 2nd circle will appear and dissapear. this is what pointed me more to a HW problem than a SW problem.
ccliving
Paper Tape
Posts: 2
Registered: ‎08-21-2019
Location: US
Views: 293
Message 17 of 18

Re: Moto Z3 play + Moto Power pack disconnecting multiple times while charging

How do I get this fixed on my phone as well? I ran the debug and took the screenshots. This is my first time in these forums and I don't know what to do next to report this problem.

ccliving
Paper Tape
Posts: 2
Registered: ‎08-21-2019
Location: US
Views: 293
Message 18 of 18

Re: Moto Z3 play + Moto Power pack disconnecting multiple times while charging

I'm having this problem as well. Please let me know how to get this dealt with. I have figured out the developer tools part  and taken screen shots. This is really annoying. I bought the battery mod from Motorola directly.

Top Kudoed Authors