Motorola Community

Moto Z Phones - Mod CapableMoto Z3
All Forum Topics
Options

7 Posts

04-09-2019

US

7 Signins

90 Page Views

  • Posts: 7
  • Registered: ‎04-09-2019
  • Location: US
  • Views: 90
  • Message 1 of 9

Moto Power pack constantly reconnecting

2019-04-09, 18:17 PM

I have a Moto Z3 with the Moto Power Pack, and when I charge the phone with the pack connected, it charges to 48% and the the mod continuously reconnects.  It still charges the battery, but it buzzes and beeps contantly.  It's pretty annoying in the middle of the night.  It will occasionally happen while I'm using the phone with the mod connected and it pretty much prevents me from being able to do anything else with the phone.

 

Anyone else have this issue or have a solution?

Reply
Options

7 Posts

04-09-2019

US

7 Signins

90 Page Views

  • Posts: 7
  • Registered: ‎04-09-2019
  • Location: US
  • Views: 90
  • Message 2 of 9

Re: Moto Power pack constantly reconnecting

2019-04-09, 18:20 PM
Sorry, we both have Verizon
Reply
Options

1629 Posts

03-11-2019

US

562 Signins

39745 Page Views

  • Posts: 1629
  • Registered: ‎03-11-2019
  • Location: US
  • Views: 39745
  • Message 3 of 9

Re: Moto Power pack constantly reconnecting

2019-04-10, 18:29 PM

Hi ohm529,

 

Thank you for posting. Have you checked if the Moto Mod is up to date? While the mod is attached and go to Settings > Moto Mod > System Update. Please let me know how it goes. 

 

Best regards,
Zeke
Motorola Support

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

7 Posts

04-09-2019

US

7 Signins

90 Page Views

  • Posts: 7
  • Registered: ‎04-09-2019
  • Location: US
  • Views: 90
  • Message 4 of 9

Re: Moto Power pack constantly reconnecting

2019-04-10, 18:39 PM

The mod is up to date and the phone just updated to Pie this morning

Reply
Options

1629 Posts

03-11-2019

US

562 Signins

39745 Page Views

  • Posts: 1629
  • Registered: ‎03-11-2019
  • Location: US
  • Views: 39745
  • Message 5 of 9

Re: Moto Power pack constantly reconnecting

2019-04-10, 19:03 PM

I recommend resetting the mod by going to Settings > Moto Mod > Reset. Have you tried other mods and check if the mod would still have reconnecting issues? 

 

Best regards,
Zeke
Motorola Support



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

7 Posts

04-09-2019

US

7 Signins

90 Page Views

  • Posts: 7
  • Registered: ‎04-09-2019
  • Location: US
  • Views: 90
  • Message 6 of 9

Re: Moto Power pack constantly reconnecting

2019-04-10, 20:11 PM

I've reset it many times to no avail. I've also restarted my phone severl times with no affect.  Sometimes I'm able to make it stop by removing the mod, running my fingers on the pogo pins, and reattaching.  Sometimes...

 

I would love to try with a different mod, but Motorolla doesn't currently have any of the mods I'm interested in buying availble.  They haven't been available since I bought the phone in November.

Reply
Options

1629 Posts

03-11-2019

US

562 Signins

39745 Page Views

  • Posts: 1629
  • Registered: ‎03-11-2019
  • Location: US
  • Views: 39745
  • Message 7 of 9

Re: Moto Power pack constantly reconnecting

2019-04-11, 20:30 PM

Hi ohm529,

 

I recommend processing a replacement/repair for your moto mod since you have already had it reset.  You can start by going to this link here.

 

Best regards,
Zeke
Motorola Support

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

28 Posts

08-26-2018

US

27 Signins

235 Page Views

  • Posts: 28
  • Registered: ‎08-26-2018
  • Location: US
  • Views: 235
  • Message 8 of 9

Re: Moto Power pack constantly reconnecting

2019-04-25, 22:00 PM

I think this is a general bug in the Z series charging logic. My Z2 will randomly flash that the Turbo charger is connected or disconnected even when no cable is plugged in but sometimes when it is. I just get Toast over and over and can't use that part of the screen for a while until it decides that it is finished.

Reply
Options

57 Posts

03-31-2012

US

77 Signins

810 Page Views

  • Posts: 57
  • Registered: ‎03-31-2012
  • Location: US
  • Views: 810
  • Message 9 of 9

Re: Moto Power pack constantly reconnecting

2019-04-30, 13:43 PM

I've noticed that my Moto Turbo Power Pack is slightly off in fitment, leading me to get this connect/disconnect issue.  

 

I added a small piece of electrical tape around the camera hole to tighten the fit.  It's inelegant, but it works for now.

 

It is odd though - "third party" mods seem to fit better than the Moto branded one.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete