Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto Z Phones - Mod CapableMoto Z3
All Forum Topics
Options

5 Posts

07-17-2019

United States of America

6 Signins

87 Page Views

  • Posts: 5
  • Registered: ‎07-17-2019
  • Location: United States of America
  • Views: 87
  • Message 21 of 47

Re: Bluetooth Audio Connection Issue With Phone After Android Pie Update

2019-07-17, 2:56 AM

 wrote:

I'm having the same issue as Shaun 80.

I have a 2017 TriGlide with the boom 6.5.

It worked fine until the update and now it will not display song or artist. It just says unknown. If I restart my phone while it's connected over blue tooth it will display song and artist but as soon as I shut the bike off or turn Bluetooth off and try and reconnect it goes back to unknown. Harley techs checked out the radio and it works fine. Every other phone we've connected to it functions properly. Seems to be isolated to z3.


also the moto G7 power.  

Reply
Options

9 Posts

04-26-2019

United States of America

17 Signins

109 Page Views

  • Posts: 9
  • Registered: ‎04-26-2019
  • Location: United States of America
  • Views: 109
  • Message 22 of 47

Re: Bluetooth Audio Connection Issue With Phone After Android Pie Update

2019-07-17, 11:37 AM

It's not isolated to just z3 I recently up graded to z4 and have the same issue I use my work iPhone xr with no issue and my older z2 with no syncing issue 

 

Reply
Options

6 Posts

06-15-2019

United States of America

14 Signins

87 Page Views

  • Posts: 6
  • Registered: ‎06-15-2019
  • Location: United States of America
  • Views: 87
  • Message 23 of 47

Re: Bluetooth Audio Connection Issue With Phone After Android Pie Update

2019-09-22, 22:24 PM

Well glad I read your reply, I was going to upgrade to see if it would fix the issue. Obviously Lenovo doesn't want to reply to this issue. Harley had no clue, neither does Verizon.

Reply
Options

2 Posts

10-12-2019

United States of America

1 Signins

26 Page Views

  • Posts: 2
  • Registered: ‎10-12-2019
  • Location: United States of America
  • Views: 26
  • Message 24 of 47

Re: Bluetooth Audio Connection Issue With Phone After Android Pie Update

2019-10-12, 15:21 PM
Have you been able to resolve this problem. I'm having the same problem with my 2015 Road Glide. Spent a lot of money at the dealership to find out it's my phone. Had Verizon send me a new phone and same problem.
Reply
Options

2 Posts

10-12-2019

United States of America

1 Signins

26 Page Views

  • Posts: 2
  • Registered: ‎10-12-2019
  • Location: United States of America
  • Views: 26
  • Message 25 of 47

Re: Bluetooth Audio Connection Issue With Phone After Android Pie Update

2019-10-12, 15:27 PM

I am having the same issue as the others on this forum with the Harley boom audio spent quite a bit at the dealership to find out it's my phone. Is there going to be a fix for this. Kinda defeats the reason for having a hands free device and smart phone.

Reply
Options

9 Posts

04-26-2019

United States of America

17 Signins

109 Page Views

  • Posts: 9
  • Registered: ‎04-26-2019
  • Location: United States of America
  • Views: 109
  • Message 26 of 47

Re: Bluetooth Audio Connection Issue With Phone After Android Pie Update

2019-10-12, 19:50 PM

Only work around I have found that didn't even work all the time is I will start a secondary app like slacker radio .and switch to Spotify wile slacker is running and  in the middle of playing a song my controls stay working. But some times I have to re sync with slacker a few times to get it to work properly.  My work Iphone has no issues it's definitely a Motorola Bluetooth issue I have a z2 no issues my z3 and z4 Same issues won't sync Spotify at all untill another app starts and the other program has to have a perfect scenerio to start . 

Reply
Options

6 Posts

10-21-2019

United States of America

20 Signins

122 Page Views

  • Posts: 6
  • Registered: ‎10-21-2019
  • Location: United States of America
  • Views: 122
  • Message 27 of 47

Re: Bluetooth Audio Connection Issue With Phone After Android Pie Update

2019-10-21, 17:58 PM

 wrote:

The symptoms are when pairing bluetooth I loose all track data on radio screen of music  and can't control track skip ,pause or play like I could before the 9 pie update.   first I have done factory reset of phone erased all Bluetooth settings on radio .tryed to repair I could get it to sync perfect but once you cycled power of vehicle ,or turn Bluetooth fuction off it would not sync properly again.unless you factory reset everything and start over .also have tryed upgrading software on radio Wich was released last month. Also have received new phone from Verizon same issue. But if I connect my older motorol z2 with Android 8 on it no problems .I have also tried ever variation of setting for Bluetooth under developer . I even matches settings that are on my old phone . It worked up till I put Android 9 pie in .I have also noticed some times when I pair devices a bluetooth peer notification comes on bar saying  "some function will be activated after repairing ." I have also tried only running media function with phone function turned off .


Any updates or solution about this? I recently changed phones from a Moto Z to Moto Z3 Play and am experiencing the EXACT SAME ISSUE as described above with the Moto Z3 Play. I tested on 3 different car bluetooth systems with the exact same result.  

 

_pav 

Reply
Options

6 Posts

10-21-2019

United States of America

20 Signins

122 Page Views

  • Posts: 6
  • Registered: ‎10-21-2019
  • Location: United States of America
  • Views: 122
  • Message 28 of 47

Re: Bluetooth Audio Connection Issue With Phone After Android Pie Update

2019-10-21, 21:32 PM

Shortly after posting my reply in this thread (see above), I was able to reproduce the problem on both a Moto X4 and a Moto Z3 Play - both running Android 9. The issue is reproduceable with the Spotify app  where track info and control  interfaces are unsupported. Judging by the other report of a Moto G7 Plus experiencing the same issue, it would imply the problem is with the Spotify app AND any Motorola phone running Android 9. It isn't clear as to whether it's a low-level driver problem or just the app, but I would ask anyone from Motorola reading this to verify the issue.

 

_pav

Reply
Options

6 Posts

06-15-2019

United States of America

14 Signins

87 Page Views

  • Posts: 6
  • Registered: ‎06-15-2019
  • Location: United States of America
  • Views: 87
  • Message 29 of 47

Re: Bluetooth Audio Connection Issue With Phone After Android Pie Update

2019-10-21, 21:37 PM

I don't use Spotify, it doesn't show artist or song with Pandora either so doubt it's a problem with the app.

Reply
Options

6 Posts

10-21-2019

United States of America

20 Signins

122 Page Views

  • Posts: 6
  • Registered: ‎10-21-2019
  • Location: United States of America
  • Views: 122
  • Message 30 of 47

Re: Bluetooth Audio Connection Issue With Phone After Android Pie Update

2019-10-21, 22:36 PM

 wrote:

I don't use Spotify, it doesn't show artist or song with Pandora either so doubt it's a problem with the app.


 

I was able to confirm that bluetooth data & control works with Google Play music but does not with Spotify on Z3 Play & Moto X4 running Android 9.  If the data/control problem is also occurring with Pandora, it points to a potential issue with app interfaces & the Android 9 Motorola bluetooth driver.

 

The reports here are coming from multiple Motorola owners running Android 9 on  Z3, Z3 Play, Moto X4, G7 Plus and Z4.

 

Hopefully someone at Motorola is watching this thread and will flag it with engineering team.

 

_pav

 

 ***UPDATE***

It seems that this problem has been reported by another Moto X4 user on the Spotify help forum here and also by Samsung users.

"Samsung" fix recommended by "Spotify":

         1.  Clear all Spotify app data in Android system Settings

         2. Uninstall Spotify

         3. Reinstall Spotify

         4. Disable all "Car view" options in Spotify settings

         5. Disable "battery optimization" in the Android system Settings menu.

 

I tried these steps with my Moto X4 and Moto Z3 Play.  It didn't fix the problem, but perhaps other forum users may want to give this a try.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms