Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto Z Phones - Mod CapableMoto Z² Play
All Forum Topics
Options

44 Posts

01-06-2011

Poland

41 Signins

530 Page Views

  • Posts: 44
  • Registered: ‎01-06-2011
  • Location: Poland
  • Views: 530
  • Message 1 of 5

Camera laggy on my Z2 Play

2019-01-23, 11:55 AM

Hi,

 

I've noticed that recently when I tried to take some photos with Hasselblad, it's basically... unusable.

The camera application is generally very laggy after some latest updates of the phone.

There is some delay between the press of shutter button and the moment the actual photo is taken.

Effectively this makes photos blurred, or composed incorrectly - in the photo there is slightly another scene than the one I wanted to take.

Additionally, photos seem to be washed out of colours.

 

Initially I thought that maybe it's just the Hasselblad fault, but no, the effect is quite similar with built - in camera.

I've tried factory reset, and all the other common troubleshooting steps - no change.

 

Is there any fix planned maybe ?

Reply
Options

44 Posts

01-06-2011

Poland

41 Signins

530 Page Views

  • Posts: 44
  • Registered: ‎01-06-2011
  • Location: Poland
  • Views: 530
  • Message 2 of 5

Re: Camera laggy on my Z2 Play

2019-01-27, 22:38 PM
Hey, Moto Support - wake up !

That was just a simple question - is there a plan for any further updates of Z2 Play camera ?

It's hard to believe that there is near zero interest in solving your customer's problems...
Reply
Options

14293 Posts

03-05-2018

United States of America

1313 Signins

178190 Page Views

  • Posts: 14293
  • Registered: ‎03-05-2018
  • Location: United States of America
  • Views: 178190
  • Message 3 of 5

Re: Camera laggy on my Z2 Play

2019-01-30, 19:12 PM

Hi xfire,

 

Thanks for posting. I couldn't say what would the next update contains for sure. However, let's try isolating the case first, for us to know what could cause the delay in capturing photos. I'd like to confirm, did you restore your apps after doing the reset? 

 

Best regards,
Rich
Motorola Support



Did someone help you today? Click the thumbs up button to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

44 Posts

01-06-2011

Poland

41 Signins

530 Page Views

  • Posts: 44
  • Registered: ‎01-06-2011
  • Location: Poland
  • Views: 530
  • Message 4 of 5

Re: Camera laggy on my Z2 Play

2019-01-30, 19:43 PM

Nice to see you again, Agent_Rich ! :smileyvery-happy:

A side note : I previously reported problems with Hasselblad and camera application not starting up each time correctly. Now it seems to be resolved, but we have some new problems...

 

Now, back to your questions : Yes, I have restored most important apps, but I have just a few (no games nor anything heavy, just a Google Pay and two other banking apps and Deezer + Spotify).

 

BUT ! I have noticed something. When I disable Google Lens in the camera application, it becomes more responsible and the lag is minimal.

 

But there is another problem. After I disabled Google Lens, I immediately noticed that new photos that I have taken are not displayed at all in the "Google Photos" application. Like they were not saved by the camera. I had to restart the phone and then all the photos were displayed as they should. But actually this behaviour is something that can be replicated easily.

 

But there's something more. If there is photo displayed on the screen and then you try to display the photo details, then the photo is displayed in somewhat lower resolution. Then you have to close the details, swipe to display another photo and back - and the photo is displayed again in full resolution. 

 

I have also noticed that photos quality is much lower in current camera app release. I pay a lot of attention to this as I really love(d) to take photos with my Hasselblad. And now... I hardly use it, really. Photos are worse than before. It's a pity, really.

 

I know this is a lengthy list of problems but believe me, I really love smartphone photography (I'm a "pixel peeper" type of user, you know...) and until recently I was really happy with my Moto + Hasselblad. Now I'm really not that impressed. For sure there were some changes in the application, and it's worse now. I hope the Camera Team will spend more time on providing better results. Come on, guys ! Z2 Play is really great phone, just the camera needs some more love now... :heart:

Reply
Options

14293 Posts

03-05-2018

United States of America

1313 Signins

178190 Page Views

  • Posts: 14293
  • Registered: ‎03-05-2018
  • Location: United States of America
  • Views: 178190
  • Message 5 of 5

Re: Camera laggy on my Z2 Play

2019-02-06, 14:30 PM

Hi xfire,

 

Does it also happen while taking videos? Can you please send me a sample photos/video showing this? But first please make sure you have enough internal memory space. Try unmounting the SD if you have one. And check if you have the latest updated for your camera in Playstore, just search Moto Camera. As well as the moto mod is up to date (Attach the mod > Settings > Moto Mod > Software Update). Let me know. Thanks.

 

Best regards,
Rich
Motorola Support



Did someone help you today? Click the thumbs up button to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms