Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto Z Phones - Mod CapableMoto Z² Play
All Forum Topics
Options

3 Posts

05-14-2018

India

2 Signins

31 Page Views

  • Posts: 3
  • Registered: ‎05-14-2018
  • Location: India
  • Views: 31
  • Message 1 of 60

Moto Z2 Play: Fingerprint sensor not working after Oreo Update

2018-05-14, 6:48 AM

Dear Friends,

 

I purchased a Motorola Z2 Play during the 2017 Diwali sale and had been enjoying using the mobile until 12-May-2018.

 

On 12-May-2018, I was prompted to take OTA update to Oreo and I did the same after data backup. Strangely though, the fingerprint sensor in my device is not getting recognized after the Oreo update. I can make this out as my finger tap / movement is not recognized when I try to setup my fingerprint. Also, the One Touch Nav doesn't work either.

 

So, I tried calling customer care on 12-May-2018 and they informed me to try a factory reset. I did the same (thrice), but it was still non functional.

 

Then I spoke today and they asked me to clear all credentials on the phone. I did that as well, but still it is not working.

 

Now they are asking me to take the device to a service centre.

 

I currently reside in Chennai, and the review for all the service centres here are very poor; and I do not know if I can trust them with my device.

 

Has anybody else faced such issue after Oreo update?

 

Any tricks / hacks that I need to try before I go to the service centre..??

 

Edit - I do not have a memory card on the phone. I use Airtel 4G sim on slot 1. No sim in slot 2.

 

Phone SKU - XT1710-10

 

Android Version - 8.0.0

 

Build Number - OPS27.76-12-25

 

Please advise accordingly.

 

Thanks in Advance.

Reply
Options

57 Posts

04-25-2018

India

60 Signins

936 Page Views

  • Posts: 57
  • Registered: ‎04-25-2018
  • Location: India
  • Views: 936
  • Message 2 of 60

Re: Moto Z2 Play: Fingerprint sensor not working after Oreo Update

2018-05-14, 12:46 PM

@Surya46

I think you should go to service centre as it seems to be hardware issue and the chances are the fingerprint scanner might be damaged.

 

If you fail to add new fingerprint it is very likely that the fingerprint scanner is damaged and need to be replaced.

 

By the way can you please confirm when you had last google drive automatic backup and if you can change shape of te icons such as tear drop, square, etc. In my case google drive backup stopped working after 6th may and option for changing icon shape is completely missing which was present in another Z2P of another region.

(For changing icon shape: Long press on home screen>settings>icon shape)

 

Thanks

Reply
Options

3 Posts

05-14-2018

India

2 Signins

31 Page Views

  • Posts: 3
  • Registered: ‎05-14-2018
  • Location: India
  • Views: 31
  • Message 3 of 60

Re: Moto Z2 Play: Fingerprint sensor not working after Oreo Update

2018-05-15, 7:27 AM
I don't understand as to how the fingerprint sensor could have failed all of a sudden..!!

It was working fine until I hit the "INSTALL" button on the downloaded OTA update.

The sensor has not missed a single beat since I purchased the phone.

I guess I will have to visit the service centre.

Thanks for your feedback.
Reply
Options

14293 Posts

03-05-2018

United States of America

1313 Signins

178190 Page Views

  • Posts: 14293
  • Registered: ‎03-05-2018
  • Location: United States of America
  • Views: 178190
  • Message 4 of 60

Re: Moto Z2 Play: Fingerprint sensor not working after Oreo Update

2018-05-16, 16:18 PM

Hi Surya46,

 

Sorry to know about that. Have you tried to reconfigure your security settings? Kindly go to Settings > Security > Remove all fingerprint and then try to set it up again. Please let me know if that fixed the issue. 

 

Best regards,
Rich
Motorola Support



Did someone help you today? Click the thumbs up button to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

2 Posts

05-18-2018

Indonesia

2 Signins

28 Page Views

  • Posts: 2
  • Registered: ‎05-18-2018
  • Location: Indonesia
  • Views: 28
  • Message 5 of 60

Re: Moto Z2 Play: Fingerprint sensor not working after Oreo Update

2018-05-18, 14:47 PM

Dear agent rich, I have the different problem from surya46, My moto display on my Albus can't working. but

before i  am upgrading from Nougat to oreo, it is working properly. can you please help me what should I do ?

 

 

regrads,

 

 

Reman  

Reply
Options

5418 Posts

07-12-2014

United States of America

925 Signins

79600 Page Views

  • Posts: 5418
  • Registered: ‎07-12-2014
  • Location: United States of America
  • Views: 79600
  • Message 6 of 60

Re: Moto Z2 Play: Fingerprint sensor not working after Oreo Update

2018-05-21, 21:17 PM

 wrote:

Dear agent rich, I have the different problem from surya46, My moto display on my Albus can't working. but

before i  am upgrading from Nougat to oreo, it is working properly. can you please help me what should I do ?

 

 

regrads,

 

 

Reman  


Hi Reman,

 

We're not quite sure what you are referring to. Can you share a screenshot of what you are pertaining to?

 

Regards,
JM
Motorola Support

**Please don't ask me questions by Personal Message; questions belong in the forums.

Reply
Options

23 Posts

01-03-2018

Brazil

31 Signins

203 Page Views

  • Posts: 23
  • Registered: ‎01-03-2018
  • Location: Brazil
  • Views: 203
  • Message 7 of 60

Re: Moto Z2 Play: Fingerprint sensor not working after Oreo Update

2018-05-25, 1:45 AM
I got exactly the same behaviour after oreo update. Fingerprint sensor was working 5/5, now sometimes I have to try 3 or 4 times to wake the phone up.
FYI, my fingerprint sensor has no fingerprints registered, that is, I just long press it in order to wake the phone up.
Reply
Options

68 Posts

05-02-2018

Brazil

155 Signins

1159 Page Views

  • Posts: 68
  • Registered: ‎05-02-2018
  • Location: Brazil
  • Views: 1159
  • Message 8 of 60

Re: Moto Z2 Play: Fingerprint sensor not working after Oreo Update

2018-05-25, 14:50 PM

today i was forced to erase all fingerprints and add all them again. another issue from an phone that i don't trust anymore and i probably nevery buy the whole brand again, including the brand that actually controls it

Reply
Options

14293 Posts

03-05-2018

United States of America

1313 Signins

178190 Page Views

  • Posts: 14293
  • Registered: ‎03-05-2018
  • Location: United States of America
  • Views: 178190
  • Message 9 of 60

Re: Moto Z2 Play: Fingerprint sensor not working after Oreo Update

2018-05-28, 14:43 PM

Hi Brunesi Cristiano76,

 

Are we still having the same issue after few days? I'm thinking if the phone just needs a couple of days to adjust with the update. 

 

Best regards,
Rich
Motorola Support



Did someone help you today? Click the thumbs up button to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

68 Posts

05-02-2018

Brazil

155 Signins

1159 Page Views

  • Posts: 68
  • Registered: ‎05-02-2018
  • Location: Brazil
  • Views: 1159
  • Message 10 of 60

Re: Moto Z2 Play: Fingerprint sensor not working after Oreo Update

2018-05-28, 16:13 PM

to be honest, i've set 5 fingerprints at day 1. about 2 months after that, i've started to get a few troubles, like fingerprint not recognized. i've cleaned the sensor, with the an lens cleaner that come with my glasses (isn't wet, it's just an kind of silk, i think). didn't worked at all. so, i've erased all, added 4 fingerprints and is working ok most of the time, except when the software that was supposed to exist only in very cheap phones to cleam ram kills the app that does fingerprint reading. yes, no reboot, but still, a lot of times i get "type your password to enable fingerprint". and yes, i've did an full reset after oreo, just in case. didn't worked at all and the phone is brand new, first owner, now with 2-3 months after deceived

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms