cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
HSU
What's DOS?
Posts: 6
Registered: ‎04-06-2012
Location: United States
Views: 3,596
Message 1 of 14

MotoActv not recognized by MotoCast, and not visible in Windows Explorer.

 Just purchased a MotoActv and installed latest MotoCast software (v1.2.9) on three computers.  One is XP-Home SP3, another is W7-HomePremium 32bit, another is W7-HomePremium 64bit.


I am having the same issue with all three computers.  The MotoCast software installs all four steps without errors.  But right clicking MotoCast icon/Wireless settings shows only "Content, General, Account, Network" tabs.  I suspect this is because MotoCast is not recognizing my MotoActv device.  My MotoActv device does not show up in Windows Explorer, so I can not install any software from it, or load content into it.


When I connect the MotoActv device, all of my computers do recognize the USB connection, and Device Manager shows "Mot Composite ADB Interface", "Motorola USB Networking Driver", and "USB Composite Device" as working properly.


My MotoCast web account works fine, and loads(indexes) my computer content fine.  But without connection to my MotoActv device, it is almost useless for me.  I also can not sign into MotoActv.com (it keeps telling me "Invalid credentials, please try again.")  I suspect this is because the MotoActv device is not connected/recognized by MotoCast.


I am using the supplied USB cord.  I tried another I have, but that was worse.


Please help.  If we can just get this to work, I could love this device!  It has lots of cleaver and unique new features other devices do not have.  But without connecting to MotoCast, it is just a fancy and expensive pedometer, and will have to be returned with a very poor review. 


Thank you for your prompt attention!!!

marmarinou
802.11n
Posts: 504
Registered: ‎07-09-2010
Location: United States
Views: 3,596
Message 2 of 14

Re: MotoActv not recognized by MotoCast, and not visible in Windows Explorer.

HSU:  It sounds like you have not gone through the setup process yet for MOTOACTV.


When you connect your MOTOACTV by USB cable to any of your PCs, the MotoHelper icon should appear in the taskbar near the MotoCast icon. Does that icon appear when you connect? 


 


If the MotoHelper icon does appear, right-click on it. You should see "When device connects" and one or more menu choices. If it is not selected, select "Launch MotoCast USB".  Then, when MotoCast USB launches, it will guide you through the MOTOACTV setup process.


 


Let us know if the MotoHelper icon appears when you connect.


If MotoHelper does not appear, please check your Programs or Add/Remove Programs: you should see "MotoHelper 2.1.40 Driver 5.5.0".  The next step would be to remove that program, then install MotoCast again from mymotocast.com.  MotoCast installation includes the MotoHelper/Driver bundle.

HSU
What's DOS?
Posts: 6
Registered: ‎04-06-2012
Location: United States
Views: 3,596
Message 3 of 14

Re: MotoActv not recognized by MotoCast, and not visible in Windows Explorer.

marmarinou, Thanks for your help.


The answer to your question is, No.  The MotoHelper icon does NOT appear when MotoActv device is connected or not.  Only the MotoCast icon is visible.  When the device is plugged in, the computer makes a connection sound, and the drivers appear in Device manager.  When the USB cable is disconnected, the computer makes a disconnection sound, and the drivers disappears from the Device manager list.


Because the MotoHelper is not available, I can not launch MotoCast USB from there.  I tried going to \Program files (x86)\Motorola Media Link\Lite\ and maually launching the MotoCast USB (MMLCC.exe).  The program starts, but can not find the device, so after about a minute, a message appears, "Please connect a Motorola device."  Several USB removal/insertions gave the same message each time.


By manually running the MML.exe program, I found "Sync automaticaly when a device connects via USB" was not checked on.  I did select it and closed the program.  But each time I run this MML.exe program, it is always not checked.


I also tried plugging the Motoactv device into my work computer today (W7-Home premium 32 bit), and the computer tried to auto-install the device drivers, but was unsuccessful.  This same thing happened to my previous attempts with my other three computers at home.  I had to then download the latest software online and install that for the drivers to work.  But MotoHelper never shows up on the task bar, only MotoCast (as I mentioned in my initial post).


Any other suggestions?  I am ready to return this asap if no other suggestions that can make this work.


BTW, in my All Programs/Motorola Mobility folder, only MotoCast is listed.  Nothing else is there.


It seems that MotoCast is ignoring or can not recognize this device, even though the computer does.  Is it possible I got a defective device, or USB cable, and ordering another one might solve this mystery?  I have only one other cable that fits, but even the computer will not recognize the device with that cable. 


Thanks again!

marmarinou
802.11n
Posts: 504
Registered: ‎07-09-2010
Location: United States
Views: 3,596
Message 4 of 14

Re: MotoActv not recognized by MotoCast, and not visible in Windows Explorer.

Before returning the device, you can try a Factory Reset:


Settings > General > Factory Reset


This will erase any personal data you have entered, but you would want to do that anyway before returning the device, so it is worth a try.

HSU
What's DOS?
Posts: 6
Registered: ‎04-06-2012
Location: United States
Views: 3,596
Message 5 of 14

Re: MotoActv not recognized by MotoCast, and not visible in Windows Explorer.

Ok marmarinou, you're a genius.  I know your "Factory Reset" suggestion seems obvious, but sometimes it takes a genius to see the obvious.


Since the MotoCast software was already up-to-date, this problem was solved after your a device "Factory Reset" while the device was connected via USB.  After reset, MotoHelper appeared and finished the setup.  After the setup process (several steps) completed, I was able to access MotoActv.com web site as well. 


Finally I was able to use my MotoActv today, and I really like it.  A few minor improvements can be made, but overall the device is the best on the market for what I was looking for... a small gps workout device.  I'm now considering getting the watch band and another MotoActv for my wife! 


"Factory Reset" should be the standard first recommendation for a new MotoActv not connecting to the computer.  At the very least it should be in the quick setup guide. 


Much thanks for your help!

marmarinou
802.11n
Posts: 504
Registered: ‎07-09-2010
Location: United States
Views: 3,596
Message 6 of 14

Re: MotoActv not recognized by MotoCast, and not visible in Windows Explorer.


HSU said:

.....

"Factory Reset" should be the standard first recommendation for a new MotoActv not connecting to the computer.  At the very least it should be in the quick setup guide. 


Much thanks for your help!



 HSU:  I am very glad that the Factory Reset fixed things for you.


Just to confirm, when you posted originally:


Device Manager shows "Mot Composite ADB Interface", "Motorola USB Networking Driver", and "USB Composite Device" as working properly.


Was the MOTOACTV still in its "out of the box" state?  Did you make any modifications to it before then?


Also, which software version is your MOTOACTV on currently? 


Settings > General > MOTOACTV Status > Software Version


Have you done a device software update yet?

HSU
What's DOS?
Posts: 6
Registered: ‎04-06-2012
Location: United States
Views: 3,596
Message 7 of 14

Re: MotoActv not recognized by MotoCast, and not visible in Windows Explorer.

marmarinou:  I will try to answer your questions as I understand it ...


1) Out of the box, I was excited to try the new device.  The first thing I did was plug it into the included USB charger overnight.  After a full charge, I did view most of the screens on the device, and customized my personal profile, as well as a couple of screens, before I tried to connect/install the device on the computer.  Sorry, I do not remember all the changes I made before trying to connect the device to the computer.


When the device did not auto-install, that was when I signed onto MotoCast on the web, and downloaded/installed the latest MotoCast software.  After MotoCast installed without incident, I still could not get the device to connect.  That was when I checked the Device Manager for the drivers, while the device was still connected by USB.  It seems MotoCast just could not connect to the device, to finish the install, without that "Factory Reset".


2) Once the device connected, I was able to easily undate to the latest software version... MA 1.6.6 N8

GMO1
What's DOS?
Posts: 7
Registered: ‎10-10-2012
Location: United States
Views: 3,596
Message 8 of 14

Re: MotoActv not recognized by MotoCast, and not visible in Windows Explorer.


hey guys i was just reading and i do have the same problem i did try all that you guys been discusted in this form but nothing help..



i have a Motorola Atrix 4g and it works perfect the MotoCast but on my MotoActv does not



and althought i have same error that it talks about ADB



what else we can do if "Factory Reset" and Unistall and Reinstall MotoCast it's not HELPING AT ALL!!

marmarinou
802.11n
Posts: 504
Registered: ‎07-09-2010
Location: United States
Views: 3,596
Message 9 of 14

Re: MotoActv not recognized by MotoCast, and not visible in Windows Explorer.



GMO said:


hey guys i was just reading and i do have the same problem i did try all that you guys been discusted in this form but nothing help..



i have a Motorola Atrix 4g and it works perfect the MotoCast but on my MotoActv does not



and althought i have same error that it talks about ADB



what else we can do if "Factory Reset" and Unistall and Reinstall MotoCast it's not HELPING AT ALL!!


View original




Which software version is your MOTOACTV on?

GMO1
What's DOS?
Posts: 7
Registered: ‎10-10-2012
Location: United States
Views: 3,596
Message 10 of 14

Re: MotoActv not recognized by MotoCast, and not visible in Windows Explorer.


TO marmarinou: 



 



I have the vertion of 2.0.23   and my MotoACTV is 8g  but still i cant get it on THE MOTOCAST TO SYNC IT