English Community

Lenovo TabletsOther Android based Tablets and Phablets Knowledge Base

Recover to Lenovo Android 3.2 for K1 Tablet

Reinstalling Android 3.2 on an IdeaPad K1 Tablet


This article contains instructions in the attached PDF, which can be used along with the code available in the included download link to re-image your K1 with the latest Lenovo provided Android 3.2 release including the Lenovo launcher and all pre-installed applications.


This may be useful for customers who have tried the Lenovo Vanilla ICS 4.03 release, custom roms from the developer community, or to recover a K1 that is stuck in a loop boot situation in which the nVidia logo is displayed repeatedly without ever entering the Android OS.


Please note that this proceedure will completely wipe the K1, and all data, including user installed data and applications will be erased.


Please download and review the attached PDF and familiarize yourself with the APX mode, installation of the driver (if you have not done so previously), and the imaging process.   Use of a PC running Windows 7 is recommended.


Once you are familiar with the instructions, download the 3.2 Honeycomb package here and follow the instructions to complete the re-imaging process.


Was this information helpful?

Yes No


rgcaudle On 2013-09-08, 22:40 PM

I recently got the boot loop on my K1 Tablet. I've been trying to perform this reinstall. However, every time I click on  flash_old.bat, it runs until it gets to the line "Formatting partition 12 UDA please wait.. done!" and then it just sits there. Whats the problem here?

bchestnut On 2013-10-09, 10:39 AM

I am also having the same problem after "Formatting Partition 12."  What should I try next?

doo03dah On 2013-11-20, 23:21 PM

I,too, am having the same problem after "Formatting Partition 12."  What should I try next? Help!

noxpert On 2014-01-07, 3:49 AM

I had the same problem after "Formatting Partition 12".

I turned the tablet off, went back into recovery mode, restarted the flash process and it worked the second time. I was running the flash_old, since the flash.bat did not work on my hardware.

cookap On 2014-06-02, 11:17 AM

I am having the problem of getting stuck after "Formatting Partition 12....UDA please wait....done!".  The only file that seems to do anything is the flash_old.bat.  Please help.  I'm really frustrated.  If someone would please offer some help I would really, really appreciate it.  I have tried so many times.  With the SD card in, with the SD card out.  I've turned it off and on so many times.  It will only turn on with the blank screen and two lights now and even does that when plugged into the wall.  Thank you!

zoltanthegypsy On 2014-06-26, 22:28 PM
ag07 On 2015-02-19, 6:14 AM


I have the same problem. cannot remember the password. I followed these instructions and  I get to the step where I update driver and get the message that windows encountered an error... Cannot find the specified file. How do I fix that? Thanks!

fourdragons On 2015-05-06, 19:57 PM



i installed the ICS stock rom as mentioned in one of your posts and its working.. but i'm not satisfied with that.. i need to go back to Honeycomb.. I have the stock rom downloaded but when i try to run the "flash.bat" or any of the other .bat file, i get the error message "USB device not found".. and the command window exits in a fraction of a second. I don't know how to fix this.. 


I tried in two systems one on my laptop running Windows 7 Ultimate and on my Desktop running Windows 8.1 Enterprise edition.. It did not work on both... Please help me.. 

joelking On 2015-08-03, 2:26 AM

Hi to all,


Please help. the the buttons "Vol - + plus Power " does not show recovey screen..

can anyone please have an idea about this?





Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop