English Community

Lenovo TabletsOther Android based Tablets and Phablets Knowledge Base

S6000: Error Message "Damaged SD Card" On Good 64GB SD Card

Question

I bought a SanDisk 64 GB micro SD and inserted into my S6000. It recognized the card and showed about 59 GB available.  I un-mounted the card and inserted into a card reader attached to my PC and transferred some files over to it.  The problem now is that every time I insert the card into the S6000, it gives me a "damaged SD card" error.

 

The card works fine in a Samsung S3 phone and a Samsung Galaxy Tab but still doesn't work in the S6000. I even tried reformatting it in both devices.

 

I tried 2 other Micro SD cards, 4 GB and 32 GB, they work fine in the S6000, so I know the reader isn't broken.

 

SanDisk's web site says to reformat in a PC with exFAT, I did that, it still won't work.

 

Lenovo Tech Support says to send the tablet back. Is there anything else I can try?

Answer

An investigation by the engineering team revealed that this symptom is caused by the way the card is formatted. This appears to affect all 64GB Class10 SDXC cards. If you are configuring one of these cards in the tablet, please follow the steps below:

 

Warning : This will delete all your data on the SD Card. Back up anything you wish to save before beginning this process.

 

  • Begin by using the provided Micro SD Card Adapter and insert the card in a Laptop or Desktop card reader.

  1. Go to Computer or My Computer depending on the OS. Right click (right mouse button) on the SD Card and select (See illustration below)

    Capture1.PNG
  2. Go to File System Select FAT32 or exFAT

    Capture2.PNG

    NB: 
    > If you’re able to format the card FAT32 you can insert it in the tablet and use it immediately
    > If FAT32 isn’t an option select exFAT then press Start .  Once this completes insert the card into the tablet.  

  3. You’ll notice a small ICON for the SD Card in the top left corner of the screen.
    Capture3.PNG

  4. Swipe down over the icon and you’ll see the following message
    Capture4.PNG

  5. Tap on the Damaged SD Card message which will allow you to reformat the card
    Capture5.PNG

  6. Once this is complete you’re finished and able to use the card inside the tablet
    Capture6.PNG

  7. To confirm this worked go to Settings and Storage you should now see the SD Card and Total space
    Capture7.PNG

Was this information helpful?

Yes No

Comments

dr_adel On 2014-01-18, 11:25 AM
how to change my default audio player in lenovo ideatab A3000-h
jmichae3 On 2014-04-29, 5:17 AM

 

it might be bacuse the filesystem for a 32GB card and lower is FAT32, while for 64GB and above it's exFAT (64-bit FAT). they are not compatible. the filesystem is actualy capable of 8TB, but due to bugs in windows98 that prevented scandisk from seeing more than 32GB, the 32GB limit stuck and never got fixed, even through windows 8.1. now everyone rides the 32GB bug FAT32 bandwagon, for compatibility reasons I guess.

 

an SD card shold be formatted not with windows but with SD card formatting software provided by the SD card organixzation, or by your device.  https://www.sdcard.org/downloads/formatter_4

 

if your OS doesn't support exFAT or 64GB cards, then it won't work with a 64GB or larger card. same problem with any device that uses a memory card, like a camera. try a 32GB SD card, you may find it works just fine.

 

a5uperman On 2014-06-15, 3:28 AM

64GB cards are now like $40.

Why didn't you pay the license fee to MS for exFAT?

Or at least look into the opensource filesystem that reads them?

pzanotti On 2017-01-17, 10:14 AM

I had same problem with 32Mb SD Card class 10 using in my cell moto g3. How can I solv this?

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Delete