English Community

Linux Operating SystemsOther Linux Discussions Knowledge Base

Ideapad S205: GRUB+EFI trouble



Need some help setting up a "Dualboot" with Windows 7 and Debian on an S205.


The S205 system shipped with FreeDOS. I replaced the HDD with a Samsung 470 Series SSD.


Then I installed Windows:


Hitting F12 (e.g. Fn+F11); selecting my external USB DVD drive; waiting until the first "press any key to boot from cd/dvd........." prompt expired. Then a second one - this time in german since i have a german Windows 7 - appeared.


When I enter the Windows setup from the first prompt, the installer complains about unsupported storage media - maybe this is because my SSD is preformatted with an MBR partition table and the first prompt enters the EFI+GPT Windows installer.  So I guess the first prompt does not come from my Windows CD, maybe some EFI program?


When I entered the setup from the second, a German prompt (which comes from the CD I think), I was able to install Windows like I used to do on "normal" PCs with BIOS. So I believe this is the BIOS emulation mode.


Windows works well, including Shutdown, Hibernate, WLAN. But i wanted a dualboot setup, so i shrinked the Windows C: partition, maintaining the correct alignment (partition offsets) to preserve health and performance of my SSD.


Then Icreated 3 new partitions - one for /boot (/dev/sda3), one for / (/dev/sda5) and one for swap (/dev/sda6).


After that, I installed Debian Sid to /dev/sda5 (which is btrfs) and GRUB (grub-legacy, 0.97) to /dev/sda3 because /boot shouldn't be on a btrfs.  First I tried GRUB2, but it doesn't work. I found some advice in planet3dnow.de forums. They say I had to use GRUB instead of GRUB2. 


Next, I chrooted in my installed Debian using a Live-CD, purged every single grub package and installed grub-legacy.

As root, I entered

# grub

 to get a grub shell. Then

root (hd0,2)


setup (hd0,2)

 to install GRUB to my /boot partition. Of course, /dev/sda3 (which is (hd0,2)) was marked as active.

When i turned my S205 on after that, it gave me "loading GRUB.." and then immediately restarted, and so on (infinite loop).


The same happened when i tried to install GRUB to (hd0,0), which is the Windows 7 boot partition.


I know that you normally install GRUB to the MBR of the disk, but that didn't work at all:

When i tried to install GRUB to (hd0) in the beginning, when booting all i got was "BOOTMGR missing, press ctrl+alt+del to restart" from Windows.

I had to boot the Windows CD, execute 'bootrec /fixmbr', 'bootrec /fixboot', 'bootsect /nt60 C: /mbr' and set the first partition (Windows Bootloader) as active to fix that.

But directly after that, GRUB worked, which is quite surprising since the mentioned Windows commands normally overwrite everything related to foreign bootloaders.


Now I can boot my Debian, that works like a charm. But I can't boot Windows.

I have the following entry in my /boot/grub/menu.lst:

title        Windows 7
root         (hd0,0)
chainloader +1

 Normally this works when Windows (or, here, its bootloader) is on the first partition. Of course i tried (hd0,1) as well since this is the "C:" partition (/dev/sda2). /dev/sda1 has only 100MB and contains the Windows Bootloader.


What can I do? 


This was resolved by:


1. boot a Linux Live-CD

2. mount /dev/sda5 to /mnt, /dev/sda3 to /mnt/boot. bindmount /dev and /sys and mount /proc to their places in /mnt.

3. chroot /mnt

4. purge every grub related package

5. install grub-pc (it's GRUB2) and os-prober

6. grub-install /dev/sda --> update-grub

7. boot the Windows CD, enter the console

8. bootsect /nt60 C:

9. diskpart --> select disk 0 --> select partition 3 --> active --> exit

10. repeat 1.-3.

11. grub-install --force /dev/sda3 (warinings about blocklists, ignore that. Should finish with "ok, no errors". Problems with core.img? Post them here!)

12. update-grub (should find Windows 7 Loader)

13. reboot into your working GRUB2 

Was this information helpful?

Yes No


Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop