English Community

Linux Operating SystemsOther Linux Discussions Knowledge Base

T400 ThinkPad running warm under Linux

Symptoms

 

I have found this very unusual that while running Windows OS my Thinkpad T400 is extremely silent and smooth but while running linux OS like Ubuntu( tried  386 and 64 bit ) , mandriva , centos .  My T400 runs much warmer and is difficult to use this way.

 

 

 

 

Diagnosis

 

While CPU usage may be reported low at idle,  power management drivers may not be optimized and properly scaling CPU and GPU cycles.   Switchable graphics models operating in discrete mode may generate more heat and exhibit reduced run time due to the higher energy consumption.

Solution

 

Recomendations:  Install most recent kernel / release for the distro being used and consider installing and powertop.

 

For switchable Intel / ATI models, try going into you BIOS and change the switchable graphic option (or discrete graphics) to integrated graphics.  Running on integrated mode will reduce power consumption and lower the thermal profile of the system.

Was this information helpful?

Yes No

Comments

arzo On 2014-08-06, 14:21 PM
  1. Try installing frequency-applet for your environment, (probably frequency-applet if GNOME)
  2. play a little bit with cpupower frequency-set, more at https://wiki.archlinux.org/index.php/CPU_frequency_scaling#Setting_maximum_and_minimum_frequencies
  3. install (or enable) additional drivers for graphic card (this is an app in Ubuntu) - they might be disabled for default.
  4. try disabling external graphic in BIOS as mentioned

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Delete