English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

3 Posts

09-07-2019

DE

22 Signins

191 Page Views

  • Posts: 3
  • Registered: ‎09-07-2019
  • Location: DE
  • Views: 191
  • Message 1 of 6

Black screen on wakeup from after suspend | Thinkpad E585

2019-12-31, 14:21 PM

Issue

I get a black screen after I wake my laptop from suspension. The issue occurs mostly, but not always.

 

Laptop specs

Laptop: Thinkpad E585
Graphics Card: AMD Radeon RX Vega 10

OS: elementary OS 5.1. Earlier I tried Ubuntu 18.04.3.

Kernel: 5.4.6-050406-generic

BIOS: 1.56

 

Unsuccessful attempts

 

 1. I have tried several versions of Linux kernel:

(i) 4.19.79 instructed here

(ii) 4.19.91

(iii) 5.0.0.37 which was preinstalled with elementary OS,

(iv) 5.3.12

(v) 5.4.6 as instructed here.

 

2.  Also, I have upgraded BIOS two times in the last few months when Lenovo released them.

 

3. I also tried All Open and Pro variants of amdgpu drivers provided by AMD here.

 

4a. In the /etc/default/grub file, I set:

GRUB_CMDLINE_LINUX="amd_iommu=pt ivrs_ioapic[32]=00:14.0 iommu=soft trace_clock=global"

as instructed here.

 

4b. I tried:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash ivrs_ioapic[32]=00:14.0 spec_store_bypass_disable=prctl"

which I had also done when I had installed Linux for the first time as mentioned here.

 

4c. I also tried:

GRUB_CMDLINE_LINUX="nouveau.modeset=0"

as advised here.

 

5. The issue is there for both secure mode on and off.

 

At the moment, nothing seems to work. Any help would be greatly appreciated!

 

 

Edit - 01-Jan-2020

If it's important to mention, my laptop is dual-boot with Windows 10.

 

Reply
Options

5 Posts

03-01-2019

NL

7 Signins

35 Page Views

  • Posts: 5
  • Registered: ‎03-01-2019
  • Location: NL
  • Views: 35
  • Message 2 of 6

Re:Black screen on wakeup from after suspend | Thinkpad E585

2020-03-09, 12:09 PM

I recently upgraded from Ubuntu 18.10 to 19.04 running kernel

 

Linux user-ThinkPad-E585 5.4.7-050407-generic #201912311234 SMP Tue Dec 31 17:38:50 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

 

And now i just discovered that on a blank screen on resume from suspend the numlock key actually still worked (on previous resumes it was always fully blocked). Now i ran following to fetch the relevant logging:

 

journalctl -o short-precise -k -b -1 

 

Since i'm not a kernel guru, ;-) does this give any links/hits where to continue?

 

Paul

 

 

mars 06 23:07:55.129780 paul-ThinkPad-E585 kernel: PM: suspend entry (deep)

mars 06 23:07:55.140120 paul-ThinkPad-E585 kernel: Filesystems sync: 0.010 seconds

mars 09 12:46:41.362305 paul-ThinkPad-E585 kernel: Freezing user space processes ... (elapsed 0.004 seconds) done.

mars 09 12:46:41.362461 paul-ThinkPad-E585 kernel: OOM killer disabled.

mars 09 12:46:41.362565 paul-ThinkPad-E585 kernel: Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.

mars 09 12:46:41.362663 paul-ThinkPad-E585 kernel: printk: Suspending console(s) (use no_console_suspend to debug)

mars 09 12:46:41.362777 paul-ThinkPad-E585 kernel: wlp4s0: deauthenticating from 4c:09:d4:c9:f3:e0 by local choice (Reason: 3=DEAUTH_LEAVING)

mars 09 12:46:41.362876 paul-ThinkPad-E585 kernel: psmouse serio2: Failed to disable mouse on synaptics-pt/serio0

mars 09 12:46:41.363477 paul-ThinkPad-E585 kernel: ------------[ cut here ]------------

mars 09 12:46:41.363586 paul-ThinkPad-E585 kernel: WARNING: CPU: 1 PID: 19137 at kernel/irq/chip.c:210 irq_startup+0xef/0x100

mars 09 12:46:41.363679 paul-ThinkPad-E585 kernel: Modules linked in: xt_conntrack xt_MASQUERADE nf_conntrack_netlink nfnetlink xfrm_user xfrm_algo xt_addrtype iptable_filter iptable_nat nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c bpfilter br_netfilter bridge stp llc ccm overlay amdgpu uvcvideo snd_hda_codec_conexant snd_hda_codec_generic amd_iommu_v2 snd_hda_codec_hdmi gpu_sched ttm videobuf2_vmalloc videobuf2_memops snd_hda_intel videobuf2_v4l2 snd_intel_nhlt videobuf2_common drm_kms_helper snd_hda_codec snd_hda_core nls_iso8859_1 videodev mc drm snd_hwdep i2c_algo_bit fb_sys_fops snd_pcm syscopyarea sysfillrect sysimgblt edac_mce_amd kvm_amd ccp kvm irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel aesni_intel ath10k_pci crypto_simd cryptd snd_seq_midi glue_helper ath10k_core snd_seq_midi_event ath joydev input_leds mac80211 snd_rawmidi serio_raw snd_seq wmi_bmof thinkpad_acpi nvram ledtrig_audio k10temp snd_seq_device snd_timer cfg80211 libarc4 snd ucsi_acpi typec_ucsi typec soundcore mac_hid

mars 09 12:46:41.363819 paul-ThinkPad-E585 kernel:  sch_fq_codel msr parport_pc ppdev lp parport ip_tables x_tables autofs4 uas usb_storage hid_generic usbhid hid ahci nvme psmouse i2c_piix4 libahci sdhci_pci r8169 cqhci sdhci realtek nvme_core wmi video i2c_scmi

mars 09 12:46:41.363920 paul-ThinkPad-E585 kernel: CPU: 1 PID: 19137 Comm: kworker/u32:5 Not tainted 5.4.7-050407-generic #201912311234

mars 09 12:46:41.364009 paul-ThinkPad-E585 kernel: Hardware name: LENOVO 20KV0008MH/20KV0008MH, BIOS R0UET74W (1.54 ) 07/23/2019

mars 09 12:46:41.364101 paul-ThinkPad-E585 kernel: Workqueue: events_unbound async_run_entry_fn

mars 09 12:46:41.364559 paul-ThinkPad-E585 kernel: RIP: 0010:irq_startup+0xef/0x100

mars 09 12:46:41.364689 paul-ThinkPad-E585 kernel: Code: f6 4c 89 ef e8 d2 40 00 00 85 c0 75 21 4c 89 ef 31 d2 4c 89 f6 e8 81 cd ff ff 4c 89 e7 e8 a9 fe ff ff 41 89 c5 e9 4d ff ff ff <0f> 0b eb b2 0f 0b eb ae 66 0f 1f 84 00 00 00 00 00 0f 1f 44 00 00

mars 09 12:46:41.364789 paul-ThinkPad-E585 kernel: RSP: 0018:ffff99e603b23b78 EFLAGS: 00010002

mars 09 12:46:41.364879 paul-ThinkPad-E585 kernel: RAX: 0000000000000010 RBX: 0000000000000001 RCX: 0000000000000040

mars 09 12:46:41.364979 paul-ThinkPad-E585 kernel: RDX: 0000000000000000 RSI: ffffffff9e6490e0 RDI: ffff8beff30e2540

mars 09 12:46:41.365072 paul-ThinkPad-E585 kernel: RBP: ffff99e603b23b98 R08: 0000000000000000 R09: ffff8befe7187e08

mars 09 12:46:41.365165 paul-ThinkPad-E585 kernel: R10: 0000000000000000 R11: ffffffff9e465148 R12: ffff8befe75bb800

mars 09 12:46:41.365240 paul-ThinkPad-E585 kernel: R13: 0000000000000001 R14: ffff8beff30e2540 R15: 0000000000000000

mars 09 12:46:41.365333 paul-ThinkPad-E585 kernel: FS:  0000000000000000(0000) GS:ffff8beff7040000(0000) knlGS:0000000000000000

mars 09 12:46:41.365426 paul-ThinkPad-E585 kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033

mars 09 12:46:41.365528 paul-ThinkPad-E585 kernel: CR2: 000000c420959010 CR3: 000000062aeec000 CR4: 00000000003406e0

mars 09 12:46:41.365636 paul-ThinkPad-E585 kernel: Call Trace:

mars 09 12:46:41.365786 paul-ThinkPad-E585 kernel:  __enable_irq+0x52/0x60

mars 09 12:46:41.365888 paul-ThinkPad-E585 kernel:  enable_irq+0x4d/0x90

mars 09 12:46:41.366005 paul-ThinkPad-E585 kernel:  nvme_poll_irqdisable+0x3bc/0x3e0 [nvme]

mars 09 12:46:41.366131 paul-ThinkPad-E585 kernel:  ? wake_up_q+0x70/0x70

mars 09 12:46:41.366262 paul-ThinkPad-E585 kernel:  __nvme_disable_io_queues+0x1bd/0x200 [nvme]

mars 09 12:46:41.366410 paul-ThinkPad-E585 kernel:  ? nvme_del_queue_end+0x30/0x30 [nvme]

mars 09 12:46:41.366487 paul-ThinkPad-E585 kernel:  nvme_disable_io_queues+0x2a/0x30 [nvme]

 

Reply
Options

2 Posts

11-29-2019

TR

9 Signins

30 Page Views

  • Posts: 2
  • Registered: ‎11-29-2019
  • Location: TR
  • Views: 30
  • Message 3 of 6

Re:Black screen on wakeup from after suspend | Thinkpad E585

2020-03-25, 8:07 AM
Using Ubuntu 20.04 with latest firmware and same problem.I think they never gonna fix it.
Reply
Options

3 Posts

09-07-2019

DE

22 Signins

191 Page Views

  • Posts: 3
  • Registered: ‎09-07-2019
  • Location: DE
  • Views: 191
  • Message 4 of 6

Re:Black screen on wakeup from after suspend | Thinkpad E585

2020-04-01, 9:00 AM

1. (cont) I also tried the following kernels with no success. 

 

(vi) 5.4.12 

(vii) 5.5.3 

(viii) 5.4.6

 

6. Talked to AMD Customer Care. They say they do not provide drivers for Ubuntu (I'm not sure then what they mean from OS Support for Ubuntu mentioned on their webpage) and I should ask laptop manufacture (Lenovo) for the drivers. I also contacted Lenovo Technical Support who say they only provide hardware support and for software support I should contact Microsoft. (Dude, how is Microsoft gonna help me with Ubuntu/eOS :p)

 

Have also posted on elementary OS Stack Exchange to consult people there.

 

By the way, if it helps, here is the log file I generated with journalctl -o short-precise -k -b -1 as Paul447 mentioned above.

 

Wasted so many days on fixing this issue. Should have bought a product for which both hardware and software are made by one company who would own their product (and not ping-pong their customers among each other like AMD and Lenovo are doing).

Reply
Options

1 Posts

07-21-2020

DE

4 Signins

20 Page Views

  • Posts: 1
  • Registered: ‎07-21-2020
  • Location: DE
  • Views: 20
  • Message 5 of 6

Re:Black screen on wakeup from after suspend | Thinkpad E585

2020-07-21, 14:56 PM

Seems that it is not just a issue with ubuntu. I am faceing the same with thinkpad x390 yoga and win10 1909. However, this worked in the beginning quite well. But now my screen stays also black when I want to wakeup from standby. Very anoying :(

Reply
Options

1 Posts

08-12-2020

AF

2 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎08-12-2020
  • Location: AF
  • Views: 5
  • Message 6 of 6

Re:Black screen on wakeup from after suspend | Thinkpad E585

2020-08-12, 18:14 PM

Same issue for me on E585 with ubuntu 20. No solution until now :s any help @Lenovo?!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete