Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

19 Posts

12-31-2016

Latvia

40 Signins

270 Page Views

  • Posts: 19
  • Registered: ‎12-31-2016
  • Location: Latvia
  • Views: 270
  • Message 1 of 1

Can't Install any Arch Based Distro in EFI Mode

2018-02-10, 12:28 PM

Hello! I've tried to install Arch Linux on my IdeaPad Y700-15ISK 80NV a couple of times, but I can't boot into installation stick in EFI mode. It does work in legacy mode. However, in EFI mode it says "EFI USB Device (TOSHIBA TransMemory) has been blocked by the current security policy."

Note that secure boot IS OFF.

I looked through my BIOS a couple of times (by the way, the BIOS sucks - it is ugly and lacks any useful features), tried many setting configs. Nothing worked. What can I do?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms