Showing results for 
Search instead for 
Did you mean: 
Posts: 5
Registered: ‎03-07-2017
Location: ES
Views: 4,574
Message 1 of 3

Can't boot linux since last BIOS update

Hi. Today I updated the BIOS (from here: Everything worked fine and nothing except the Lenovo logo seemed to have changed. However, since then I'm no longer able to boot my linux partition. Previously, I had a dual boot and I could both run windows 10 and linux. I would always set GRUB booter in the first position of the boot priority order, but grup doesn't appear now. Also, I would press F12 and the UEFI BOOT MANAGER showed differents options, windows and linux between them. But again, pressing F12 does nothing now.


I don't know how this happened. It seems like the linux partition has disappeared. Any suggestions are very welcome.


Thanks in advance!

Blue Screen Again
Posts: 2
Registered: ‎12-10-2017
Location: BR
Views: 4,450
Message 2 of 3

Re: Can't boot linux since last BIOS update

Hello, I have a dual boot with Windows 10 and Manjaro and yesterday I had the same issue as you.


Firstly, through a Manjaro live CD, I tried to reinstall grub and "backflashing" the BIOS to the previous version, but none of that solved, and I kept receiving the same error ("Bootloader x was blocked by the current security policy: Unknown error n"). However, a few moments later, I realized what was wrong.


Apparently, the BIOS firmware updater doesn't keep the custom settings, instead, they return to the default after the BIOS is updated. Therefore, it's necessary to reconfigure the BIOS:
(My laptop is a 320-15IKB (Type 80XL, 80YE) (ideapad), so I can't assure it'll work for you too)


1°: go to the Configuration tab and change SATA Controller Mode to AHCI;
2°: go to the EXIT tab and disable OS Optimized Defaults (this step may be unnecessary¹);
3°: go to the Security tab and disable Secure Boot;
4°: right down Secure Boot Mode, select Reset to Setup Mode, press enter and confirm with Yes;
5°: Save and Exit;
6°: return to the BIOS Setup and check if in the Security tab the value in bold "Secure Boot Status" is "Disabled";
7°: in Boot tab change your Linux bootloader to the first position;
8°: Save, and reboot.


¹: Click here to read a comment about this option

Paper Tape
Posts: 1
Registered: ‎03-28-2018
Location: US
Views: 4,244
Message 3 of 3

Re: Can't boot linux since last BIOS update - Solved



The Lenovo Utility notified me there was a BIOS update, so I figured it was security related and thought OK, it shouldn't take long, however after the update completed the PC reboot failed: Blue Screen, said INACCESSIBLE_BOOT_DEVICE


Since my laptop is under warranty, I contacted support via chat and they had me try a few things, then told me I would have to do a system recovery, since there was no way to back out the changes to the BIOS.


Not good news since I had not filed my taxes yet and there was no recent backup!!!


After searching YouTube and trying several things, the trick that worked was to switch the Intel RST, to AHCI mode in the BIOS and the PC booted normally! Note: If you made other changes to your BIOS, be sure to set things to default before making the above change - F9.


Could have been the prayer my wife had just sent up, either way I'm happy but a bit pissed at Lenovo for pushing out updates that fail.


Also, my ticket is still open and I could not find a way to close, update or otherwise contact Lenovo support after hours, so maybe they will see this and save someone else from having a heart attack.


Legion Y720-15IKB Laptop (Lenovo)



Check out current deals!

Shop current deals

Top Kudoed Authors