Showing results for 
Search instead for 
Did you mean: 
Fanfold Paper
Posts: 2
Registered: ‎02-15-2017
Location: FR
Views: 536
Message 1 of 2

Ctrl keys from integrated keyboard disabled


My two ctrl keys do not work for more than 4 months now and nobody achieved to find to find why.

I have a IdeaPad Y700-15isk with an i5, dual boot debian9/windows 10 (debian being my everyday OS). The issue is showing both on windows and linux so I think the problem comes from deeper. However it's not a hardware problem since I achieved one to make the keys work for the time my computer was on, by pressing a random combination of keys containing Fn, ctrl, F9, F10 and F11. I did not find any documentation from Lenovo related to disabeling ctrl key throughout function keys...

Moreover, Ctrl keys are working if I use my usb external keyboard. Ctrl keys do not work if I plug another keyboard on the connector of the motherboard (done by a repair IT guy). The IT guy flashed the BIOS but the problem is still there. He contacted Lenovo France but they said they had no idea and never had seen this problem before.

I wonder if it could come from linux that could have sent some signal to my controller and disabled the keys...

I would be very pleased if someone gave me hints on how to fix this issue.

What's DOS?
Posts: 1
Registered: ‎12-06-2018
Location: EG
Views: 366
Message 2 of 2

Re: Ctrl keys from integrated keyboard disabled

I was actually going to write about this problem to Lenovo. It differs on different models of y700 15ISK mine is 80RU.

It must be something with the BIOS. If you have the same model, do the following:
- Open the On-Screen Keyboard and click on any of the controls (nothing will show up probably)

- Now PRESS really hard on one or both CTRL keys (like you don't really care about it any more)

You'll probably find both CTRL keys flashing on the On-Screen Keyboard. Once they have a constant light, you'll find out that both of them work now without any problem.

The other problem here is that once the computer shuts down, or even hibernate, the issue appears again and you'll have to do the mentioned steps again. Man Mad

It doesn't matter if you didn't move the machine or didn't even change the lid position. Once it shuts down/hibernates, it happens again. Man MadMan Mad

I also tried on Windows and Linux, removed windows, and then removed linux. It's not an OS issue even with every update from Lenovo, it's still the same.

It's disappointing that such a good machine comes with such a problem.

Check out current deals!

Shop current deals

Top Kudoed Authors