English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

2 Posts

04-11-2014

Sweden

1 Signins

13 Page Views

  • Posts: 2
  • Registered: ‎04-11-2014
  • Location: Sweden
  • Views: 13
  • Message 1 of 1

L540 bricked after installing Linux

2014-04-11, 15:10 PM

I bought a demo unit with no OS on it. Suited me just fine. Did my research and it seemed to have good Linux support. So I thought...

 

Installed Kubutu 13.10, which worked fine running from usb stick. Since the SSD was empty, I let the installer partition it for me. Rebooted. And, that was that.

 

It wouldn't boot, I couldn't enter BIOS and none of the F-keys worked.

 

I then tried removing the SSD, same thing, nothing after the ThinkPad logo. I also tried with another SSD just for fun, but that didn't do much difference either.

 

Talked to support, and they said it was bricked, and they had to replace the mainboard. First time in since I started using Linux in 1996 I've totalled a computer just by installing a proper OS =).

 

Anyway, my question(s): should I have set some magic settings in BIOS prior to installing? If so, which ones, so it doesn't happen again when I get my computer back. And what could have happened? Or did I just have bad luck (beeing that it was a demo unit, and that).

 

All this UEFI, secureboot and whatnot is all new to me. Never had a computer with it before.

 

Since it was a new computer, and I only ran it for 15-20 minutes before sending it for repairs, I have no idea what BIOS version I had, so maybe it was a BIOS bug, any ideas?

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete