Showing results for 
Search instead for 
Did you mean: 
Paper Tape
Posts: 1
Registered: ‎03-24-2015
Location: United States
Views: 19,666
Message 21 of 32

Re: Lenovo yoga book - Linux


Paper Tape
Posts: 1
Registered: ‎06-29-2017
Location: DE
Views: 16,984
Message 22 of 32

Re: Lenovo yoga book - Linux

Hello together,


The new Ubuntu Desktop 17.04 64bit will also boot into Live mode from a microSD card on the Windows Version of the Yoga Book.


It seems to run quite performant and I was able to connect a 1440p external monitor.

Unfortunately I have the same issues that okflo described for 16.04, all of the following devices won't work:

WLAN, Touchscreen, Halo Keyboard, Pen Input.


I connected an external mouse, keyboard and ethernet adapter with a USB hub, that worked very well.

I'll try a bit more, but I'm happy about any ideas on how to solve this :-)

Paper Tape
Posts: 1
Registered: ‎07-12-2017
Location: DE
Views: 16,430
Message 23 of 32

Re: Lenovo yoga book - Linux



some commands you can try (and post the output here):


To identify hardware (WLAN and maybe others):

lspci -vvv

To list all connected USB devices (porbably just what you connected but there are rumors that hardware developers attach internal hardware via hidden USB connections):

lsusb -vvv

To check what input devices are detected:

xinput list

To list all hardware (lshw doesnt ship with all distributions by default though):

sudo lshw

The output of all of those commands is pretty long, you could e.g. write it to a file and then upload that somewhere




The Yoga book looks very interesting but I don't want to be stuck with Win10 or Gapps. Also i think its missing a thunderbolt port but thats a minor thing that probably won't be a problem in the next few years.

Paper Tape
Posts: 1
Registered: ‎08-03-2017
Location: CN
Views: 15,515
Message 24 of 32

Re: Lenovo yoga book - Linux

hi friends
now I can install Ubuntu Desktop 17.10 64bit on yoga book, and it run quite performant ,but wifi ,touch ,audio cann't work normally. beside ,I can use mouse and keyboard by usb hub to operate the system, and usb RJ45 ( transvert to usb ) to access internet .
now I try to proting wifi driver on the pad ,but it still cann't work , the wifi HW is bcm4356, you can find the detail info about wifi in the attached file. I doubt that is the wifi power pin didn't setup in HW level?( I mean we should set power pin in drvier)
and if I have bcm4356 drvier source code , how can I bulid the dirver which can used on ubuntu system?
wait for your reply , beside ,I can reply as for as possible.O(∩_∩)O

01:00.0 Network controller: Broadcom Limited BCM4356 802.11ac Wireless Network Adapter (rev 02)
Subsystem: Lenovo BCM4356 802.11ac Wireless Network Adapter
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 16
Region 0: Memory at 91400000 (64-bit, non-prefetchable) [size=32K]
Region 2: Memory at 91000000 (64-bit, non-prefetchable) [size=4M]
Capabilities: [48] Power Management version 3
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=2 PME-
Capabilities: [58] MSI: Enable- Count=1/16 Maskable- 64bit+
Address: 0000000000000000 Data: 0000
Capabilities: [68] Vendor Specific Information: Len=44 <?>
Capabilities: [ac] Express (v2) Endpoint, MSI 00
DevCap: MaxPayload 256 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset- SlotPowerLimit 10.000W
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd+ ExtTag- PhantFunc- AuxPwr+ NoSnoop+
MaxPayload 128 bytes, MaxReadReq 512 bytes
DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <2us, L1 <32us
ClockPM+ Surprise- LLActRep- BwNot- ASPMOptComp+
LnkCtl: ASPM L1 Enabled; RCB 64 bytes Disabled- CommClk+
ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
DevCap2: Completion Timeout: Range ABCD, TimeoutDis+, LTR+, OBFF Via WAKE#
DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-, LTR+, OBFF Disabled
LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-
Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
Compliance De-emphasis: -6dB
LnkSta2: Current De-emphasis Level: -3.5dB, EqualizationComplete-, EqualizationPhase1-
EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
Capabilities: [100 v1] Advanced Error Reporting
UESta: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
UEMsk: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
CESta: RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
CEMsk: RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
AERCap: First Error Pointer: 00, GenCap+ CGenEn- ChkCap+ ChkEn-
Capabilities: [13c v1] Device Serial Number 00-00-38-ff-ff-00-38-0f
Capabilities: [150 v1] Power Budgeting <?>
Capabilities: [160 v1] Virtual Channel
Caps: LPEVC=0 RefClk=100ns PATEntryBits=1
Arb: Fixed- WRR32- WRR64- WRR128-
Ctrl: ArbSelect=Fixed
Status: InProgress-
VC0: Caps: PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
Arb: Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
Ctrl: Enable+ ID=0 ArbSelect=Fixed TC/VC=ff
Status: NegoPending- InProgress-
Capabilities: [1b0 v1] Latency Tolerance Reporting
Max snoop latency: 15360ns
Max no snoop latency: 15360ns
Capabilities: [220 v1] #15
Capabilities: [240 v1] L1 PM Substates
L1SubCap: PCI-PM_L1.2+ PCI-PM_L1.1+ ASPM_L1.2+ ASPM_L1.1+ L1_PM_Substates+
PortCommonModeRestoreTime=0us PortTPowerOnTime=70us
L1SubCtl1: PCI-PM_L1.2+ PCI-PM_L1.1+ ASPM_L1.2+ ASPM_L1.1+
T_CommonMode=0us LTR1.2_Threshold=163840ns
L1SubCtl2: T_PwrOn=70us
Kernel modules: brcmfmac, wl
What's DOS?
Posts: 2
Registered: ‎08-21-2017
Location: US
Views: 14,828
Message 25 of 32

Re: Lenovo yoga book - Linux


To make working Wi-Fi you must create a file brcmfmac4356-pcie.txt into directory /lib/firmware /brcm/.


You should enter supervisor mode with su command.


Aftre that, type in terminal these commands:


mount -t efivarfs none /sys/firmware/efi/efivars
cat /sys/firmware/efi/efivars/nvram-74b00bd9-805a-4d61-b51f-43268123d113 > /lib/firmware/brcm/brcmfmac4356-pcie.txt

 Reboot Yoga Book and configure your WiFi interface.


I would to know if anyone has Bluetooth working (perhaps BlueTooth is embedded in 4356 Broadcom chip).

What's DOS?
Posts: 2
Registered: ‎08-21-2017
Location: US
Views: 14,828
Message 26 of 32

Re: Lenovo yoga book - Linux


driver for BROADCOM 4356 is already presente in Ubuntu 17.04.

Paper Tape
Posts: 4
Registered: ‎09-04-2017
Location: US
Views: 8,765
Message 27 of 32

Re: Lenovo yoga book - Linux

how close are you to booting from USB? I am thinking about Windows to go.

Paper Tape
Posts: 2
Registered: ‎12-19-2017
Location: SG
Views: 10,696
Message 28 of 32

Re: Lenovo yoga book - Linux

Hi, anyone have any success with installing and running Linux (I prefer Ubuntu) on the Yoga Book Windows?


Paper Tape
Posts: 2
Registered: ‎12-19-2017
Location: SG
Views: 7,317
Message 29 of 32

Re: Lenovo yoga book - Linux

Just reviving this topic.

I tried to run (livecd) the latest version of Ubuntu (18.04) without success.

Steps taken:

1) Make a bootable USB (I used a 8GB microSD card, and connected that to a USB - microUSB OTG adapter.

2) I booted into BIOS and turned Secure Boot off.

3) Accessing the BIOS again, I selected the USB device as a bootable option.

4) The Yoga Book displays the Ubuntu splash screen, then hangs and never loads properly.

5) I've tried connecting an external keyboard, mouse and usb-to-ethernet adapter, on a USB hub (all of these devices worked when the Yoga Book was running Win10). Sadly, I can't get past the Ubuntu splash screen.


If anyone has made any real progress, do post here. The Yoga Book, running Win10, is horribly slow. I do hope we can eventually install Linux on it one day in the future.

Serial Port
Posts: 35
Registered: ‎07-30-2017
Location: AT
Views: 5,769
Message 30 of 32

Re: Lenovo yoga book - Linux

in our telegram group we got wifi, touch and rotating work under 18.04, but the others are difficult to fix, hope lenovo will give us more options

And we're back...

Move delayed but still coming

Learn More

Check out current deals!

Shop current deals

Top Kudoed Authors