Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

2 Posts

09-03-2020

Germany

4 Signins

25 Page Views

  • Posts: 2
  • Registered: ‎09-03-2020
  • Location: Germany
  • Views: 25
  • Message 41 of 80

Re:Linux: Fn-keys not working - Thinkpad E14 AMD Gen 2

2020-09-03, 15:56 PM

Same with the E15 Gen2 the new Bios 1.0.8.  Fn not working

Kernel 5.8.5

 

already weak that lenovo is not active here....

 

Reply
Options

923 Posts

05-14-2020

United States of America

369 Signins

4560 Page Views

  • Posts: 923
  • Registered: ‎05-14-2020
  • Location: United States of America
  • Views: 4560
  • Message 42 of 80

Re:Linux: Fn-keys not working - Thinkpad E14 AMD Gen 2

2020-09-03, 20:45 PM

Hello Andy Linux,

 

What does acpi-listen report for you?

 

What does xinput say?

 

What desktop are you using?   Is it in Xorg or Wayland mode? or some other mode?

 

What locale are you using?  What linux distribution?

 

We seem to be stuck, saying it is lenovo's problem with the bios.  A company named InsydeBIOSH2O (or however they really spell it) seems now to be actually working with lenovo bios issues instead of lenovo, does anybody know the insydebiosh2o forum URL?

 

Respectfully,

Usedtoberich

 

I am using 5.8.200 kernel, fedora linux, but alas and alak, a lowly ideapad.  My function keys work great.

Reply
Options

13 Posts

07-19-2020

Germany

19 Signins

75 Page Views

  • Posts: 13
  • Registered: ‎07-19-2020
  • Location: Germany
  • Views: 75
  • Message 43 of 80

Re:Linux: Fn-keys not working - Thinkpad E14 AMD Gen 2

2020-09-04, 11:29 AM

@DaveOber Any news or comments from Lenovo? I have no problem with waiting a while for a fix, but I would love to hear a "We see your problem, we reported it to our developers, they are working on it" instead of what most users see as a "we do not care about you"

Reply
Options

2 Posts

09-17-2020

Italy

5 Signins

25 Page Views

  • Posts: 2
  • Registered: ‎09-17-2020
  • Location: Italy
  • Views: 25
  • Message 44 of 80

Re:Linux: Fn-keys not working - Thinkpad E14 AMD Gen 2

2020-09-17, 12:59 PM

I've read that after resuming from sospension Fn keys start working

(https://forum.manjaro.org/t/fn-keys-light-on-key-pressed-and-laptop-lid-closed/18021/6)

but in my Mint 20 I can't resume from suspension

also, external monitor doesn't work

very disappointed by ThinkPad

Reply
Options

4 Posts

08-29-2020

Switzerland

9 Signins

35 Page Views

  • Posts: 4
  • Registered: ‎08-29-2020
  • Location: Switzerland
  • Views: 35
  • Message 45 of 80

Re:Linux: Fn-keys not working - Thinkpad E14 AMD Gen 2

2020-09-20, 6:11 AM
I had also some issues with default 5.4 kernel, I installed a more recent one and resume from suspension (currentéy 5.8.8.) works.
Reply
Options

2 Posts

09-17-2020

Italy

5 Signins

25 Page Views

  • Posts: 2
  • Registered: ‎09-17-2020
  • Location: Italy
  • Views: 25
  • Message 46 of 80

Re:Linux: Fn-keys not working - Thinkpad E14 AMD Gen 2

2020-09-22, 7:12 AM

I'm trying some other distro: Manjaro and Kubuntu don't start at all, PopOS doesn't work resume

also, if I install TLP the notebook hangs

Reply
Options

12 Posts

09-01-2020

Germany

15 Signins

95 Page Views

  • Posts: 12
  • Registered: ‎09-01-2020
  • Location: Germany
  • Views: 95
  • Message 47 of 80

Re:Linux: Fn-keys not working - Thinkpad E14 AMD Gen 2

2020-09-23, 5:46 AM

@Desperados78 did you disable Secureboot in the UEFI setup? Fedora works OOB, and TLP works too.

Reply
Options

6 Posts

08-26-2020

Czech Republic

8 Signins

35 Page Views

  • Posts: 6
  • Registered: ‎08-26-2020
  • Location: Czech Republic
  • Views: 35
  • Message 48 of 80

Re:Linux: Fn-keys not working - Thinkpad E14 AMD Gen 2

2020-09-23, 14:26 PM

@Desperados78 Most likely the reason behind your issues is that you're using an old kernel, I've purchased E14 gen2 the day it was available in my country and installed Arch immediately, so I know from experience that every kernel ranging from 5.7.x works on this device (tested up to 5.9-rc5, I sometimes build RC kernels when there are changes that might affect me).

Given that you're running stable release distros like Mint and PopOs, I guess that those have something like the 5.4.x kernel which to my knowledge doesn't have the proper support for our CPU. So what you should do is head to kernel.org and grab the latest stable one, build it and try it out, that should fix your issues with laptop not waking up and external monitors not connecting.

 

However this won't fix the media key issue, that's up to lenovo to do, but I think that they will do it since I think that at least the L14 utilizes the same keyboard and that one is certified by Ubuntu to run Linux.

 

The temporary workarounds are either the suspending method, or setting up a cron job for it.

 

The lesson to take here is, that if you buy a new hardware, you need new software to run it - LTS kernel won't do it, updates for LTS kernels do not contain device drivers, only security patches.

Reply
Options

4 Posts

08-29-2020

Switzerland

9 Signins

35 Page Views

  • Posts: 4
  • Registered: ‎08-29-2020
  • Location: Switzerland
  • Views: 35
  • Message 49 of 80

Re:Linux: Fn-keys not working - Thinkpad E14 AMD Gen 2

2020-09-24, 14:48 PM
Hi Ondra5 Can you elaborate the cron job part, I know how to initiate suspend, but is there a way to "wake up" the laptop automatically? Thanks for your help.
Reply
Options

6 Posts

08-26-2020

Czech Republic

8 Signins

35 Page Views

  • Posts: 6
  • Registered: ‎08-26-2020
  • Location: Czech Republic
  • Views: 35
  • Message 50 of 80

Re:Linux: Fn-keys not working - Thinkpad E14 AMD Gen 2

2020-09-25, 10:54 AM

It's possible to suspend for a specified amount of time, i.e. it'll wake up automatically.

There's a utility called rtcwake for it.

 

Now how do we do it (I'll write a step by step guide so anyone can use it, even if they're not familiar with cron jobs and the command line.)

Note: I'm running Arch Linux, so some of the commands might differ from your use case.

 

First we need to install cron if it's not already on the

sudo pacman -S cronie

Now we nee to enable cronie (assuming you run systemd based distribution, if not - use your init system here)

sudo systemctl enable cronie.service

Now we need to create a crontab file from which cron will take what to do, since we need to only run it once during the boot, we can't use any of the files provided by cronie.

sudo touch /etc/crontab

The last thing we have to do is edit the (the -E flag for sudo is used for the program that is gonna run, so that it uses the users configuration and not the configuration that the root user has for it) (I use neovim, you can use whatever you want, if you don't know what to use, use nano)

sudo -E nvim /etc/crontab

Put this into the file:

@reboot root rtcwake -m mem -s 2

Now just reboot

 

 

NOTE:

Do not use this if you run some old kernel, like the default one on ubuntu or debian, those 5.4.x kernels don't have proper support for our hardware and it was previously reported here that the laptop doesn't wake up from suspend on old kernels.

***That is not kernel or distro or lenovo fault, that's user error since it's dumb to run new hardware with old kernel.

 

EXPLANATION:

This will suspend the laptop to memory for 2 seconds during the boot and automatically wake it up before user login.

 

If you have any questions throw them at me.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms