Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

8 Posts

04-28-2021

United States of America

13 Signins

55 Page Views

  • Posts: 8
  • Registered: ‎04-28-2021
  • Location: United States of America
  • Views: 55
  • Message 21 of 31

Re:No sound from speakers using Realtek ALC287

2021-05-28, 14:27 PM

I have the same exact issue and was close to returning my Yoga 7i 14".  After trying several distros I settled on Manjaro and followed the instructions in this Arch wiki to enable speaker audio.  The only issue I ran into was the startup script (a permissions issue).  That aside, after my computer boots up and I log in, all I have to do is play audio, suspend, and then wake, and audio begins playing through the speakers immediately.  The issue is still open at kernel.org, so hopefully it will be resolved soon.

https://wiki.archlinux.org/title/Lenovo_Yoga_7i#Speaker_audio

Reply
Options

2 Posts

02-24-2021

Indonesia

2 Signins

5 Page Views

  • Posts: 2
  • Registered: ‎02-24-2021
  • Location: Indonesia
  • Views: 5
  • Message 22 of 31

Re:No sound from speakers using Realtek ALC287

2021-05-28, 14:43 PM
Awesome tip ! Thank you
Reply
Options

3 Posts

05-07-2021

Canada

4 Signins

15 Page Views

  • Posts: 3
  • Registered: ‎05-07-2021
  • Location: Canada
  • Views: 15
  • Message 23 of 31

Re:No sound from speakers using Realtek ALC287

2021-06-01, 14:09 PM

Do not work on 13s Gen2 ITL i7... In fact seems it do not work wioth ALC3306. 

Tried other kernel, other distro, everything... Nothing... Headphone working, but not the speaker...

Very sad... :( 

Reply
Options

4 Posts

06-02-2021

Spain

4 Signins

20 Page Views

  • Posts: 4
  • Registered: ‎06-02-2021
  • Location: Spain
  • Views: 20
  • Message 24 of 31

Re:No sound from speakers using Realtek ALC287

2021-06-02, 19:57 PM

I've just receive my Lenovo Slim 7 and the sound does not work in Ubuntu 20. I've tried so many things, but I haven't succeeded yet. Is there any official workaround for it?

 

Thanks

Reply
Options

8 Posts

04-28-2021

United States of America

13 Signins

55 Page Views

  • Posts: 8
  • Registered: ‎04-28-2021
  • Location: United States of America
  • Views: 55
  • Message 25 of 31

Re:No sound from speakers using Realtek ALC287

2021-06-03, 15:02 PM

Have you seen this?  If this is your model (with the Ryzen cpu), this might work.  It seems that enabling deep sleep is the first step toward solving the audio issue related to the kernel.

https://bbs.archlinux.org/viewtopic.php?id=259075

Reply
Options

4 Posts

06-02-2021

Spain

4 Signins

20 Page Views

  • Posts: 4
  • Registered: ‎06-02-2021
  • Location: Spain
  • Views: 20
  • Message 26 of 31

Re:No sound from speakers using Realtek ALC287

2021-06-07, 7:15 AM

This solutions is related to the deep mode. I don't see any problems regarding it right now. I have a Intel model.

The only problem is the internal speakers that don't work in Linux anyway. If connect any earplug, it works. I saw other solutions to change the grunt file, but it didn't work either. 

Reply
Options

4 Posts

06-02-2021

Spain

4 Signins

20 Page Views

  • Posts: 4
  • Registered: ‎06-02-2021
  • Location: Spain
  • Views: 20
  • Message 27 of 31

Re:No sound from speakers using Realtek ALC287

2021-06-07, 18:32 PM
Hello Dave. Nice to meet you. I'm having the same issue here with Legion 7slim. Could you please help me with this issue?
Reply
Options

5 Posts

06-02-2021

Argentina

5 Signins

35 Page Views

  • Posts: 5
  • Registered: ‎06-02-2021
  • Location: Argentina
  • Views: 35
  • Message 28 of 31

Re:No sound from speakers using Realtek ALC287

2021-06-09, 14:04 PM

Hey there!

 

In this thread there are a couple of different issues in discussion. One is solved by the deep sleep solution, and is related to the sound card Realtek ALC287. The other is not solved yet, and is related to the sound card Realtek ALC3306.

 

@Gnsouza I think your device may have the Realtek ALC3306: https://psref.lenovo.com/syspool/Sys/PDF/Yoga/Yoga_Slim_7_15IIL05/Yoga_Slim_7_15IIL05_Spec.pdf.

 

I started another discussion to talk about ALC3306 specifically, but is not getting much attention. Maybe someone could bump it a bit? Lenovo Legion 7 16ACHg6 - No sound from speakers with ALC 3306-English Community

 

Hope this helps.

 

 

Reply
Options

4 Posts

06-02-2021

Spain

4 Signins

20 Page Views

  • Posts: 4
  • Registered: ‎06-02-2021
  • Location: Spain
  • Views: 20
  • Message 29 of 31

Re:No sound from speakers using Realtek ALC287

2021-06-09, 19:19 PM

Hi @pablitar 

We have the same problem. My model is Legion slim 7. I've seen your other post. I've googled a lot about this problem and I haven't found any solution. I don't have problems with the sleep mode, as it was suggested by @puny_giant .

 

https://psref.lenovo.com/Product/Lenovo_Legion_S7_15ACH6

High Definition (HD) Audio, Realtek® ALC3306 codec

 

I'm running out of options right now. Let's see if any staff member from Lenovo gives us a hint how to solve this issue.

 

Regards

Reply
Options

8 Posts

04-28-2021

United States of America

13 Signins

55 Page Views

  • Posts: 8
  • Registered: ‎04-28-2021
  • Location: United States of America
  • Views: 55
  • Message 30 of 31

Re:No sound from speakers using Realtek ALC287

2021-06-10, 20:15 PM

Nevermind.  (I thought I found something, but it was the incorrect model.)

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All