Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

79 Posts

12-26-2020

Austria

44 Signins

615 Page Views

  • Posts: 79
  • Registered: ‎12-26-2020
  • Location: Austria
  • Views: 615
  • Message 131 of 383

Re:T14 AMD battery drain in standby (Linux)

2021-03-05, 0:16 AM

@ MarkRHPearson wrote:

@jd_user - I' forwarded the information about the lid sensor to the BIOS team .

 

 

 - I' been running a test update with 1.29 BIOS & 1.30 EC and I also have minimal drain there (0.1 Wh in 19 hours)

FWIW I have lid sensor enabled.

 

Thanks. Is there a way to replicate this setup for regular users?

 

Also, is this power drain in S3 or powered off?

Reply
Options

526 Posts

07-22-2019

Canada

407 Signins

4386 Page Views

  • Posts: 526
  • Registered: ‎07-22-2019
  • Location: Canada
  • Views: 4386
  • Message 132 of 383

Re:T14 AMD battery drain in standby (Linux)

2021-03-05, 2:05 AM

It's a test BIOS so I'd need to get confirmation from the firmware team to let it out in the wild. I'll ask. @aproximacion  - normally on the AMD system the two pieces get updated together (not sure why, just the way it is)

 

I've been testing the power off issue at the moment. The suspend issue is being looked at too separately as well - I just haven't done so myself yet.

 

Mark

Reply
Options

15 Posts

10-10-2020

Belgium

19 Signins

65 Page Views

  • Posts: 15
  • Registered: ‎10-10-2020
  • Location: Belgium
  • Views: 65
  • Message 133 of 383

Re:T14 AMD battery drain in standby (Linux)

2021-03-05, 6:29 AM

I tested the sleep during the night, with the LID sensor disabled (USB always-on disabled too), and it went from 69% to 53% in 11 hours.

So for me it's not really a good result.

Reply
Options

31 Posts

09-08-2020

Germany

31 Signins

200 Page Views

  • Posts: 31
  • Registered: ‎09-08-2020
  • Location: Germany
  • Views: 200
  • Message 134 of 383

Re:T14 AMD battery drain in standby (Linux)

2021-03-05, 8:51 AM
Same here. Put my T14 to suspend yesterday at 22:00 (BIOS 1.29, lid sensor disabled) and woke it up 11.5 hours later. The battery level went down from 70% to 51%, which roughly corresponds to 0.84 Wh/h power loss. So this definitely doesn't fix the problem for me.
Reply
Options

79 Posts

02-14-2021

Ukraine

88 Signins

415 Page Views

  • Posts: 79
  • Registered: ‎02-14-2021
  • Location: Ukraine
  • Views: 415
  • Message 135 of 383

Re:T14 AMD battery drain in standby (Linux)

2021-03-05, 13:03 PM

i can’t be sure if that is relevant, but what’s your kernel version?

Reply
Options

15 Posts

10-10-2020

Belgium

19 Signins

65 Page Views

  • Posts: 15
  • Registered: ‎10-10-2020
  • Location: Belgium
  • Views: 65
  • Message 136 of 383

Re:T14 AMD battery drain in standby (Linux)

2021-03-05, 13:04 PM

Mine is 5.10.19-200.fc33.x86_64

Reply
Options

31 Posts

09-08-2020

Germany

31 Signins

200 Page Views

  • Posts: 31
  • Registered: ‎09-08-2020
  • Location: Germany
  • Views: 200
  • Message 137 of 383

Re:T14 AMD battery drain in standby (Linux)

2021-03-05, 14:04 PM
Mine is 5.10.19-100.fc32.x86_64
Reply
Options

26 Posts

01-23-2021

Argentina

28 Signins

225 Page Views

  • Posts: 26
  • Registered: ‎01-23-2021
  • Location: Argentina
  • Views: 225
  • Message 138 of 383

Re:T14 AMD battery drain in standby (Linux)

2021-03-05, 23:15 PM

Yesterday I've powered off machine from 1am to 9am today, it went down from 40910mW to 40590mW (320mWh drain in 8 hours, 0.04W per hour).

BIOS 1.29, Linux mode, Lid sensor on, USB-always-on off, kernel 5.8.0-38-generic

It's confusing. On power off, seems like sometimes it's fine sometimes not.

I want to make a script in a free time to log battery automatically.

Reply
Options

526 Posts

07-22-2019

Canada

407 Signins

4386 Page Views

  • Posts: 526
  • Registered: ‎07-22-2019
  • Location: Canada
  • Views: 4386
  • Message 139 of 383

Re:T14 AMD battery drain in standby (Linux)

2021-03-06, 2:12 AM

I agree - I thought I was reproducing the problem consistently, but went back to 1.30 EC and BIOS to re-run that test last night and got just .1Wh in ~10hrs. There is something really wonky and inconsistent going on (I didn't change anything else).

 

I was going to run another test BIOS from the firmware team over the weekend but unfortunately it has bricked my . I've got to figure getting my hands on a new system :/ Not a good Friday....

 

Mark

Reply
Options

79 Posts

12-26-2020

Austria

44 Signins

615 Page Views

  • Posts: 79
  • Registered: ‎12-26-2020
  • Location: Austria
  • Views: 615
  • Message 140 of 383

Re:T14 AMD battery drain in standby (Linux)

2021-03-06, 7:19 AM

@ MarkRHPearson wrote:

I agree - I thought I was reproducing the problem consistently, but went back to 1.30 EC and BIOS to re-run that test last night and got just .1Wh in ~10hrs. There is something really wonky and inconsistent going on (I didn' change anything else).

 

Another points of reference: X13, was flashed to 1.30 and then rolled-back to 1.29.

Battery drain in S3 - 0.72W/h, when powered off - 0.02 W/h.

 

While I would love to see the latter lower (current number means losing ~15 W/h over a month), this is not the main concern.

 

0.72 W/h in S3 is.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms