Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

35 Posts

01-23-2021

Argentina

52 Signins

435 Page Views

  • Posts: 35
  • Registered: ‎01-23-2021
  • Location: Argentina
  • Views: 435
  • Message 1 of 11

T14 AMD battery drain on suspend and shutdown

2021-01-23, 16:49 PM

Battery drains during suspend, hibernation and shutdown too. Last time I run sudo systemctl hibernate it went down ~20% in 12 hours. I'm not sure how to debug it properly, because everything seems like working fine (fans and power leds are switched off), and dmesg logs seems ok.

 

It also happens at shutdown. ~15% drain in 15 hours. This time touchpad wasn't working after boot. Here's the dmesg output.

1% per hour while sleep/suspend might slightly be acceptable, but I didn't expect to happen after shutdown.

 

I've already,

- switched power saving to Linux on BIOS

- disabled Wake-On-LAN and Always-on USB

- turned off Windows 10 Optimized defaults

 

Do you recommend using a specific kernel? or specific distro + kernel that you've already check battery saving works fine?

Also tried with the one tested in the Ubuntu Certification, 5.6.0-1027-oem kernel without success. 

Battery drain isn't a problem on Windows, so it shouldn't be a hardware fault.

 

I'm running KDE Neon (Ubuntu 20.04 LTS), and TLP on a Thinkpad T14 AMD. These are my current battery stats,

➜ uname -r 
5.8.0-38-generic

➜ sudo tlp-stat -b
Coloque su dedo índice derecho en el lector de huellas dactilares
--- TLP 1.3.1 --------------------------------------------

+++ Battery Features: Charge Thresholds and Recalibrate
natacpi    = active (data, thresholds)
tpacpi-bat = active (recalibrate)
tp-smapi   = inactive (ThinkPad not supported)

+++ ThinkPad Battery Status: BAT0 (Main / Internal)
/sys/class/power_supply/BAT0/manufacturer                   = LGC
/sys/class/power_supply/BAT0/model_name                     = 5B10W139
/sys/class/power_supply/BAT0/cycle_count                    =     12
/sys/class/power_supply/BAT0/energy_full_design             =  50500 [mWh]
/sys/class/power_supply/BAT0/energy_full                    =  51480 [mWh]
/sys/class/power_supply/BAT0/energy_now                     =  25410 [mWh]
/sys/class/power_supply/BAT0/power_now                      =  46978 [mW]
/sys/class/power_supply/BAT0/status                         = Charging

/sys/class/power_supply/BAT0/charge_start_threshold         =     40 [%]
/sys/class/power_supply/BAT0/charge_stop_threshold          =     80 [%]
tpacpi-bat.BAT0.forceDischarge                              =      0

Charge                                                      =   49.4 [%]
Capacity                                                    =  101.9 [%]

 

Here's a graph during hibernation,

 

enter image description here

 

And here's the respective dmesg output. Also, it seems last logs before hibernation are actually dumped when restored, is that the normal behavior, right?

 

Reply
Options

35 Posts

01-23-2021

Argentina

52 Signins

435 Page Views

  • Posts: 35
  • Registered: ‎01-23-2021
  • Location: Argentina
  • Views: 435
  • Message 2 of 11

Re:T14 AMD battery drain on suspend and shutdown

2021-01-23, 16:53 PM

My BIOS version is,

 

➜ sudo dmidecode -s bios-version
R1BET61W(1.30 )

And there seems to have some ACPI errors,

 

➜ journalctl -p err

 

-- Reboot --
ene 23 13:07:44 t14 kernel: Initramfs unpacking failed: Decoding failed
ene 23 13:07:44 t14 kernel: pci 0000:00:00.2: AMD-Vi: Unable to read/write to IOMMU perf counter.
ene 23 13:07:44 t14 kernel: [drm:dm_helpers_dp_write_dpcd [amdgpu]] *ERROR* Failed to find connector for link!
ene 23 13:07:44 t14 kernel: [drm:dm_helpers_dp_write_dpcd [amdgpu]] *ERROR* Failed to find connector for link!
ene 23 13:07:44 t14 kernel: [drm:dm_helpers_dp_write_dpcd [amdgpu]] *ERROR* Failed to find connector for link!
ene 23 13:07:44 t14 kernel: I2C multi instantiate pseudo device driver INT3515:00: IRQ index 1 not found
ene 23 13:07:44 t14 kernel: ACPI Error: No handler for Region [ECSI] (00000000618c35e0) [EmbeddedControl] (20200528/evregion-127)
ene 23 13:07:44 t14 kernel: ACPI Error: Region EmbeddedControl (ID=3) has no handler (20200528/exfldio-261)
ene 23 13:07:44 t14 kernel: ACPI Error: Aborting method \_SB.UBTC.ECRD due to previous error (AE_NOT_EXIST) (20200528/psparse-529)
ene 23 13:07:44 t14 kernel: ACPI Error: Aborting method \_SB.UBTC._DSM due to previous error (AE_NOT_EXIST) (20200528/psparse-529)
ene 23 13:07:44 t14 kernel: ucsi_acpi USBC000:00: ucsi_acpi_dsm: failed to evaluate _DSM 2
ene 23 13:07:44 t14 kernel: snd_pci_acp3x 0000:07:00.5: Invalid ACP audio mode : 0
ene 23 13:07:44 t14 systemd[1]: docker.socket: Socket service docker.service not loaded, refusing.
ene 23 13:07:44 t14 systemd[1]: Failed to listen on Docker Socket for the API.

Reply
Options

18 Posts

09-15-2020

Austria

29 Signins

150 Page Views

  • Posts: 18
  • Registered: ‎09-15-2020
  • Location: Austria
  • Views: 150
  • Message 3 of 11

Re:T14 AMD battery drain on suspend and shutdown

2021-01-24, 18:06 PM

I can confirm this problem. I am using Fedora 33 on my T14 AMD (bios 1.30). I can't suspend my laptop over night on (windows mode), because its out of battery the next morning. I noticed that the fan never goes off. When its totally out of power I can't turn my Laptop on charging it over my USB-C dock Gen2. Even after a few minutes. I have to use the charger. But the usb-c dock is another problem...

 

Reply
Options

35 Posts

01-23-2021

Argentina

52 Signins

435 Page Views

  • Posts: 35
  • Registered: ‎01-23-2021
  • Location: Argentina
  • Views: 435
  • Message 4 of 11

Re:T14 AMD battery drain on suspend and shutdown

2021-01-24, 18:27 PM

Yes, you might want to revert to 1.29

 

More in this thread, https://forums.lenovo.com/t5/Other-Linux-Discussions/T14-AMD-battery-drain-in-standby-Linux/m-p/5037674?page=6#5228910

Reply
Options

18 Posts

09-15-2020

Austria

29 Signins

150 Page Views

  • Posts: 18
  • Registered: ‎09-15-2020
  • Location: Austria
  • Views: 150
  • Message 5 of 11

Re:T14 AMD battery drain on suspend and shutdown

2021-01-24, 22:24 PM
Thank you for sharing the thread. I downgraded to 1.29.
Reply
Options

887 Posts

07-22-2019

Canada

539 Signins

6626 Page Views

  • Posts: 887
  • Registered: ‎07-22-2019
  • Location: Canada
  • Views: 6626
  • Message 6 of 11

Re:T14 AMD battery drain on suspend and shutdown

2021-02-06, 16:28 PM

As a note, if you're happy building your own kernel, this proposed patch should help:

https://lore.kernel.org/lkml/20210204051850.64857-1-aaron.ma@canonical.com/

 

Any feedback from people who try it would be appreciated. I don't believe it's accepted upstream yet.

 

Mark

Reply
Options

35 Posts

01-23-2021

Argentina

52 Signins

435 Page Views

  • Posts: 35
  • Registered: ‎01-23-2021
  • Location: Argentina
  • Views: 435
  • Message 7 of 11

Re:T14 AMD battery drain on suspend and shutdown

2021-02-06, 17:30 PM

I have Always On USB turned off from the BIOS and I experience battery drain ~1% per hour both on sleep and shutdown (running BIOS 1.30).

I should measure my tests again with BIOS 1.29, which seems a bit less.

Reply
Options

35 Posts

01-23-2021

Argentina

52 Signins

435 Page Views

  • Posts: 35
  • Registered: ‎01-23-2021
  • Location: Argentina
  • Views: 435
  • Message 8 of 11

Re:T14 AMD battery drain on suspend and shutdown

2021-02-06, 17:47 PM

@Mark_Lenovo were you able to verify this on Lenovo? I mean, this is trivial to test.

Reply
Options

105 Posts

02-14-2021

Ukraine

144 Signins

705 Page Views

  • Posts: 105
  • Registered: ‎02-14-2021
  • Location: Ukraine
  • Views: 705
  • Message 9 of 11

Re:T14 AMD battery drain on suspend and shutdown

2021-02-14, 17:27 PM

i posted there: https://forums.lenovo.com/t5/Other-Linux-Discussions/T14-AMD-battery-drain-in-standby-Linux/m-p/5037674?page=7#5258527
but apparently that post belongs to this thread:

 

--

today realized i'm having pretty similar issues with the battery drain whereas i do power off my laptop every time.

 

i do power off with: `shutdown -h now`

 

running latest bios firmware

 

sleep state: linux

 

wake on lan: disabled

 

always on usb: disabled

 

running NixOS.

 

installed upowerd and tlp:

```

    upower = {
      enable = true;
      criticalPowerAction = "PowerOff";
    };

 

    

    tlp = {
      enable = true;
      settings = {

        CPU_SCALING_GOVERNOR_ON_AC = "performance";
        CPU_SCALING_GOVERNOR_ON_BAT = "powersave";

        # The following prevents the battery from charging fully to
        # preserve lifetime. Run `tlp fullcharge` to temporarily force
        # full charge.
        # https://linrunner.de/tlp/faq/battery.html#how-to-choose-good-battery-charge-thresholds
        START_CHARGE_THRESH_BAT0 = 40;
        STOP_CHARGE_THRESH_BAT0 = 50;

        # 100 being the maximum, limit the speed of my CPU to reduce
        # heat and increase battery usage:
        CPU_MAX_PERF_ON_AC = 70;
        CPU_MAX_PERF_ON_BAT = 30;

        SOUND_POWER_SAVE_ON_AC = 0;
        SOUND_POWER_SAVE_ON_BAT = 1;

        CONTROL_BRIGHTNESS = 1;
        BATT_BRIGHTNESS_COMMAND = "brightnessctl --device=amdgpu_bl0 set 20%";
        LM_AC_BRIGHTNESS_COMMAND = "brightnessctl --device=amdgpu_bl0 set 35%";
        NOLM_AC_BRIGHTNESS_COMMAND =
          "brightnessctl --device=amdgpu_bl0 set 35%";
        BRIGHTNESS_OUTPUT = "/sys/class/backlight/amdgpu_bl0/brightness";
      };
    };
  };

```

 

i have laptop for about 2-3 months, and already 11 cycle of battery. first time i suspected something weird when powering off in the evening and starting up next day, the charge would not be the same 49% max as per TLP, i thought, ok fine, maybe i'm tripping.

 

but then, powered off two days ago, and starting up just now: the charge is 5%. the machine was just powered off.

 

ps. i do have splash Lenovo screen hanging for about 10-15 seconds, anyone experiencing the same?

 

ps2: been sound also won't go away even with options disabled for it.

--

Reply
Options

105 Posts

02-14-2021

Ukraine

144 Signins

705 Page Views

  • Posts: 105
  • Registered: ‎02-14-2021
  • Location: Ukraine
  • Views: 705
  • Message 10 of 11

Re:T14 AMD battery drain on suspend and shutdown

2021-02-14, 18:36 PM

reverted to BIOS 1.29 as per community suggestions. will monitor.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms