Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

29 Posts

09-08-2020

Germany

29 Signins

180 Page Views

  • Posts: 29
  • Registered: ‎09-08-2020
  • Location: Germany
  • Views: 180
  • Message 1 of 13

T14 AMD issues with USB-C docks

2020-11-14, 18:38 PM

My T14 AMD (20UES00L00) displays rather erratic behavior when connected to a USB-C docking station.

The dock I'm using is Dell WD15, i.e. it's capable of driving two monitors and supplying the laptop with power

via a single USB-C cable. In addition, it's also equipped with USB, audio and Ethernet ports.

 

When connecting the dock or even booting the laptop with the dock connected, I can get everything

working  properly only in roughly 20% of cases. Most likely I observe one of the following cases

 

  • The external monitor is working, keyboard and mouse too, but the USB-C charging doesn't work
  • The external monitor is working, keyboard, mouse and USB-C charging don't work
  • The external monitor is not working, keyboard, mouse and USB-C charging work
  • More permutations of the above.

 

In most cases, by reconnecting the dock several times (switching the USB-C ports on T14) I can

get everything working up to the USB-C charging. I don't think that this situation can be regarded

as a satisfactory one.

 

I also have two other USB-C docks (DIGITUS DA-70861, C2G 88845) which exhibit similar issues

when connected to my T14.

 

It also seems that even Lenovo's USB-C docks don't work that well with T14, at least according to

some reports in the forums.

 

I also noticed that the interoperability with my WD15 was much better when I was on the BIOS version

1.09. With the BIOS 1.25 almost nothing worked, while version 1.27 seems to be somewhere in-between.

So it even seems like Lenovo is trying to fix something here, but they are not very successful at it.

 

I'm wondering if this is a problem that affects only me, or also other T14 AMD owners. In the latter case

it is reasonable to expect that Lenovo should address these issues.

 

So if you are having similar issues with any USB-C dock (no matter if it's a Lenovo model or not), please 

reply to this thread.

 

PS I created this thread in this subforum since I'm a Linux user (Fedora), I don't use Windows 10 on this

laptop, so I can't say if the situation is better in that case.

 

 

Reply
Options

6 Posts

11-21-2020

United States of America

6 Signins

60 Page Views

  • Posts: 6
  • Registered: ‎11-21-2020
  • Location: United States of America
  • Views: 60
  • Message 2 of 13

T14 AMD issues with USB-C docks

2020-11-22, 0:08 AM
Hopefully the firmware updates mentioned here can fix this. I also have issues. https://forums.lenovo.com/topic/findpost/2713/5048223/5180930
Reply
Options

1 Posts

12-22-2020

Switzerland

1 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎12-22-2020
  • Location: Switzerland
  • Views: 0
  • Message 3 of 13

Re:T14 AMD issues with USB-C docks

2020-12-22, 13:19 PM

Hi,

 

I'm getting exactly same issue on Lenovo T14S AMD with Dell docking. I am on Windows OS.

 

Did you solve this ?

 

 

Regards

 

Alex

Reply
Options

29 Posts

09-08-2020

Germany

29 Signins

180 Page Views

  • Posts: 29
  • Registered: ‎09-08-2020
  • Location: Germany
  • Views: 180
  • Message 4 of 13

Re:T14 AMD issues with USB-C docks

2020-12-23, 13:57 PM

No I didn't. Since this is most likely a firmware-level issue, the only one who can solve it is Lenovo via a BIOS-update.
However, given that one runs into similar problems even when using Lenovo's own USB-C Docks recommended for ThinkPads,
it is not likely that they will care to fix a Dell docking.

Reply
Options

29 Posts

09-08-2020

Germany

29 Signins

180 Page Views

  • Posts: 29
  • Registered: ‎09-08-2020
  • Location: Germany
  • Views: 180
  • Message 5 of 13

Re:T14 AMD issues with USB-C docks

2020-12-28, 17:38 PM

Having said that, I think that Dell's WD-15 also has a lot of oddities.

At the end of the day, I try to reboot the dock every morning before connecting
my T14 to it. This way the monitor is not always recognized on the first attempt, but
after replugging the dock cable several times, it usually works.

What doesn't work most of the time is the power supply via the dock's USB-C cable.
Here I ended up purchasing some extra USB-C power supplies for work and home. So when
I get the monitor working but see that the battery is discharging, I just connect an
extra power supply to the second USB-C port. This is not how things are supposed to be,
but it kind of works.







Reply
Options

6 Posts

01-08-2021

United States of America

7 Signins

30 Page Views

  • Posts: 6
  • Registered: ‎01-08-2021
  • Location: United States of America
  • Views: 30
  • Message 6 of 13

Re:T14 AMD issues with USB-C docks

2021-01-08, 18:30 PM

This is the exact issue I'm having. I'm on Windows 10. I have not yet tried downgrading the BIOS firmware. My other laptops work fine with my Dell WD15 dock, this laptop does not. If these issues aren't solved, I may have to return the device.

 

Until Lenovo fixes their docking issue, I have to spend 20 minutes plugging and unplugging my dock daily - not to mention the wear and tear on my usb-c port. Point is that if you play with it enough and insert it enough times in different ports you'll eventually get it working somehow.

 

02:32:31 PM I got the timing down for the dock connection
02:32:41 PM the LED indicator for charging is very useful for debugging docks
02:33:07 PM in any circumstance where the dock is buggy or charging isn't working/monitors aren't detected, you have to unplug everything (dock power, cable)
02:33:10 PM wait a good 30 seconds
02:33:14 PM plug dock in first
02:33:22 PM then plug in the usbc cable
02:33:31 PM if the LED does not light up (for charging), immediately unplug replug
02:33:44 PM if it does light up, wait 10-20s to see if monitors show up
02:33:55 PM if not, unplug replug immediately without waiting
02:34:02 PM usually that gets it working
02:34:06 PM the timing is quite important here

I'm on latest BIOS (1.30). You can downgrade to 1.29, but not to 1.05 or 1.09 unfortunately. I didn't try the others as OP pointed out 1.27 didn't work. Only one left to try is 1.25.

 

Just so no one else wastes their time trying what I did, you can't flash 1.09 via USB either once you're on 1.30 or 1.29. The error you get is "The system program file is not correct for this system." (even though the readme.txt says it supports the T14 AMD Gen 1)

Reply
Options

6 Posts

01-08-2021

United States of America

7 Signins

30 Page Views

  • Posts: 6
  • Registered: ‎01-08-2021
  • Location: United States of America
  • Views: 30
  • Message 7 of 13

Re:T14 AMD issues with USB-C docks

2021-01-10, 20:14 PM

I can get my T14 to reliably hang/crash by simply unplugging and replugging my USB-C dock multiple times now.

Reply
Options

29 Posts

09-08-2020

Germany

29 Signins

180 Page Views

  • Posts: 29
  • Registered: ‎09-08-2020
  • Location: Germany
  • Views: 180
  • Message 8 of 13

Re:T14 AMD issues with USB-C docks

2021-01-10, 20:24 PM
Too bad. IMHO docking (WD 15) worked best with 1.05, but I'd be reluctant to downgrade, since 1.29 finally fixes the annoying "wake-up-on-lid-close" bug. Pity that T14 AMD is so much plagued with different issues despite of its superb CPU performance.
Reply
Options

6 Posts

01-08-2021

United States of America

7 Signins

30 Page Views

  • Posts: 6
  • Registered: ‎01-08-2021
  • Location: United States of America
  • Views: 30
  • Message 9 of 13

Re:T14 AMD issues with USB-C docks

2021-01-10, 20:43 PM

Is there even a valid downgrade path to 1.05? I can't get the downgrade to even start at 1.30 even though I've disabled rollback protection in the BIOS settings.

Reply
Options

195 Posts

12-17-2018

United States of America

350 Signins

2321 Page Views

  • Posts: 195
  • Registered: ‎12-17-2018
  • Location: United States of America
  • Views: 2321
  • Message 10 of 13

Re:T14 AMD issues with USB-C docks

2021-01-11, 11:50 AM

According to the release notes once you have gone to 1.28 you can not go back below that so you  might be able to get from 1.30 to 1.28 but that is as far as you can go.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms