Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

3 Posts

07-21-2012

Ireland

3 Signins

16 Page Views

  • Posts: 3
  • Registered: ‎07-21-2012
  • Location: Ireland
  • Views: 16
  • Message 1 of 5

T430 Discrete GFX under Linux not booting

2012-07-21, 21:49 PM

Hi all. I recently purchased a T430 with the NVS 5400M 2GB discrete GPU with the intention of using it as my dev machine for CUDA work. Unfortuneately, when I set the machine to boot with Optimus OS check disabled and the GPU set to Discrete I cannot boot into linux. I have tried installing with the inbuilt graphics, instlaling the NVidia binary blob, then changing over but the system just hangs while booting. I have tried booting into a live CD with the discrete option and it has failed to boot, and have tried a text-based installation and it still fails. I have been using Ubuntu 12.04 x64 default, alternate, and even Xubuntu. I have come to understand that this distro was supported (or at least proven to work) on this machine, but I haven't achieved this with the NVidia GPU.

 

If anybody has any suggestions for this I would greatly appreciate it. Thank you.

Lee.

Reply
Answer
Options

3 Posts

07-21-2012

Ireland

3 Signins

16 Page Views

  • Posts: 3
  • Registered: ‎07-21-2012
  • Location: Ireland
  • Views: 16

Re: T430 Discrete GFX under Linux not booting

2012-07-26, 21:45 PM
Hello Hiro,

I have found a quick-fix for getting CUDA programs working. Running with the default Optimus settings and booting with the inbuilt Intel GPU, I can get CUDA programs to run via the Bumblebee package under Ubuntu. ($~ optirun ./my_prog).

It doesn't fix the boot issue, but at least may offer a workaround for any others experiencing the issue. Thanks anyway.

Lee.
Reply

Replies(4)
Options

455 Posts

05-26-2012

Raleigh, North carolina

191 Signins

14841 Page Views

  • Posts: 455
  • Registered: ‎05-26-2012
  • Location: Raleigh, North carolina
  • Views: 14841
  • Message 2 of 5

Re: T430 Discrete GFX under Linux not booting

2012-07-26, 21:10 PM

Hello Loriordan,

 

I have T430 and was interested in the issues you were having and set my BIOS settings to what you stated and tried to load my Ubuntu 12.04 LTE x64 ( its on duel boot with Windows 7) and got a screen that was lined/black/purple/fuzzy and just frozen. I Know for a fact that if I revert the settings that I will be able to load into Ubuntu 12.04. As a side note windows 7 x64 bit loads fine with the BIOS setting you said. I know this isn't really a solution but a affirmation of your problem but I will be looking into it and I will get back to you with any fix or work around I can find.

 

Best Regards,

 

Hiro

Did you find a post Awesome? A response just Outstanding? Kudo them!
Did the post you read answer your question? Did someone help you figure out your problem? Hit Solution Provided and give that person a pat on the back for helping you out!
Reply
Answer
Options

3 Posts

07-21-2012

Ireland

3 Signins

16 Page Views

  • Posts: 3
  • Registered: ‎07-21-2012
  • Location: Ireland
  • Views: 16
  • Message 3 of 5

Re: T430 Discrete GFX under Linux not booting

2012-07-26, 21:45 PM
Hello Hiro,

I have found a quick-fix for getting CUDA programs working. Running with the default Optimus settings and booting with the inbuilt Intel GPU, I can get CUDA programs to run via the Bumblebee package under Ubuntu. ($~ optirun ./my_prog).

It doesn't fix the boot issue, but at least may offer a workaround for any others experiencing the issue. Thanks anyway.

Lee.

0 person found this solution to be helpful.

This helped me too

Reply
Options

8 Posts

04-08-2012

USA

11 Signins

67 Page Views

  • Posts: 8
  • Registered: ‎04-08-2012
  • Location: USA
  • Views: 67
  • Message 4 of 5

Re: T430 Discrete GFX under Linux not booting

2012-08-08, 9:26 AM

Just an FYI/Me too from a W530 owner. This problem also exists on the W530 when choosing the 'Discrete' option when running Ubuntu 12.04 with and without the Bumbelbee package installed.

 

When using Discrete, I get a very low-res GRUB screen. I select default and the screen goes purple (normal boot); the Ubuntu boot logo does not come on and eventually the HDD LED goes off. Knowing that the next thing to do would be to enter my password, I do that, but nothing happens. No HDD activity; nothing.

 

I've got to hold the power button down to turn it off. When I turn it back on, it looks like it is booting, Thinklight & keyboard light up and then it shuts down (No Lenovo POST screen) and starts back up normally.

 

-bdk

Reply
Options

7 Posts

11-04-2012

Germany

8 Signins

48 Page Views

  • Posts: 7
  • Registered: ‎11-04-2012
  • Location: Germany
  • Views: 48
  • Message 5 of 5

Re: T430 Discrete GFX under Linux not booting

2012-11-04, 18:29 PM
Hello,

i have the same issue with my T430. when i turn on the discrete graphics and boot linux (Kubuntu or Chakra), the boot will either not finish or freeze a few seconds after booting.

I would like to use the external DVI ports on the port replicator. Unfortunatally in this condition my docking station is useless, because the internal intel graphics is not connected to the external digital outputs.

Is there a solution for my problem? Are there more informations which could be helpful for you?

Thank you!
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms