cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BobTheSponge
Paper Tape
Posts: 2
Registered: ‎08-28-2019
Location: AF
Views: 1,750
Message 271 of 277

Re: ThinkPad E485/E585 - Firmware bug ACPI IVRS table

Since the latest bios update I have no computer freeze any more

 

BUT

 

After resuming from sleep, randomly, the screen stays all black, and I have to REISUB.

 

So PLEASE Lenovo, can we have a proper fix??

 

(Ubuntu 19.10 alpha)

 

 

$ lspci | grep -i VGA
05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] (rev c4)

 

Seltox
Paper Tape
Posts: 6
Registered: ‎01-24-2019
Location: AU
Views: 1,744
Message 272 of 277

Re: ThinkPad E485/E585 - Firmware bug ACPI IVRS table

Echoing the above posts.  New BIOS seems to have fixed booting issues and haven't seen any freezes.

 

Still has problem of not waking at random after having lid closed.   Does anyone know any workarounds for this problem without having to power cycle?

randombot
Paper Tape
Posts: 3
Registered: ‎08-05-2019
Location: NL
Views: 1,701
Message 273 of 277

Re: ThinkPad E485/E585 - Firmware bug ACPI IVRS table

For me disabling C6 with zenstates on every boot/wakeup is still needed.

You can automate this with systemd services.

 

I too still have issues, but this is I think related to my wifi card that I swapped for the Intel AC9260. When I disable the bluetooth service, suspend and resume works fine on gnome.

 

 

JimmyTwoShoots
Core Memory
Posts: 14
Registered: ‎01-10-2019
Location: US
Views: 1,154
Message 274 of 277

Re: ThinkPad E485/E585 - Firmware bug ACPI IVRS table

E485 status report:

 

* BIOS 1.54

* Stock Debian Buster

* boot parameters psmouse.synaptics_intertouch=1 amdgpu.ppfeaturemask=0xffffbfff

* no graphics corruption seen

* suspend/resume working

* most shocking result: idle power baseline 4.4W

 

Idle power measured is for a Gnome session with a terminal (no browser or other apps open.) Previous idle power measurements:

* BIOS 1.53, Ubuntu 19.04 w/ kernel 4.20 (a combination with no support) and iommu=pt amdgpu.ppfeaturemask=0xffffbff: 5.3W

* BIOS 1.53, Stock Ubuntu 19.04 with minimum necessary boot parameters: ~7W

 

arcooke
Punch Card
Posts: 19
Registered: ‎08-31-2018
Location: US
Views: 848
Message 275 of 277

Re: ThinkPad E485/E585 - Firmware bug ACPI IVRS table

Hey all.  Just replying here to alert E585 owners that kernel 5.3 seemed to fix the bluetooth problems!  I'm using an upgraded Intel 9260 wifi+bt card, but I had the same issues with the factory Realtek card (bluetooth not detected unless you suspend/resume).

 

I tested multiple reboots on 5.3 and bluetooth was available at startup every time

 

There are a lot of bluetooth fixes in the release info https://lkml.org/lkml/2019/9/15/241

 

 

est_
Paper Tape
Posts: 5
Registered: ‎12-06-2018
Location: NO
Views: 264
Message 276 of 277

Re: ThinkPad E485/E585 - Firmware bug ACPI IVRS table

I updated the bios today to 1.54 from 1.48 (I think) and had a few issues. Reporting here in case it might help someone else.

 

 

After the update I could not immediately boot back into my Linux install (Gentoo Linux, kernel 5.3.2). When trying to select the boot device (NVME), screen flashed for a moment and returned to the device selection menu. To try to solve this, I figured I would chroot and try to reconfigure grub.

 

 

Several times after a cold boot the computer would hang and I had to reboot with the power button. Eventually I booted into SysRescueCD (worked fine on boot which didn't hang) and chrooted. First I simply tried `grub-mkconfig -o /boot/grub/grub.cfg` as indicated in the Gentoo Handbook (https://wiki.gentoo.org/wiki/Handbook:AMD64/Installation/Bootloader). This did not work, and the same issue described above happened when trying to boot into the Linux drive. Finally, I tried to also reinstall grub using `grub-install --target=x86_64-efi --efi-directory=/boot --removable` and then running `grub-mkconfig ...` and after rebooting, I could successfully enter the grub screen and boot into Linux.

 

 

Following the BIOS update I can successfully boot into Linux with no additional kernel parameters, where before I had to use "amd_iommu=pt iommu=soft ivrs_ioapic[32]=00:14.0". Additionally, it seems the idle power usage is lower. Before, an approximate of ~6.00-6.30 hrs was reported by the XFCE Power Manager plugin, whereas now it reports ~7.00-7.30 hrs. Note that this is without running any applications and with the brightness at around 60-70%.

 

 

So conclusion is that you should be careful about updating the BIOS if you are worried about having to fix issues like these.

Highlighted
coder_kalyan
Paper Tape
Posts: 1
Registered: ‎10-09-2019
Location: US
Views: 154
Message 277 of 277

Re: ThinkPad E485/E585 - Firmware bug ACPI IVRS table

Hey all, I have been using my Lenovo E485 for a few months and just saw this thread. I was hoping to get answers to at least some problems, so here's where I am...

I have a Lenovo E485 with the 2700U and what Linux says is the Lenovo RTL8822BE Wifi adapter. I purchased my laptop with just an HDD with Windows, and aftermarket installed an M.2 NVMe on which I have installed Arch Linux. I am running the latest (1.54) BIOS and using the GRUB bootloader.

 

Although I like my laptop and use it a lot, I have a few problems that have been bugging me...

1) Bluetooth - contrary to what I have read on this chat, even with the latest Linux 5.3.5 kernel, I am unable to get the bluetooth controller to power on until I have suspended and resumed the laptop.

2) Blank screen - Sometimes, when I open the lid or wake from suspend, the screen flashes then stays blank, and I have to manually cycle power using the power button. This seems to happen more often on the latest BIOS.

3) Restart - Something really weird - if I run reboot from Linux, when the system powers back on, it boots into Windows, even though Linux is the first boot priority. When I open the boot menu, the NVMe/GRUB option is not there! It only works when I power on via power button, so I have to run shutdown and then press the power button to boot. This problem doesn't happen when in Windows - if I restart, it boots back into Linux (which it should since that is the top boot priority). This problem is very cumbersome.

4) Power usage - Even on idle, I never see usage below ~12W. Since many people seem to have much less power usage, I was hoping to find a fix for this.

5) It runs quite hot, ~45-50 idle and spikes up to 80-90 when I'm doing something CPU intensive.

6) Linux question - I get an error during bootup saying "NO IRQ HANDLER FOR VECTOR," but it doesn't seem to cause any problems. I was wondering if anyone had a solution to this.

7) Once in a while, my touchpad stops working, but the trackpoint continuous working. The touchpad then comes back on a few seconds to a minute later, but I am not sure what is causing this (it's not CPU lag).

 

I am happy to say that with the latest kernel and BIOS, I am able to boot successfully (other than the above problems) without any extra kernel parameters.

 

Thanks! Kalyan

Check out current deals!


Shop current deals

Top Kudoed Authors