Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

38 Posts

10-09-2008

Canada

215 Signins

1683 Page Views

  • Posts: 38
  • Registered: ‎10-09-2008
  • Location: Canada
  • Views: 1683
  • Message 1 of 3

Thinkpad W500 and OpenSuse 11.1

2008-12-22, 8:12 AM

I installed OpenSuse 11.1 on W500. I am very impressive.

 

What works out of the box:

    X-windows (I use Intel driver)

    Microphone

    Webcam

    Trackpoint and trackpad

    Bluetooth

    Wireless (it identified my card as 5100 rather than 5300, but still work anyway)

    Ethernet

 

    Suspend to Ram also work

 

 

What doesn't work:

    Fingerprint

    Modem? (I haven't digged into this)

 

 

 

one Issue I found is, the computer is hotter(quite obvious) under Linux compare to running on windows.

I checked cpuinfo, its frequency stays at 800mhz most of the time (just like Windows), I don't know which parts generate so much heat.  Maybe the unused AMD graphic core? (I set to use integrated GPU in BIOS)

 

 if anyone has idea about why W500 is hotter in Linux, plz let me know.

 

thanks in advance. 

 

 

 

 

Reply
Answer
Options

99 Posts

08-24-2008

Portugal

134 Signins

751 Page Views

  • Posts: 99
  • Registered: ‎08-24-2008
  • Location: Portugal
  • Views: 751

Re: Thinkpad W500 and OpenSuse 11.1

2008-12-22, 12:29 PM

I can't think of anything other than the ATI card.

I consistently have the following behaviour:

 

BIOS set to switchable, console mode, ATI card always above +50C, lots of heat.

BIOS set to integrated, console or graphics mode, ATI card temperature unreadable, the wind that comes out seems to be cool (I would even say fresh).

BIOS set to discrete, console mode, ATI card above +50C.

BIOS set to discrete, graphics mode with fglrx driver, ATI card at 34C, warm wind.

 

Consequently, it seems to me that the only thing that can be generating such heat is the graphics card, and would tell you to recheck your BIOS setting.

 

I'm running Gentoo. The only thing which is not working right now and bothers me is the suspend-to-ram.

I wish it was working out of the box. LCD brightness controls took a bit, everything else didn't take much time.

 

 

Miguel

 

Message Edited by migle on 12-22-2008 12:30 PM
Message Edited by migle on 12-22-2008 12:31 PM
W500 4062-2XG Gentoo Linux 64
Reply

Replies(2)
Answer
Options

99 Posts

08-24-2008

Portugal

134 Signins

751 Page Views

  • Posts: 99
  • Registered: ‎08-24-2008
  • Location: Portugal
  • Views: 751
  • Message 2 of 3

Re: Thinkpad W500 and OpenSuse 11.1

2008-12-22, 12:29 PM

I can't think of anything other than the ATI card.

I consistently have the following behaviour:

 

BIOS set to switchable, console mode, ATI card always above +50C, lots of heat.

BIOS set to integrated, console or graphics mode, ATI card temperature unreadable, the wind that comes out seems to be cool (I would even say fresh).

BIOS set to discrete, console mode, ATI card above +50C.

BIOS set to discrete, graphics mode with fglrx driver, ATI card at 34C, warm wind.

 

Consequently, it seems to me that the only thing that can be generating such heat is the graphics card, and would tell you to recheck your BIOS setting.

 

I'm running Gentoo. The only thing which is not working right now and bothers me is the suspend-to-ram.

I wish it was working out of the box. LCD brightness controls took a bit, everything else didn't take much time.

 

 

Miguel

 

Message Edited by migle on 12-22-2008 12:30 PM
Message Edited by migle on 12-22-2008 12:31 PM
W500 4062-2XG Gentoo Linux 64

0 person found this solution to be helpful.

This helped me too

Reply
Options

38 Posts

10-09-2008

Canada

215 Signins

1683 Page Views

  • Posts: 38
  • Registered: ‎10-09-2008
  • Location: Canada
  • Views: 1683
  • Message 3 of 3

Re: Thinkpad W500 and OpenSuse 11.1

2008-12-22, 19:25 PM

Thanks for the suggestion, I found it was AMD GPU caused the heat issue.

 

I set to use Integrated GPU before, but I didn't disable the switchable auto-detection  by OS, so Vista turned the BIOS setting to switchable again!

 

after disable the auto-detection, now seems the heading back to normal. 

 

thanks!

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All