cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JosephJ
Not applicable
Posts: 10
Registered: ‎07-16-2017
Location: US
Views: 14,128
Message 1 of 6

Thinkpad X1 Yoga 2nd Gen - Most Compatible Linux Distro Question

Not sure why posts asking about installing an OS other than Windows 10 on this device seem to vanish but here goes my attempt for a Linux Specific question.

 

I am unwilling to run Windows 10 because an OS that without any advance notice will uninstall your privately owned and paid for software from other companies during updates potentially costing licensing fees to acquire a replacement license or even damaging system viability if one of those packages is a required driver is unacceptable to me.

 

Due to the aforementioned issues with Windows 10 I am looking to Linux as an alternative for this device.

 

Are there any known Linux Distributions that will fully support the hardware?

Does anyone have experience installing Linux and configuring it on this device?

What Linux Distribution is most recommended for this device?

What additional drivers or software are recommended on Linux to be able to use the hardware to the fullest?

 

Thanks.

 

 

schuifpui
Not applicable
Posts: 26
Registered: ‎11-01-2016
Location: NL
Views: 14,042
Message 2 of 6

Re: Thinkpad X1 Yoga 2nd Gen - Most Compatible Linux Distro Question

hi,

 

I don't recognize the issues you've had with windows 10, but I understand it is a good motivation for you to explore alternatives. If you have had little expereince with Linux before, I would recommend Ubuntu, as it has good drive support and a large user community. If you don't need the latest and greatest gizmo's then I would recommend CentOS, a more conservative (INHO more stable) distro, but maybe not with the latest hardware support. I have not tried them out (yet) on a Yoga, so just put a  liveCD on a USB stick to try things out first, before you start wiping hard disks. Have fun and let us know!

X1 Yoga 2nd gen - i7-7600U - 16 GB - 1 TB NVMe - 2k display
P70 - Xeon E3-1575M v5 - 64GB - 2+2 TB NVMe - 4k display - Quadro M5000M
W520 - i7-2820QM - 32 GB - 2 TB SSD - FHD - Quadro 2000M
T140 - Xeon E3-1245 v3 - 32 GB - 1+1 TB SSD
JosephJ
Not applicable
Posts: 10
Registered: ‎07-16-2017
Location: US
Views: 14,015
Message 3 of 6

Re: Thinkpad X1 Yoga 2nd Gen - Most Compatible Linux Distro Question

For the issue itself:
https://www.google.com/?gws_rd=ssl#q=windows+10+update+uninstalled+programs

Your solution is elegant and shows my aged Windows thinking. I forget Linux can be run without having to do whole installs by using LiveCD/USB builds.

teramind
Not applicable
Posts: 1
Registered: ‎11-30-2017
Location: DE
Views: 10,134
Message 4 of 6

Re: Thinkpad X1 Yoga 2nd Gen - Most Compatible Linux Distro Question

I tested Fedora 27. Most things work out of the box. The screen brightness-fn keys do not work. The pen works, but when the x1 yoga 2nd is in tablet mode the screen does not rotate according to the device. Also the virtual keyboard is way to small. And I have an issue with the activities menu. But I am on a usb-image, so that issues might have been addressed in the mean time.

TwoD
Not applicable
Posts: 1
Registered: ‎12-15-2017
Location: SE
Views: 9,466
Message 5 of 6

Re: Thinkpad X1 Yoga 2nd Gen - Most Compatible Linux Distro Question

Does your laptop happen to use an OLED screen? Mine does and since OLEDs do not actually have a backlight they do not react to the backlight levels being changed. (You can actually see the levels changing when the keys are pressed by running 

cat /sys/class/backlight/intel_backlight/brightness

To work around this I have a small script running which listens to those changes and recalculates them to a value between 0 and 1 (depending on the value of max_brightness from the same folder).

It's based off posts like this one:
https://askubuntu.com/questions/824949/lenovo-thinkpad-x1-yoga-oled-brightness

#!/bin/sh

path=/sys/class/backlight/intel_backlight

luminance() {
    read -r level < "$path"/actual_brightness
    bc <<< "scale=10;$level/$max"
}

read -r max < "$path"/max_brightness
xrandr --output eDP-1 --brightness "$(luminance)"

inotifywait -me modify --format '' "$path"/actual_brightness | while read; do
    echo $(luminance)
    xrandr --output eDP-1 --brightness "$(luminance)"
done

Since it depends on xrandr it only works while an X server is running, so I've set it to launch as soon as the server goes up by adding this to my ~/.xinitrc

/path/to/oled-script &
paulgr
Not applicable
Posts: 3
Registered: ‎08-31-2017
Location: US
Views: 4,337
Message 6 of 6

Re: Thinkpad X1 Yoga 2nd Gen - Most Compatible Linux Distro Question

I just put Kubuntu 18.04 (I would guess that Ubuntu 18.04 would workd just as well) on my x1 Yoga 2nd gen, and it's the real first really out of box experience I've had with linux, and it has worked exceptionally well on my x1 Yoga.  I replaced Linux Mint 18.3 as my distro because it had too many wacom pen glitches.  I would have to hold the pen to the screen and wait 20 seconds for it to respond.  It was very aggrivating. I'm guessing that Ubuntu's recent kernel update has really helped with wacom pen issue.  Hopefully, this will trickle down to Linux Mint soon (which is a distro that I would highly recommend)--just not sure of its X1 yoga support.  Just as a side note, the one thing that I'm not sure about with Ubuntu is the screen hand gestures, which I haven't been able to get working.  I've only had the system up and running for a day, so this may be an easy fix that I just haven't invested enough time in.  As far as keyboard, trackpad, nub, support for 2560x1440 native resolution (just scale the display in Kubuntu monitor app or in Font section of settings and/or change font sizes), support for wacom, mouse, wifi, ethernet, shared hard drive in dual boot with windows--so far everything is perfect!  Linux has come a long way with this latest Ubuntu release! The stylus is so responsive in Kubuntu, I'm thinking it might even work better than on my Windows 10 where it works almost flawlessly. 

 

I also had an issue with the X1 yoga and the brightness control, but I've already fixed this on Linux mint and then again on Kubuntu 18.04.  I see that others have posted solutions for this, but it can be difficult to implement for a real beginner.  Here is what I did to solve that problem:

 

The quick fix is of course to type xrandr --output eDP-1 --brightness 0.4 # dims to 40%
into the command line, adjusting the percentage to move dimmer up and down, but you will have to redo it every time you reboot.

 

This script implementation below, however, worked for me on X1 Yoga 2nd Gen running Kubuntu 18.04.  After I ran this, I can just press the F5 and F6 buttons and adjust the brightness like a normal human being. 

 

I'm super thankful the writer of this script:

Go here and check out item 9 by Elder Geek:


https://askubuntu.com/questions/824949/lenovo-thinkpad-x1-yoga-oled-brightness

 

Using his scripts, follow these instructions for hopefully flawless implimentation of the script:

 

1) $ cd /etc/acpi/events
2) $ sudo touch oled-brightness-up [creates file]
3) $ sudo gedit oled-brightness-up [You may need to download gedit text editor or use your own editor]
3) copy and paste corresponding text/script from web page
4) change the second line's directory so it reads like this: action=/usr/local/bin/oled-brightness.sh up [The file wouldn't execute from the etc/acpi directory, so I put the sh script in an executable directory]
5) save it and exit text editor
6) $ sudo touch oled-brightness-down
7) $ sudo gedit oled-brightness-down
8) copy and paste corresponding script from web page
9) change the second line's directory so it reads like this: action=/usr/local/bin/oled-brightness.sh down
10) save it and exit text editor
11) cd /usr/local/bin or use another directory with PATH permissions [type "$PATH" in command line to confirm it is located in PATH: $ $PATH]
12) sudo touch oled-brightness.sh [The usr/local/bin directory is connected to PATH, so the file will be executable from here. This is why I changed the directory in the brightness-up and brightness-down files]
User@Linux$ touch
13) $ sudo gedit oled-brightness.sh
14) copy and paste corresponding script from web page
15) Make sure that you change resandro to your user name on line 4: export XAUTHORITY=/home/resandro/.Xauthority
16) You may need to change eDP1 to eDP-1 on lines 24 and 26 depending on your set up. Pay especially close attention to this. It took me about an hour to figure this out!
17) $ xrandr [To see if your which embedded display port (eDP) you have (eDP1 or eDP-1)
17) $ sudo chmod 554 oled-brightness.sh [This is to change the permissions of the file so it is executable]
18) save it and exit text editor
19) Finally: "Remove any previous brightness handlers, and finally, do" $ sudo service acpid reload

Considerations:
I've noticed that this script does not work well while Redshift is running. So, shut that down first if you are using it.

Check out current deals!


Shop current deals

Top Kudoed Authors