English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

5 Posts

12-10-2018

DE

10 Signins

75 Page Views

  • Posts: 5
  • Registered: ‎12-10-2018
  • Location: DE
  • Views: 75
  • Message 11 of 21

Re: Thinkpad e485 bios 1.45 resume from suspend failed - Linux

2019-01-10, 15:49 PM

4.18.11 is your kernel, but what BIOS are you using?

Reply
Options

18 Posts

10-06-2018

AT

180 Signins

1267 Page Views

  • Posts: 18
  • Registered: ‎10-06-2018
  • Location: AT
  • Views: 1267
  • Message 12 of 21

Re: Thinkpad e485 bios 1.45 resume from suspend failed - Linux

2019-01-10, 16:38 PM

Test ist with BIOS 1.45 anderen Kernel 4.18.11. archlinux and Ubuntu works. 

 

 

Reply
Options

5 Posts

12-10-2018

DE

10 Signins

75 Page Views

  • Posts: 5
  • Registered: ‎12-10-2018
  • Location: DE
  • Views: 75
  • Message 13 of 21

Re: Thinkpad e485 bios 1.45 resume from suspend failed - Linux

2019-01-11, 6:23 AM

So obviously you need BIOS <1.32 or a kernel <4.18.12 - or both of course.

Reply
Options

18 Posts

10-06-2018

AT

180 Signins

1267 Page Views

  • Posts: 18
  • Registered: ‎10-06-2018
  • Location: AT
  • Views: 1267
  • Message 14 of 21

Re: Thinkpad e485 bios 1.45 resume from suspend failed - Linux

2019-01-11, 7:33 AM

i try it out and it works for me. 

 

ubuntu 18.10 works really good, only need iommu=soft. 

Reply
Options

25 Posts

01-03-2019

AU

43 Signins

300 Page Views

  • Posts: 25
  • Registered: ‎01-03-2019
  • Location: AU
  • Views: 300
  • Message 15 of 21

Re: Thinkpad e485 bios 1.45 resume from suspend failed - Linux

2019-01-11, 20:41 PM

I confirm using iommu=soft with bios 1.48 ubuntu 18.10 kernel 4.20 everything works great.

Reply
Options

5 Posts

12-10-2018

DE

10 Signins

75 Page Views

  • Posts: 5
  • Registered: ‎12-10-2018
  • Location: DE
  • Views: 75
  • Message 16 of 21

Re: Thinkpad e485 bios 1.45 resume from suspend failed - Linux

2019-01-11, 22:15 PM
Not here it doesn't. Works sometimes but definitely not for longer suspends.
Reply
Options

18 Posts

10-06-2018

AT

180 Signins

1267 Page Views

  • Posts: 18
  • Registered: ‎10-06-2018
  • Location: AT
  • Views: 1267
  • Message 17 of 21

Re: Thinkpad e485 bios 1.45 resume from suspend failed - Linux

2019-07-16, 11:12 AM

https://www.phoronix.com/scan.php?page=news_item&px=Ryzen-3K-RdRand-Systemd-Maybe

 

suspend and resume works with arch linux. (systemd-242.32-3)

 

 

 

Reply
Options

4 Posts

07-17-2019

UA

17 Signins

145 Page Views

  • Posts: 4
  • Registered: ‎07-17-2019
  • Location: UA
  • Views: 145
  • Message 18 of 21

Re: Thinkpad e485 bios 1.45 resume from suspend failed - Linux

2019-07-17, 16:01 PM

 wrote:

https://www.phoronix.com/scan.php?page=news_item&px=Ryzen-3K-RdRand-Systemd-Maybe

 

suspend and resume works with arch linux. (systemd-242.32-3)

 

 

 


Great news! Thanks. So the main problem with sleep/wake hanging is connected to wrong entropy supplied by rdrand function? In comments i found the link to bugtracker issue/fix:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1835809
"The fix itself is very small, it ignores known to be faulty random values returned by the rdrand instruction and use a different random source"
From now on suspend/resume works fine on all kernel/bios version?

Reply
Options

18 Posts

10-06-2018

AT

180 Signins

1267 Page Views

  • Posts: 18
  • Registered: ‎10-06-2018
  • Location: AT
  • Views: 1267
  • Message 19 of 21

Re: Thinkpad e485 bios 1.45 resume from suspend failed - Linux

2019-07-18, 9:30 AM

suspend/resume works again for me now. 

arch-linux

bios: 1.53

kernel: 5.2.1

boot: amd_iommu=pt ivrs_ioapic[32]=00:14.0 iommu=soft trace_clock=global

 

bios: disable tpm / bluetooth / windows stuff 

Reply
Options

1 Posts

09-20-2019

ES

1 Signins

13 Page Views

  • Posts: 1
  • Registered: ‎09-20-2019
  • Location: ES
  • Views: 13
  • Message 20 of 21

Re: Thinkpad e485 bios 1.45 resume from suspend failed - Linux

2019-09-20, 8:06 AM

But if you disable bluetooth when you run the OS you won't bluetooth device connected. I used a bluetooth mouse and I need bluettoth support.

If I disable AMD-V then supend mode works, but VirtualBox haven't.

I don't find a bios settings to get supend mode and virtualization works without problem.

Any suggestions?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete