Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit our eSupport here.

English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

4 Posts

05-02-2018

Austria

8 Signins

78 Page Views

  • Posts: 4
  • Registered: ‎05-02-2018
  • Location: Austria
  • Views: 78
  • Message 111 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-05-04, 9:00 AM

Yes, I used that patch.
I am on BIOS 1.10, that shouldn't be the problem.

Hibernate doesn't work for me. `pm-hibernate` just briefly turns off the screen. That's in kernel log:

...
[24036.572895] PM: Image saving progress:  30%
[24037.049246] PM: Image saving progress:  40%
[24037.337624] PM: Wrote 6498668 kbytes in 2.24 seconds (2901.19 MB/s)
[24037.474773] PM: Basic memory bitmaps freed
[24037.474776] OOM killer enabled.
[24037.474776] Restarting tasks ... done.
[24037.539864] PM: hibernation exit

I guess it fails because my swap partition is only 1 GB (for some reason the Ubuntu installer picked that as default), while as far as I understand it would need to be 16 GB+. I'll try to resize. Is there any other settings required for hibernate to work?

Reply
Options

27 Posts

03-24-2018

United States of America

161 Signins

1183 Page Views

  • Posts: 27
  • Registered: ‎03-24-2018
  • Location: United States of America
  • Views: 1183
  • Message 112 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-05-04, 11:36 AM

Yeah you need a swap partition at least as big as memory size.  Here are my notes on making it work after you have the swap setup (for fedora).

 

This script modifies grub entries to allow hibernation, points the kernel to the correct swap device, and regenerates grub efi settings:

#!/bin/bash
# Enable hibernation
# Using info from:
# https://psohny.wordpress.com/2015/08/13/fedora_hiber/

# Enable recovery in the /etc/default/grub
sed -i -e 's|^\(GRUB_DISABLE_RECOVERY="\)true"|\1false"|' /etc/default/grub

#Find the swapdevice
SWAPDEVICE=`grep -e '^[^#].*swap' /etc/fstab | head -n 1 | cut -d ' ' -f 1`
echo "Using SWAPDEVICE=${SWAPDEVICE} for hibernation"

#add "resume=swapdevice" to the GRUB_CMDLINE_LINUX=
sed -i -e "s|^\(GRUB_CMDLINE_LINUX=\".*\)\"|\1 resume=${SWAPDEVICE}\"|" /etc/default/grub

#Regenerate the grub config
sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

after doing this, the relevant part of my /etc/default/grub looks like this:

GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet resume=/dev/mapper/fedora-swap"
GRUB_DISABLE_RECOVERY="false"

2. Make sure hibernate is the default lid switch method.  In /etc/systemd/logind.conf, add this to the end of the [Login] section (it may already be a commented out entry in the file, in which case you can just uncomment it):

HandleLidSwitch=hibernate

You'll need to restart.  Once it all works, it takes approximately 10-15 seconds to exit hibernation after opening the lid.  Also there are no keyboard backlight flickering problems either . It is very solid. 

Reply
Options

2 Posts

05-06-2018

United States of America

17 Signins

314 Page Views

  • Posts: 2
  • Registered: ‎05-06-2018
  • Location: United States of America
  • Views: 314
  • Message 113 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-05-06, 18:36 PM

Need help with step 5 of https://delta-xi.net/#056. I have the dsdt rejected file, however there is an abnormally large amount of lines in the file. At least 30 lines with the (-) symbol, which I think needs to be removed in the .dsl file. Normally there is only 2 lines with the (-) symbol right? The 2 "One" lines, which needs to be removed in the .dsl file. What should I do? Is there any fix to this?

Reply
Options

8 Posts

05-10-2018

Canada

19 Signins

214 Page Views

  • Posts: 8
  • Registered: ‎05-10-2018
  • Location: Canada
  • Views: 214
  • Message 114 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-05-10, 2:47 AM

To avoid having to modify grub.cfg after every kernel upgrade when using the DSDT patch, use this initramfs-tools hook:

 

#!/bin/sh

. /usr/share/initramfs-tools/hook-functions
prepend_earlyinitramfs /boot/acpi_override

Save that as /etc/initramfs-tools/hooks/acpi_override.sh and give it exec permissions. Any time an initramfs is generated (e.g. when installing new kernels), this hook will prepend the acpi_override.

Reply
Options

93 Posts

07-28-2017

Germany

130 Signins

1420 Page Views

  • Posts: 93
  • Registered: ‎07-28-2017
  • Location: Germany
  • Views: 1420
  • Message 115 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-05-10, 16:57 PM

This "modern Standby" is just useless. I use Windows, with that Sleepmode (S0i3) battery went from 95% to 65% over night. Thats not what i want und expect from a device in SleepMode.

Reply
Options

4 Posts

05-14-2018

Canada

12 Signins

178 Page Views

  • Posts: 4
  • Registered: ‎05-14-2018
  • Location: Canada
  • Views: 178
  • Message 116 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-05-15, 0:52 AM

Would you mind sharing how to disabled the SD card reader? I couldn't find it in the BIOS settings. Couldn't find anything concrete on the OS itself either. Thanks :)

Reply
Options

35 Posts

04-08-2018

Germany

99 Signins

771 Page Views

  • Posts: 35
  • Registered: ‎04-08-2018
  • Location: Germany
  • Views: 771
  • Message 117 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-05-15, 4:53 AM

Had some trouble finding that myself. It's under "Security".

Reply
Options

4 Posts

05-14-2018

Canada

12 Signins

178 Page Views

  • Posts: 4
  • Registered: ‎05-14-2018
  • Location: Canada
  • Views: 178
  • Message 118 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-05-16, 0:38 AM

Hi Rydeen, thanks for the information. I echo Esonn and fiji-flo; the lack of S3 support makes this laptop nearly impossible to use. A seperate Linux focused BIOS/UEFI image (unofficial is fine) would be fantastic for those of us in the Linux world.


Is there a way we can make an official feature request?  

Reply
Options

1 Posts

05-16-2018

United States of America

3 Signins

47 Page Views

  • Posts: 1
  • Registered: ‎05-16-2018
  • Location: United States of America
  • Views: 47
  • Message 119 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-05-16, 4:21 AM

I for one would also like to see Lenovo at least tell us definitively whether or not they are going to support S3 in the future. Lenovo should be aware that we users value predictability.

Reply
Options

35 Posts

04-08-2018

Germany

99 Signins

771 Page Views

  • Posts: 35
  • Registered: ‎04-08-2018
  • Location: Germany
  • Views: 771
  • Message 120 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-05-16, 4:36 AM
I'm afraid they don't even read this thread.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms