Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

35 Posts

04-08-2018

Germany

99 Signins

771 Page Views

  • Posts: 35
  • Registered: ‎04-08-2018
  • Location: Germany
  • Views: 771
  • Message 131 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-06-24, 7:56 AM

Has anyone tried the current BIOS version 1.23 yet? Does it work OK with Linux? Does it solve any of the problems running Linux on the X1C?

Reply
Options

4 Posts

06-24-2018

United States of America

10 Signins

105 Page Views

  • Posts: 4
  • Registered: ‎06-24-2018
  • Location: United States of America
  • Views: 105
  • Message 132 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-06-24, 19:44 PM

BIOS update won't work. I didn't bother trying. (Read further below for info on that)

 

What fixed it for me

Okay so I gave the fix from delta-xi a try and looks like it works well for me as well.

 

From his page here:

They removed traditional deep sleep (ACPI S3 sleep state) in favor of a new, Microsoft-driven sleep state called Windows Modern Standby, aka Si03. This sleep state doesn't fully turn off all components except for main memory, but puts the devices themselves into an ultra low-power state. This way, much like modern smartphones do, some devices can briefly wake up particular components of the system - most notably communication devices. The idea is, to have an always-connected feature, to e.g. download updates while sleeping or stay connected to a WiFi during sleep. This may or may not be preferable idea, but for me it is not.

 

On the Intel Core architecture, Linux doesn't deal with Si03 too well (as opposed to Intel Atom CPUs) and suspend energy consumption is around 4 watts on the X1, which is extremely high and won't even give you a single day of suspend time.

 

The issue is that Lenovo has opted to solely adopt a new standby protocol disregarding the previously used one supported by ACPI. (In my opinion not giving a backwards compatible option is quite irresponsible and I can understand the frustration of others on this forum)

 

To fix this, you need to perform some things which a new user may feel uncomfortable with, but it does fix the issue.

Again, the instructions are here.

 

Some differences in implementation I took from this post:

  • You may want to copy and paste the "menuitem{[...]}" from /boot/grub/grub.cfg
    and modify "initrd" to "initrd /acpi_override" in the line containing it. Paste it into:
    /etc/grub/40_custom

    then run:
    # update-grub
    This way if grub is autogenerated, you don't have to worry about it
  • The default suspend state may be [s2idle]
    try:
    cat /sys/power/mem_sleep
    [s2idle] deep
    If you see 's2idle' in square brackets, you can change it to deep by doing the following:
    echo "deep" > /sys/power/mem_sleep
    you'll then see:
    cat /sys/power/mem_sleep
    s2idle [deep]
    This forces the laptop lid close to enable the S3 suspension, not the idling, which consumes at least 20 times less power.

Why I think BIOS update won't help

From the forum, it sounds like interaction with Lenovo support was negative and that they have refused to offer S3 support by upgrading their BIOS. I took a look at the summary of changes of their last BIOS update (which includes list of changes from the very beginning) and there is no mention of adding th S3 suspend state.

See the summary of changes here. Search for string "summary of changes"

 

I think we just need to wait for ACPI to catch up.

 

 

Anyway, with my personal experience, I would say to stay away from Lenovo. Not a good company. My prevoius laptop was a Dell XPS13 and I have never had issues (it's 3.5 years old and I mainly got a new laptop because I was offered budget money for it). For any issues I did have I had amazing support! BIOS updates were released for linux related issues! I'm strongly considering returning it tomorrow if my company will allow me and getting a newer version of the XPS.

Reply
Options

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-06-25, 0:18 AM

 I am deeply dissatisfied with Lenovo playing the moronic Microsoft fiddle. Bad breed MS can't help it to try sneak their way into BIOSes and taking over Hardware. Lenovo gave in to the candy of MS sales reps. If Lenovo does not change course and open up to FOSS with dedication and sincerity, I will soon toss this Carbon as I did already with the Virus from Redmond it came with pre-installed.

 

I'm a senior cloud architect and can't afford to play silly BIOS patch games because some world domination attitude of a single software vendor. To not being able to use Linux as a work tool would mean the end of my professional carrer. Lenovo - I will blog about this and yes this will damange your reputation in the IT community, my blog readers are from Google, Intel, Amazon and other Tier 1 ICT companies. Lenovo - we are watching!

Reply
Options

11 Posts

04-24-2018

Finland

24 Signins

161 Page Views

  • Posts: 11
  • Registered: ‎04-24-2018
  • Location: Finland
  • Views: 161
  • Message 134 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-06-25, 3:56 AM

Following delta-xi's instructions I get the deep sleep working. However, the usage is still .5 W/h *and* touchpad becomes completely untrustable. Sometimes touchpad doesn't work at all no matter what modprobes I execute.

Reply
Options

21 Posts

03-29-2014

United States of America

46 Signins

601 Page Views

  • Posts: 21
  • Registered: ‎03-29-2014
  • Location: United States of America
  • Views: 601
  • Message 135 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-06-26, 20:42 PM

I'm really on the fence about whether to buy an X1 Gen 6. Costco has a great deal right now but I'm very conerned about all the issues that people are having with the touchpad and suspend-to-RAM with linux, which is the OS I would be installing (debian testing). I've read many threads but it's not clear to me how satisfactory the various workarounds are. Would a few people care to weigh in on this? Are these issues dealbreakers? I'm reluctant to support a company that doesn't seem to be responsive to the needs of the linux community.

Reply
Options

5 Posts

03-04-2018

Canada

22 Signins

248 Page Views

  • Posts: 5
  • Registered: ‎03-04-2018
  • Location: Canada
  • Views: 248
  • Message 136 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-06-26, 20:46 PM

@Rydeen Any official updates?

 

Clearly there's still a lot of frustration from many customers.

Reply
Options

11 Posts

03-03-2018

United States of America

47 Signins

598 Page Views

  • Posts: 11
  • Registered: ‎03-03-2018
  • Location: United States of America
  • Views: 598
  • Message 137 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-06-26, 21:13 PM

@tim54 I encountered some hiccups along the way, but was eventually able to get the instructions from here working. However, I'm on Fedora, so take with the appropriate amount of salt.

 

The situation is now almost entirely satisfactory. In sleep mode, my machine consumes less than .15 watts per hour, and I haven't had any of the touch pad issues others have reported.

 

The one lasting annoyance is that I have to edit my grub file to include the /acpi_override after every kernel update (which is quite often, because Fedora). I've tried editing various grub config files, but can't seem to make the right edit to automatically add this after each update, so I just add it manually each time. It only takes 10 seconds, but still annoying.

 

Overall, I have to say that I'm extremely happy with this hardware, and now that I've got sleep working, I'm a happy camper. However, It's really unfortunate that Lenovo seems not to value it's Linux customers, and that will certainly be a factor I take into account when I buy my next machine.

Reply
Options

35 Posts

04-08-2018

Germany

99 Signins

771 Page Views

  • Posts: 35
  • Registered: ‎04-08-2018
  • Location: Germany
  • Views: 771
  • Message 138 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-06-26, 21:15 PM

To be honest, I don't think I would buy it again or that I will buy or recommend a Thinkpad anytime soon. I'm really disappointed with the complete lack of support from Lenovo. They even completely ignore this part of the forum. Sure, there are workarounds for most, if not all problems with Linux on the latest generation of Thinkpads, thanks to the great community and lots of people willing to invest time and share their solutions. However, from my past experience with Lenovo I'd never have expected that there would be so many problems in the first place. They really don't seem to care about professional users running Linux anymore.

Reply
Options

5 Posts

04-12-2018

Switzerland

9 Signins

143 Page Views

  • Posts: 5
  • Registered: ‎04-12-2018
  • Location: Switzerland
  • Views: 143
  • Message 139 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-06-26, 21:30 PM

Short answer: DONT BUY IT. The fact, that lenovo DOES NOT answer is just proof, that they don't care. And I don't buy this BS with not supporting "unveryfied software" - there is a problem with the S3 sleep system - do a bloody bios update, where we can turn it off.

Reply
Options

8 Posts

05-10-2018

Canada

19 Signins

214 Page Views

  • Posts: 8
  • Registered: ‎05-10-2018
  • Location: Canada
  • Views: 214
  • Message 140 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-06-26, 21:43 PM

@tim54, your intended setup is exactly mine. X1C6 with HDR screen and Debian Testing. I did the ACPI fix and managed to get deep sleep without any hiccups. I haven't had any problem with the touchpad or the keyboard. I know Lenovo has let everyone down here, but I got Debian to work perfectly and I'm in love with this machine.

 

At least for Debian, you can add an initramfs hook that will prepend the acpi patch on every update, so you don't have to update every time. I posted it here some weeks ago, in page 11: https://forums.lenovo.com/t5/Linux-Discussion/X1-Carbon-Gen-6-cannot-enter-deep-sleep-S3-state-aka-Suspend-to/m-p/4071927/highlight/true#M10957

 

@walkie, I don't know about Fedora, but the initramfs hooks thing didn't look like a Debian specific thing. I think it should be possible.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All