Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

15 Posts

03-05-2018

Australia

27 Signins

410 Page Views

  • Posts: 15
  • Registered: ‎03-05-2018
  • Location: Australia
  • Views: 410
  • Message 161 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-07-03, 0:58 AM

@Rydeen

"We are listening to your comments"

 

No, no you are not. You are reading our comments but are not actually bothering to listen to or understand them. For people who want to use Linux on these laptops and have a proper working sleep feature you aren't offering any solutions or workarounds to the problem. Everyone is getting frustrated with how difficult the current workaround is while all you are doing is putting your resources into optimizing the machine for Windows.

I imagine to most people here your comment has caused more harm than it has done good because all you are really saying is that you don't really care about Linux on Thinkpad anymore.

Do the right thing for once. Give us an official workaround/solution for sleep on Linux, if your current focus is truely "to provide more stable, highest performance but lowest energy consumption,  silent and cooler systems" then that is what you SHOULD do for us LINUX users.

Reply
Options

35 Posts

04-08-2018

Germany

99 Signins

771 Page Views

  • Posts: 35
  • Registered: ‎04-08-2018
  • Location: Germany
  • Views: 771
  • Message 162 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-07-03, 7:55 AM

Thank you @Rydeen, that was a very insightful answer. From my point of view it confirms that Lenovo certainly values us "linux customers" - just not enough to provide us with a statement that takes more than a few seconds to write, let alone invest any development resources into improving OS compatibility. Unfortunately there seems to be no Laptop manufacturer who does this to the extend I would consider optimal, but at least there are some who make an effort. I think in the future I will rather take my valued linux customer money to one of them. For example Dell's Project Sputnik seems to be something worth encouraging. My hope is that maybe there are more linux customers out there than a company like Lenovo might be aware of and that over time one of these companies realizes that it could be worth targeting this user group. Writing and talking about our experience can't hurt.

Reply
Options

27 Posts

03-24-2018

United States of America

161 Signins

1183 Page Views

  • Posts: 27
  • Registered: ‎03-24-2018
  • Location: United States of America
  • Views: 1183
  • Message 163 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-07-03, 8:52 AM

I realize this is a linux only thread (and I am running Fedora on my X3 Yoga), but it is worth noting that the Modern Standby problems are also occuring on Windows [see this thread].  In fact, my modern standby results (while hardly anything close to being acceptable at 1.3W/hr in Modern Standby on Linux) is actually BETTER than people on the other thread are getting on Windows by a wide margin.

 

The problem is Modern Standby not linux support for it (ok, support in Linux could be better) as it is awful on Windows as well as Linux based on the feedback in the other link.  The linux community would be letting Lenovo off the hook if somehow the takeway message was that a small group of linux "enthusiasts" were getting bad Modern Standby results, when in fact the issues extend to Windows.  All users would benefit from S3 support.

Reply
Options

5 Posts

03-04-2018

Canada

22 Signins

248 Page Views

  • Posts: 5
  • Registered: ‎03-04-2018
  • Location: Canada
  • Views: 248
  • Message 164 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-07-03, 14:17 PM
@Rydeen, I reached out over PM and I thank you for posting a public response. I didn't realize that you were entirely giving up on "legacy" S3.

I appreciate the team needing to work on stability and performance, but every Thinkpad community I'm a member of (here, http://reddit.com/r/thinkpad, etc), the #1 thing people are complaining about is the lack of good sleep support.

Is it possible that the team's priorities need to be re-evaluated?

What can we do as a community to convince you of this?

Is there a different Lenovo employee that we should speak with? Should we start a petition? Should we show up on the lawns of Lenovo's HQ and wave our X1 Carbons around while chanting?

Please give us something actionable to do that will get proper sleep support *compatibility* on Linux. You can call it legacy or whatever you want to call it, but it's a core feature that needs to be functional.

Thank you!
Reply
Options

27 Posts

03-24-2018

United States of America

161 Signins

1183 Page Views

  • Posts: 27
  • Registered: ‎03-24-2018
  • Location: United States of America
  • Views: 1183
  • Message 165 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-07-06, 10:51 AM

Judging by this response to another Linux customer, Lenovo is not recommending the X1C6 for linux at this time due to the S0i3 sleep issue.

Reply
Options

12 Posts

05-01-2018

United States of America

22 Signins

204 Page Views

  • Posts: 12
  • Registered: ‎05-01-2018
  • Location: United States of America
  • Views: 204
  • Message 166 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-07-07, 16:22 PM

I have to install Windows 7 for work related reasons, and Windows Modern Standby and s3 don't work on Windows 7.

 

I need proper s3 suspend to ram support for my WINDOWS.

Reply
Options

35 Posts

04-08-2018

Germany

99 Signins

771 Page Views

  • Posts: 35
  • Registered: ‎04-08-2018
  • Location: Germany
  • Views: 771
  • Message 167 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-07-07, 16:47 PM

@Rydeen Since here are more and more Windows users complaining about shortcomings of "modern standby" in Windows, are there any chances Lenovo might consider improving customer satisfaction of Windows users by letting them choose between both options in the BIOS?

Reply
Options

2 Posts

07-07-2018

Russian Federation

2 Signins

47 Page Views

  • Posts: 2
  • Registered: ‎07-07-2018
  • Location: Russian Federation
  • Views: 47
  • Message 168 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-07-07, 21:27 PM

My experience with S0i3 with Ubuntu 18.04:

- I'm on kernel 4.17.4-041704
- Enable Thunderbolt 3 compatibility mode in the BIOS
- Disable internal card reader in BIOS (under security settings)

- Disable Wake On LAN

- Disable Always USB
- Add kernel flag: acpi.ec_no_wakeup=1

 

After this actions my X1C6 sleeping very long.

 

upower -i /org/freedesktop/UPower/devices/battery_BAT0
  native-path:          BAT0
  vendor:               LGC
  model:                01AV494
  battery
    state:               discharging
    energy:              58,02 Wh
    energy-empty:        0 Wh
    energy-full:         61,26 Wh
    energy-full-design:  57 Wh
    energy-rate:         0,552 W
    time to empty:       4,4 days
    percentage:          94%
    capacity:            100%

cat /sys/power/mem_sleep
[s2idle]
Reply
Options

27 Posts

03-24-2018

United States of America

161 Signins

1183 Page Views

  • Posts: 27
  • Registered: ‎03-24-2018
  • Location: United States of America
  • Views: 1183
  • Message 169 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-07-09, 8:24 AM

S0i3 on Fedora 28 with

- kernel 4.17.3

- Enable Thunderbolt 3 compatibility mode in the BIOS
- Disable internal card reader in BIOS (under security settings)

- Disable Wake On LAN

- Disable Always USB
- Add kernel flag: acpi.ec_no_wakeup=1

 

Additionally, I am on a X1 Yoga3.

 

My energy rate while in S0i3 is 1.39W (about 3x the rate quoted below).  Even with that power usage rate in S0i3 you'd be losing around 7-8% over an 8 hour sleep cycle.  Under S3 you would expect that to be around 1-2%.    

 


 wrote:

My experience with S0i3 with Ubuntu 18.04:

- I'm on kernel 4.17.4-041704
- Enable Thunderbolt 3 compatibility mode in the BIOS
- Disable internal card reader in BIOS (under security settings)

- Disable Wake On LAN

- Disable Always USB
- Add kernel flag: acpi.ec_no_wakeup=1

 

After this actions my X1C6 sleeping very long.

 

upower -i /org/freedesktop/UPower/devices/battery_BAT0
  native-path:          BAT0
  vendor:               LGC
  model:                01AV494
  battery
    state:               discharging
    energy:              58,02 Wh
    energy-empty:        0 Wh
    energy-full:         61,26 Wh
    energy-full-design:  57 Wh
    energy-rate:         0,552 W
    time to empty:       4,4 days
    percentage:          94%
    capacity:            100%

cat /sys/power/mem_sleep
[s2idle]

 

Reply
Options

2 Posts

07-07-2018

Russian Federation

2 Signins

47 Page Views

  • Posts: 2
  • Registered: ‎07-07-2018
  • Location: Russian Federation
  • Views: 47
  • Message 170 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-07-09, 8:59 AM

 wrote:

S0i3 on Fedora 28 with

- kernel 4.17.3

- Enable Thunderbolt 3 compatibility mode in the BIOS
- Disable internal card reader in BIOS (under security settings)

- Disable Wake On LAN

- Disable Always USB
- Add kernel flag: acpi.ec_no_wakeup=1

 

Additionally, I am on a X1 Yoga3.

 

My energy rate while in S0i3 is 1.39W (about 3x the rate quoted below).  Even with that power usage rate in S0i3 you'd be losing around 7-8% over an 8 hour sleep cycle.  Under S3 you would expect that to be around 1-2%.    



 


Anyway this is better way for me than patching the DSDT table.
We'll wait for the fix from Lenovo.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms