English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

20 Posts

03-21-2018

Palestine, State of

46 Signins

491 Page Views

  • Posts: 20
  • Registered: ‎03-21-2018
  • Location: Palestine, State of
  • Views: 491
  • Message 271 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-09-08, 8:11 AM

I confirm, for Ubuntu 18.04, the proper S3 suspend kills touchpad and trackpoint in most cases after resume (the same thing happened when I tried doing manual DSDT table modifiication). They are not listed in xinput. They do not get back when using scripts that remove/reconnect the psmouse module and echoing none/reconnect to /sys/devices/platform/i8042/serio1/drvctl also does not help (these worked perfectly with S2Idle). It's an NFC model. Even kernel 4.19 RC2 does not help. Should we report a kernel bug somewhere?

Reply
Options

24 Posts

03-31-2018

Sweden

59 Signins

1094 Page Views

  • Posts: 24
  • Registered: ‎03-31-2018
  • Location: Sweden
  • Views: 1094
  • Message 272 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-09-08, 10:40 AM

I'm using libinput 1.11.3 and unfortunately there is no improvement with the trackpad. I have a NFC model too. I have tried to disable NFC in BIOS without any success. There is no difference if I use Wayland or X. 

 

I have compared libinput list-devices when it's working and when it's not. When touchpad/trackpoint stop working after resume, libinput list-devices are missing the following devices. 

 

 

20c20
< Kernel:           /dev/input/event6
---
> Kernel:           /dev/input/event5
254c254
< Kernel:           /dev/input/event5
---
> Kernel:           /dev/input/event6
269,305d268
< Rotation:         n/a
< 
< Device:           Synaptics TM3288-011
< Kernel:           /dev/input/event15
< Group:            10
< Seat:             seat0, default
< Size:             97x53mm
< Capabilities:     pointer gesture
< Tap-to-click:     disabled
< Tap-and-drag:     enabled
< Tap drag lock:    disabled
< Left-handed:      disabled
< Nat.scrolling:    disabled
< Middle emulation: disabled
< Calibration:      n/a
< Scroll methods:   *two-finger edge 
< Click methods:    *button-areas clickfinger 
< Disable-w-typing: enabled
< Accel profiles:   none
< Rotation:         n/a
< 
< Device:           TPPS/2 Elan TrackPoint
< Kernel:           /dev/input/event16
< Group:            11
< Seat:             seat0, default
< Capabilities:     pointer 
< Tap-to-click:     n/a
< Tap-and-drag:     n/a
< Tap drag lock:    n/a
< Left-handed:      disabled
< Nat.scrolling:    disabled
< Middle emulation: disabled
< Calibration:      n/a
< Scroll methods:   *button
< Click methods:    none
< Disable-w-typing: n/a
< Accel profiles:   flat *adaptive

I have no clue why a reboot isn't enough to reinitilize the devices. 

I am using psmouse.synaptics_intertouch=1 in my grub parameter. 

 

If I use psmosue.synaptics_intertouch=0 my touchpad and trackpoint is completely unusable.

 

Sep 08 12:30:24 x1 kernel: psmouse serio1: issuing reconnect request
Sep 08 12:30:25 x1 kernel: psmouse serio1: synaptics: queried max coordinates: x [..5678], y [..4758]
Sep 08 12:30:25 x1 kernel: psmouse serio1: synaptics: queried min coordinates: x [1266..], y [1094..]
Sep 08 12:30:26 x1 kernel: psmouse serio1: TouchPad at isa0060/serio1/input0 lost sync at byte 1
Sep 08 12:30:26 x1 kernel: psmouse serio1: TouchPad at isa0060/serio1/input0 lost sync at byte 1
Sep 08 12:30:26 x1 kernel: psmouse serio1: TouchPad at isa0060/serio1/input0 lost sync at byte 1
Sep 08 12:30:26 x1 kernel: psmouse serio1: TouchPad at isa0060/serio1/input0 lost sync at byte 1
Sep 08 12:30:26 x1 kernel: psmouse serio1: TouchPad at isa0060/serio1/input0 lost sync at byte 1
Sep 08 12:30:26 x1 kernel: psmouse serio1: issuing reconnect request

There is a Archlinux thread https://bbs.archlinux.org/viewtopic.php?id=236367 where mrfaber writes that trackpoint works after resume after editing TLP (power saving) settings. I will try this out since I haven't yet.  

Reply
Options

4 Posts

07-23-2018

Germany

12 Signins

92 Page Views

  • Posts: 4
  • Registered: ‎07-23-2018
  • Location: Germany
  • Views: 92
  • Message 273 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-09-08, 12:41 PM

The problem is that currently there are really not many viable alternatives. If it were 2014 I would have gone with MBP without a doubt. Now would you rather have to endure Mac's awful keyboard, weight, lack of ports, random system crashes and insane prices? What surprised me about Arch Linux + i3 is how stable and crash-free it actually is compared with my previous Mac experience, not to mention the current MacOS which is on a downward slope.

 

Regarding the touchpad issue, I can confirm that on Arch Linux with kernel 4.18.5 and libinput 1.11.3 I don't encounter any problems with using the touchpad after waking up from sleep. My model is 20KH.

Reply
Options

24 Posts

03-31-2018

Sweden

59 Signins

1094 Page Views

  • Posts: 24
  • Registered: ‎03-31-2018
  • Location: Sweden
  • Views: 1094
  • Message 274 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-09-08, 12:52 PM

Can you please post your custom kernel parameters (if you have any). Do you have the NFC or non NFC model? 

Reply
Options

20 Posts

03-21-2018

Palestine, State of

46 Signins

491 Page Views

  • Posts: 20
  • Registered: ‎03-21-2018
  • Location: Palestine, State of
  • Views: 491
  • Message 275 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-09-08, 12:57 PM

If someone is experiencing this issue on Ubuntu 18.04, you can describe your experiences here in the kernel bug report to let them know it's not just one person: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1791427


Reply
Options

24 Posts

03-31-2018

Sweden

59 Signins

1094 Page Views

  • Posts: 24
  • Registered: ‎03-31-2018
  • Location: Sweden
  • Views: 1094
  • Message 276 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-09-09, 12:22 PM

I seem to have some success with the TLP fix. I applied it yesterday and I have put the computer to sleep/resume multiple times since then and the trackpad/trackpoint haven't stopped working. Also I'm using libinput 1.11.3 which seems to have fix this issue: https://gitlab.freedesktop.org/libinput/libinput/issues/46

 

What I did in Fedora 28.

dnf install tlp

Edit /etc/default/tlp so that these parameters below are present

USB_AUTOSUSPEND_DISABLE_ON_SHUTDOWN=1
USB_AUTOSUSPEND=0
RUNTIME_PM_BLACKLIST="00:1f.4"

Reboot. 

Reply
Options

20 Posts

03-21-2018

Palestine, State of

46 Signins

491 Page Views

  • Posts: 20
  • Registered: ‎03-21-2018
  • Location: Palestine, State of
  • Views: 491
  • Message 277 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-09-10, 7:20 AM

The TLP trick did not work for me (perhaps it's because of my synaptics driver), so this is what I did:

I disabled the trackpoint in BIOS, set power settings to Linux to have S3 sleep state and I removed any and all walkarounds that I have been using - removed the grub intertouch thing, uncommented the blacklisted module, and removed the script that was running after suspends. My touchpad works great and survives all suspends. So I'm just missing the trackpoint and its physical three buttons, the rest works out-of-the-box. I can live with that, got used to a mouse anyway.

Reply
Options

33 Posts

03-11-2018

Germany

51 Signins

731 Page Views

  • Posts: 33
  • Registered: ‎03-11-2018
  • Location: Germany
  • Views: 731
  • Message 278 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-09-10, 12:15 PM

@anx1 thanks:

for me the following combination fixes the touchpad not working after resume issue on ubuntu 18.04 using x1c6 with nfc (20KG):

  • touchpad and trackpoint both enabled in bios
  • nfc disabled in bios (because i dont need it, dont know if it would work)
  • linux (s3) sleep in bios
  • upgrading to the newest kernel, i am using 4.18.7 from http://kernel.ubuntu.com/~kernel-ppa/mainline/
  • removing the blacklisting of i2c_i801 by commenting the line blacklist i2c_i801 in /etc/modprobe.d/blacklist.conf
  • enabling the tlp settings from anx1:
    USB_AUTOSUSPEND_DISABLE_ON_SHUTDOWN=1
    USB_AUTOSUSPEND=0
    RUNTIME_PM_BLACKLIST="00:1f.4"
  • upgrading libinput to 1.11.3, by manually downloading libinput10_1.11.3-1_amd64.deb libinput-bin_1.11.3-1_amd64.deb from cosmic (ubuntu 18.10) https://launchpad.net/ubuntu/+source/libinput and installing with sudo dpkg -i libinput10_1.11.3-1_amd64.deb libinput-bin_1.11.3-1_amd64.deb (This one is scary but upgrading didnt break any dependencies... atleast for me)

upgrading libinput was the most important part and other steps maybe can be omited. However, without the tlp settings the trackpoint (sometimes) doesnt survive suspend.

Reply
Options

1 Posts

09-10-2018

Switzerland

5 Signins

47 Page Views

  • Posts: 1
  • Registered: ‎09-10-2018
  • Location: Switzerland
  • Views: 47
  • Message 279 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-09-10, 13:27 PM

For the carbon x1 6th gen, it seems Lenovo addressed this issue by a bios update.

Update to bios 1.30 then select, it in the bios menu: Config  -> Power -> Sleep State - Set to "Linux"

 

S3 is enabled now. Works like a charm for me. Suspends and wakes up upon closing and opening the lid. Very low power consumption during sleep (<4% for 12hrs).

 

I have Ubuntu 18.04 installed, kernel 4.15 and `acpi.ec_no_wakeup=1` set in the /etc/default/grub file.

 

https://wiki.archlinux.org/index.php/Lenovo_ThinkPad_X1_Carbon_(Gen_6)#Enabling_S3

Reply
Options

7 Posts

04-13-2018

United States of America

10 Signins

170 Page Views

  • Posts: 7
  • Registered: ‎04-13-2018
  • Location: United States of America
  • Views: 170
  • Message 280 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-09-10, 14:54 PM

Wow! Installed via USB (converted the ISO to IMG, dd to a USB, reboot since I run in BIOS mode like a chump) and enabled Linux sleep mode. S3 is working absolutely perfect on my X1C6 20KH in Debian Testing on 4.17.17-1. I had about 10% drain over a 24 hour period while suspended.

 

A huge thumbs up and thank you to Lenovo for providing a patched BIOS, to Erik of the Delta Xi blog for the original ACPI patch, and to everyone contributing in the forums.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms