English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

33 Posts

03-11-2018

DE

51 Signins

731 Page Views

  • Posts: 33
  • Registered: ‎03-11-2018
  • Location: DE
  • Views: 731
  • Message 91 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-04-26, 9:43 AM
oky, ubuntu 18.04 using 4.16.4 from the mainline ppa with "psmouse.synaptics_intertouch=1 acpi.ec_no_wakeup=1" seems to be working reliable (at least for 2 days with ~30 suspend/resumes)
Reply
Options

14 Posts

04-09-2018

GB

38 Signins

359 Page Views

  • Posts: 14
  • Registered: ‎04-09-2018
  • Location: GB
  • Views: 359
  • Message 92 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-04-26, 9:51 AM

 wrote:
oky, ubuntu 18.04 using 4.16.4 from the mainline ppa with "psmouse.synaptics_intertouch=1 acpi.ec_no_wakeup=1" seems to be working reliable (at least for 2 days with ~30 suspend/resumes)

Sorry for such a noob questions, but where/how does one set "psmouse.synaptics_intertouch=1 acpi.ec_no_wakeup=1" ? In a file? At start up?

Reply
Options

7 Posts

04-13-2018

US

10 Signins

170 Page Views

  • Posts: 7
  • Registered: ‎04-13-2018
  • Location: US
  • Views: 170
  • Message 93 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-04-26, 15:54 PM

Hi! You want to set them in:

/etc/default/grub

There is a line that looks like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet"


You want to add it after quiet, like so:

GRUB_CMDLINE_LINUX_DEFAULT="quiet psmouse.synaptics_intertouch=1 acpi.ec_no_wakeup=1"


After making the change, please run:

sudo update-grub

...and reboot for the changes to take effect.

I've always referred to these as kernel parameters set at boot time. For what it's worth, on Debian Testing with 4.15 kernel, I have not needed to set the psmouse parameter, but I mostly use the TrackPoint only. Good luck, and let us know your testing results!

Reply
Options

34 Posts

04-08-2018

DE

99 Signins

771 Page Views

  • Posts: 34
  • Registered: ‎04-08-2018
  • Location: DE
  • Views: 771
  • Message 94 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-04-26, 16:15 PM
Hello spinachbb,

could you give a short explanation what effect "acpi.ec_no_wakeup=1" is supposed to have?

I managed to get my touchpad and trackpoint working with "psmouse.synaptics_intertouch=1" thanks to this thread: https://forums.lenovo.com/t5/Linux-Discussion/Troubles-with-X1-Carbon-2018-X1C6-TouchPad-and-TrackPoint-under/m-p/4056821#M10832
but I'm still having issues with deep sleep. Is "acpi.ec_no_wakeup=1" supposed to help with that, even if I have not patched my DSDT tables as described here: https://delta-xi.net/#056 ?
Reply
Options

7 Posts

04-13-2018

US

10 Signins

170 Page Views

  • Posts: 7
  • Registered: ‎04-13-2018
  • Location: US
  • Views: 170
  • Message 95 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-04-26, 16:19 PM

According to the (always fantastic) Arch wiki, setting the acpi.ec_no_wakeup kernel param will enable Si03 sleep. I'd refer you there for more information. Keep in mind, this might be tied to a specific kernel version. Overall, the Arch wiki seems to have some of the most up-to-date information on the X1C6 and Linux. Some of it may or may not apply to your distribution.

Reply
Options

34 Posts

04-08-2018

DE

99 Signins

771 Page Views

  • Posts: 34
  • Registered: ‎04-08-2018
  • Location: DE
  • Views: 771
  • Message 96 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-04-26, 16:21 PM
great, thank you!
Reply
Options

27 Posts

03-24-2018

US

161 Signins

1183 Page Views

  • Posts: 27
  • Registered: ‎03-24-2018
  • Location: US
  • Views: 1183
  • Message 97 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-04-26, 16:37 PM

S0i3 is mostly working on the X1C6 (haven't tested) and the X1Y3 (have tested).  Just make sure to disable the card reader in the bios or via the command line as described on the archwiki linked above.  If you don't do that, you will likely lose 3-5% battery per hour in S0i3 sleep.

 

As an FYI to any other X1Y3 owner reading this, a few other usb devices need to be disabled (in addition to the card reader) to have an acceptable power drain in S0i3.

Reply
Options

7 Posts

04-13-2018

US

10 Signins

170 Page Views

  • Posts: 7
  • Registered: ‎04-13-2018
  • Location: US
  • Views: 170
  • Message 98 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-04-26, 16:41 PM
That's great! I see that was a little earlier in the thread. Looks like that param will work with kernel 4.13 and higher, thus avoiding the need to DSDT patch for S3 state.

rh78, other than the card reader, what USB devices might need disabling?
Reply
Options

27 Posts

03-24-2018

US

161 Signins

1183 Page Views

  • Posts: 27
  • Registered: ‎03-24-2018
  • Location: US
  • Views: 1183
  • Message 99 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-04-26, 16:50 PM

If you have the X1C6, I think that is the only thing to worry about from what I've read.

 

On the X1Y3, it seems the WACOM tablet and (1-10) and another unidentified usb device (1-9) need to be disabled.  Otherwise, there is too much battery drain (even with the card reader disabled in the bios).  There are no bios settings for these two.

Reply
Options

34 Posts

04-08-2018

DE

99 Signins

771 Page Views

  • Posts: 34
  • Registered: ‎04-08-2018
  • Location: DE
  • Views: 771
  • Message 100 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-04-26, 17:04 PM
Where in the BIOS can the card reader be disabled?
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete