English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

11 Posts

03-03-2018

US

47 Signins

598 Page Views

  • Posts: 11
  • Registered: ‎03-03-2018
  • Location: US
  • Views: 598
  • Message 31 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-07, 0:25 AM

JeremyS: I'm also running Fedora 27. What did you do at Step 9 of Esonn's howto?

 

It seems that Fedora auto-generates the grub.cfg file, so presumably I have to add /acpi_override to one of the scripts used to generate this file (probably /etc/grub.d/10_linux), but I was wondering if you found a cleaner solution to this?

 

P.S. Thanks a lot to the Arch folks for cracking this nut, and especially to Esonn for the howto. (Still hoping for an official solution from Lenovo though!)

 

Update: Just wanted to confirm that editing the generated file worked! Hurray! I assume I'll have to do it again next time I do system update, so still interested in a cleaner solution than editing the generated file. But very happy to have deep sleep working for now. Thanks again!

Reply
Options

14 Posts

03-05-2018

AU

27 Signins

410 Page Views

  • Posts: 14
  • Registered: ‎03-05-2018
  • Location: AU
  • Views: 410
  • Message 32 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-07, 0:54 AM

walkie: Yeah I edited /boot/efi/EFI/fedora/grub.cfg and it does look like you'll have to do this every update.

Also, how is your suspend battery consumption now? Mine is still really high, around about 3W (dropped from 100% to 54% over 9 hours).

I tried enabling powertop's device power management and it looks like suspend power draw has gone down to 2W, but it's still not anywhere where I'd expect it to be.

I suppose the next step would be to try and find out what's drawing that much power during suspend? Any ideas on the best way of doing this? Maybe it's not supsending properly when I close the lid...

 

Reply
Options

11 Posts

03-03-2018

US

47 Signins

598 Page Views

  • Posts: 11
  • Registered: ‎03-03-2018
  • Location: US
  • Views: 598
  • Message 33 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-07, 3:04 AM

JeremyS: Well,  it seems I'm still drawing a little over 3W while suspended also...

 

I'll try manually suspending it next time (instead of just closing the lid) and see if it properly goes into deep sleep that way.

 

If not, I have no idea how to tell what's drawing power while suspended.

Reply
Options

14 Posts

03-05-2018

AU

27 Signins

410 Page Views

  • Posts: 14
  • Registered: ‎03-05-2018
  • Location: AU
  • Views: 410
  • Message 34 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-07, 3:18 AM

walkie: I just tried manually suspending it for 2 hours and it was still drawing 3W.

 

Not sure what I can do next, might have to get hibernate working.

Reply
Options

11 Posts

03-03-2018

US

47 Signins

598 Page Views

  • Posts: 11
  • Registered: ‎03-03-2018
  • Location: US
  • Views: 598
  • Message 35 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-07, 4:12 AM

Yep, manual suspend didn't make a difference.

Reply
Options

11 Posts

03-03-2018

US

47 Signins

598 Page Views

  • Posts: 11
  • Registered: ‎03-03-2018
  • Location: US
  • Views: 598
  • Message 36 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-07, 5:55 AM

Fortunately, setting up hibernate turned out to be easy following these directions:

https://ask.fedoraproject.org/en/question/96389/fedora-24-how-to-enable-hibernate/

 

Seems to work perfectly, and restoring is quite fast with the SSD (10-15 seconds). Not a perfect solution, but a viable workaround for now.

Reply
Options

10 Posts

03-01-2018

AT

34 Signins

280 Page Views

  • Posts: 10
  • Registered: ‎03-01-2018
  • Location: AT
  • Views: 280
  • Message 37 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-07, 7:29 AM

JeremyS/walkie: does /sys/power/mem_sleep contain "deep", and is it put in brackets?

Reply
Options

11 Posts

03-03-2018

US

47 Signins

598 Page Views

  • Posts: 11
  • Registered: ‎03-03-2018
  • Location: US
  • Views: 598
  • Message 38 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-07, 7:32 AM

Hi, Esonn. Yes, it does.

$ cat /sys/power/mem_sleep 
s2idle [deep]
Reply
Options

10 Posts

03-01-2018

AT

34 Signins

280 Page Views

  • Posts: 10
  • Registered: ‎03-01-2018
  • Location: AT
  • Views: 280
  • Message 39 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-07, 7:47 AM

Hmm, that's odd indeed. Your dmesg output (including a suspend/resume attempt) might give a clue, maybe there's a fallback to s2idle for some reason. Also, have you deactived all settings in the BIOS which potentially consume energy? e.g. thunderbolt wake-up, usb charging, etc. Don't have my device right here, can't tell you the exact setting names.

Reply
Options

14 Posts

03-05-2018

AU

27 Signins

410 Page Views

  • Posts: 14
  • Registered: ‎03-05-2018
  • Location: AU
  • Views: 410
  • Message 40 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-07, 12:12 PM

walkie: Yeah I got hibernate working now too, acceptable workaround for now =)

Esonn: Here are the outputs of the following commands:

$ dmesg | grep ACPI | grep supports
[    0.077772] ACPI: (supports S0 S3 S4 S5)
$ cat /sys/power/mem_sleep 
[s2idle] deep

I think put the laptop to sleep manually and here is the output of dmesg:

[  586.793061] PM: suspend entry (s2idle)
[  586.793062] PM: Syncing filesystems ... done.
[  586.810330] Freezing user space processes ... (elapsed 0.004 seconds) done.
[  586.814900] OOM killer disabled.
[  586.814901] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[  586.816800] Suspending console(s) (use no_console_suspend to debug)
[  587.202794] e1000e: EEE TX LPI TIMER: 00000011
[  587.351426] PM: suspend devices took 0.535 seconds
[  587.371453] acpi INT3400:00: Unsupported event [0x86]
[  587.376218] thinkpad_acpi: unknown possible thermal alarm or keyboard event received
[  587.376219] thinkpad_acpi: unhandled HKEY event 0x6032
[  587.376220] thinkpad_acpi: please report the conditions when this event happened to ibm-acpi-devel@lists.sourceforge.net
[  595.467996] acpi INT3400:00: Unsupported event [0x86]
[  595.473629] ACPI: button: The lid device is not compliant to SW_LID.
[  595.682868] nvme nvme0: Shutdown timeout set to 8 seconds
[  595.768812] PM: resume devices took 0.297 seconds
[  595.768829] OOM killer enabled.
[  595.768831] Restarting tasks ... done.
[  595.775321] thermal thermal_zone6: failed to read out thermal zone (-61)
[  595.782948] [drm] RC6 on
[  595.792966] PM: suspend exit 

Is the first line meant to read "s2idle deep"?

Edit: I did have USB power and thunderbolt wake up enabled, I've turned them off now. Will have to run another sleep test tomorrow.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete