English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

2 Posts

03-17-2018

US

21 Signins

301 Page Views

  • Posts: 2
  • Registered: ‎03-17-2018
  • Location: US
  • Views: 301
  • Message 51 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-17, 3:05 AM

Did anyone have any luck on Ubuntu 16.04?! I tried following the guide here, but the patch gets rejected at step 5. I don't know what to do at this point, as I don't know how to manually edit the .dsl file,  or what it even means to do that...Any help would be appreciated. 

 

Thank you. 

Reply
Options

33 Posts

03-11-2018

DE

51 Signins

731 Page Views

  • Posts: 33
  • Registered: ‎03-11-2018
  • Location: DE
  • Views: 731
  • Message 52 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-18, 12:16 PM

i managed to get this done on ubuntu 18.04 and on arch, but haven't tried 16.04.  Nevertheless, as stated in step 5:

 

"Note: Hunk 6 may fail due to different specified memory regions. In this case, simply edit the (almost fully patched) dsdt.dsl file, search for and entirely delete the two lines reading solely the word "One". You can look at hunk 6 in the patch file to see how the lines above and below look like if you're unsure."

 

This also happend to me on both arch and ubuntu 18.04. There must be a file caled "dsdt.dsl.rej", which shows what was not possible to change. Mine looks as follows:

 

--- dsdt.dsl    2018-03-03 14:47:12.279105691 +0100
+++ dsdt.dsl    2018-03-03 14:26:30.606427931 +0100
@@ -351,9 +287,7 @@
     Name (SS1, 0x00)
     Name (SS2, 0x00)
     Name (SS3, One)
-    One
     Name (SS4, One)
-    One
     OperationRegion (GNVS, SystemMemory, 0xAB54E000, 0x0767)
     Field (GNVS, AnyAcc, Lock, Preserve)
     {

 

Thus, as stated in the guide you have to manually delete these two lines containing "One" in the file dsdt.dsl. Search for the lines above and below and verifiy twice that you have found the right position.  Note that the line numbers only roughly match the one in the patch file. Then delete these two lines and move on in the guide.

 

ps. a solution by lenovo would be cool :)

 

 

edit: i forgot to mention some adjustments for ubuntu:

1. the arch package isal is contained in acpica-tools. Therefore you need to run sudo apt install acpica-tools cpio

2. when you edit /boot/grub/grub.cfg you need to insert /boot/acpi_override instead of /acpi_override

Reply
Options

5 Posts

03-19-2018

US

10 Signins

127 Page Views

  • Posts: 5
  • Registered: ‎03-19-2018
  • Location: US
  • Views: 127
  • Message 53 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-19, 9:04 AM

Please try pass `acpi.ec_no_wakeup=1` on the Linux command line.

 

This acpi param is supported from ​v4.13, it is simple to reduce the power consumption.

If it meets your requirement, then no need to patch DSDT which is more complex.

 

Power button can wake up system.

Reply
Options

2 Posts

03-17-2018

US

21 Signins

301 Page Views

  • Posts: 2
  • Registered: ‎03-17-2018
  • Location: US
  • Views: 301
  • Message 54 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-19, 20:20 PM
Hi,

Yes, the issue was with my installed isal version which caused vastly different decompilation.
Reply
Options

7 Posts

03-02-2018

US

50 Signins

387 Page Views

  • Posts: 7
  • Registered: ‎03-02-2018
  • Location: US
  • Views: 387
  • Message 55 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-20, 0:21 AM
@Aaron0, this works very well. Thanks!

With `acpi.ec_no_wakeup=1`, the power usage went from 3-4 W to 0.84W in s2idle.
Reply
Options

33 Posts

03-11-2018

DE

51 Signins

731 Page Views

  • Posts: 33
  • Registered: ‎03-11-2018
  • Location: DE
  • Views: 731
  • Message 56 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-20, 13:58 PM

hm `acpi.ec_no_wakeup=1` seems to work well and the system reaches pc10 state and the powerconsumption is minimal. However, my touchpad is not working on resume :/ 

 

edit: touchpad is working i only had to completly shutdown... and not only restarting oO. However new problem, on resume i have to press the power button. Just opening the lid is not sufficient...

Reply
Options

5 Posts

03-19-2018

US

10 Signins

127 Page Views

  • Posts: 5
  • Registered: ‎03-19-2018
  • Location: US
  • Views: 127
  • Message 57 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-22, 14:51 PM

LID open can't wakeup is a expected result.

 

Maybe you can use keyboard instead:

# echo enabled > /sys/devices/platform/i8042/serio0/power/wakeup

If it works, you can try a udev rule to make it persistent.

 

Let's wait for Lenovo BIOS's final solution.

Reply
Options

8 Posts

03-10-2018

CH

27 Signins

329 Page Views

  • Posts: 8
  • Registered: ‎03-10-2018
  • Location: CH
  • Views: 329
  • Message 58 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-23, 0:25 AM

I own a X1Y3 and also managed to make it work on ubuntu 18.04. however i have the following issues:

 

  • when i close the lid, then the system wakes up again. so i go to sleep with `sleep 5 && systemctl suspend -i` and then close the lid as fast as as possible :-)
  • sometimes TrackPoint doesn't wake up, meaning i can't use it. either i let it sleep couple of time or reboot. this is an issue since i have disabled the trackpad.

I hope that Lenovo provides a proper BIOS, since this is a disgrace for such a nice machine.

Reply
Options

3 Posts

03-23-2018

US

4 Signins

50 Page Views

  • Posts: 3
  • Registered: ‎03-23-2018
  • Location: US
  • Views: 50
  • Message 59 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-23, 9:38 AM

Sorry if I'm missing something obvious but where do I put this `acpi.ec_no_wakeup=1` command? Does this negate the need to do all the other stuff to get sleep working properly under Fedora 27? 

Reply
Options

3 Posts

03-23-2018

US

4 Signins

50 Page Views

  • Posts: 3
  • Registered: ‎03-23-2018
  • Location: US
  • Views: 50
  • Message 60 of 313

Re: X1 Carbon Gen 6 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

2018-03-24, 1:16 AM

Just to answer my own question 'acpi.ec_no_wakeup=1' goes in the /boot/vmlinuz line in grub. You can add it at the grub menu at boot or add it using grubby command as root.

 

On my fedora 27 system I usd the following commands to add it to all my kernel entries 

 

grubby --update-kernel=ALL args="ro rhgb quiet LANG=en_US.UTF-8 acpi.ec_no_wakeup=1"

 

I also edited the /etc/default/grub file and added it to the GRUB_CMDLINE_LINUX line which I hope will add the entry for all new kernels going forward.

I used the following fedora doc as a guide.

 

https://docs.fedoraproject.org/f27/system-administrators-guide/kernel-module-driver-configuration/Working_with_the_GRUB_2_Boot_Loader.html

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete