cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
wurstpfote
Punch Card
Posts: 32
Registered: ‎07-07-2017
Location: DE
Views: 700
Message 11 of 11

Re: X1 Yoga Gen 3 cannot enter deep sleep (S3 state aka Suspend-to-RAM) on Linux

Thanks for the hint, but it is not working with initramfs-tools installed in debian stable for me. May be one should switch to grub2, which accepts the respective flag in /etc/grub/default. I do not have the time to fiddle with it.

 

A working alternative is this one-liner that has to be applied after each kernel update:

sudo sed -i 's/initrd\t/initrd\t\/acpi_override /g' /boot/grub/grub.cfg

 

You may do a dry-run without the '-i' flag to see that it does not compromise your grub.cfg:

sed 's/initrd\t/initrd\t\/acpi_override /g' /boot/grub/grub.cfg | grep acpi_override

 

Check out current deals!


Shop current deals

Top Kudoed Authors