cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
blackomegax
Fanfold Paper
Posts: 13
Registered: ‎01-25-2009
Location: Atlanta, GA
Views: 4,936
Message 1 of 7

X140e brightness in linux does not work.

I figured, being a laptop that is supposed to be available with Ubuntu, and approved by Ubuntu hardware certs, installing 14.04 would yield good results.

 

NOPE.

 

Everything except brightness control. Screen is maxed out, limiting battery life to 6 hours instead of 8-9.  (I know, there are worse fates, but I'll be **bleep** if I am stuck with windows 8....)

 

I've tried many things. new kernels, RC kernels, catalyst drivers, etc. Nothing works.

 

Any ideas?

blackomegax
Fanfold Paper
Posts: 13
Registered: ‎01-25-2009
Location: Atlanta, GA
Views: 4,919
Message 2 of 7

Re: X140e brightness in linux does not work.

update: fixed myself.

 

echo 1-255 to /sys/class/backlight/radeon_bl0/brightness

Sh0cK
Ctrl-Alt-Del
Posts: 10
Registered: ‎05-28-2014
Location: the Netherlands
Views: 4,844
Message 3 of 7

Re: X140e brightness in linux does not work.

Thanks, I'll try that as well on my Edge E145!

Concerning battery life, you could try installing 'tlp'. Just google 'tlp linux'. I'm running Xubuntu and that also makes a difference.
blackomegax
Fanfold Paper
Posts: 13
Registered: ‎01-25-2009
Location: Atlanta, GA
Views: 4,799
Message 4 of 7

Re: X140e brightness in linux does not work.

Permafix: With AMD opensource gpu driver


kernel parameters

thinkpad-acpi.brightness_enable=1 acpi_backlight=vendor
Sh0cK
Ctrl-Alt-Del
Posts: 10
Registered: ‎05-28-2014
Location: the Netherlands
Views: 3,706
Message 5 of 7

Re: X140e brightness in linux does not work.

How should I interpret this?
Can you please be a little bit more extensive?

Thanks in advance!
blackomegax
Fanfold Paper
Posts: 13
Registered: ‎01-25-2009
Location: Atlanta, GA
Views: 3,670
Message 6 of 7

Re: X140e brightness in linux does not work.

In Ubuntu 14.04, adding those two kernel parameters to grub enabled brightness control via default hotkeys on my X140e.

 

https://wiki.ubuntu.com/Kernel/KernelBootParameters

alk224
Paper Tape
Posts: 2
Registered: ‎08-16-2016
Location: US
Views: 1,870
Message 7 of 7

Re: X140e brightness in linux does not work.

That answer is correct, but lacking in detail for most users. To add kernel parameters you need to modify your grub file and then run update-grub.

 

First, start editing your grub file (with sudo):

sudo nano /etc/default/grub

 

Next look for the line that starts with GRUB_CMDLINE_LINUX_DEFAULT

 

On my x140e it looks like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

 

Now add the kernel parameters to that line, adding a space, but within the quotes like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash thinkpad-acpi.brightness_enable=1 acpi_backlight=vendor"

 

Close the file, saving (ctrl-X, Y, enter)

 

Now run the update grub command so that the changes are incorporated on next boot:

sudo update-grub

 

Now restart the computer. My system is dual-boot and I find some of the hardware doesn't necessary switch 100% from one OS to the other, so you may be better off fully shutting down rather than just a reboot. 

 

Check out current deals!


Shop current deals

Top Kudoed Authors