Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo PhonesP1, P1m, P70 & P90 Series Smartphones
All Forum Topics
Options

41 Posts

06-25-2015

Aland Islands

198 Signins

1334 Page Views

  • Posts: 41
  • Registered: ‎06-25-2015
  • Location: Aland Islands
  • Views: 1334
  • Message 1 of 4

p1m option "Hide sensitive notification content" switched to "Show all notification content"

2017-09-02, 12:01 PM

p1m, Lollipop 5.1

In settings: "Sound & notification"->"When device is locked" there are 3 options:

1. Show all notification content

2. Hide sensitive notification content

3. Don't show notifications at all

---

I have set:

---

Hide sensitive notification content

---

And I have my phone locked with "lines pattern" and to unlock the phone I have to enter with my finger the correct line pattern.

If "SMS message with security code" arrives from "internet banking" and the phone is locked the phone will not show the "SMS message with security code" and it is correct behavior because I have set in options:

---

Hide sensitive notification content

---

But if I use the "power saving switch" on the left side of the phone the "power saving switch" will erase the setting:

---

Hide sensitive notification content

---

and the setting is instead switched to:

---

Show all notification content

---

which is wrong behavior.

The setting "Show all notification content" will cause that all "SMS messages", even the "SMS messages with security code" received from "internet banking", are shown even if the phone is locked.

Can please Lenovo look at this flaw / bug.

 

Reply
Options

2122 Posts

10-07-2016

Philippines

445 Signins

18733 Page Views

  • Posts: 2122
  • Registered: ‎10-07-2016
  • Location: Philippines
  • Views: 18733
  • Message 2 of 4

Re: p1m option "Hide sensitive notification content" switched to "Show all notificati

2017-09-04, 20:07 PM

Hi dezinku, 

 

Was it like this ever since you got the device? Have tested a phone here and it's not acting like this. Try to boot your device to Safe Mode and check if issue still persists. Press and hold Power button until "Power off" shows then press and hold "Power off" until "Reboot to safe mode" shows and touch "OK". Let me know. 

 

Regards, 

Venice 

Moto-Lenovo Support 

Reply
Options

41 Posts

06-25-2015

Aland Islands

198 Signins

1334 Page Views

  • Posts: 41
  • Registered: ‎06-25-2015
  • Location: Aland Islands
  • Views: 1334
  • Message 3 of 4

Re: p1m option "Hide sensitive notification content" switched to "Show all notificati

2017-09-05, 6:47 AM

Thank you for your interest.

Version:

H401

P1ma40_S040_170106_16G_ROW

P1ma40_A_V046_170106

I did what you said.

Left bottom label was: Safe mode

1. In settings I set: Sound & notification: Hide sensitive notification content;

close settings app

2. I switched to "power saving mode" on the left side of the phone

3. waiting 15 seconds

4. Switched back from "power saving mode" to "normal mode".

5. In settings I see now: Show all notification content; It should be: Hide sensitive notification content

---

thank you.

 

 

Reply
Options

2122 Posts

10-07-2016

Philippines

445 Signins

18733 Page Views

  • Posts: 2122
  • Registered: ‎10-07-2016
  • Location: Philippines
  • Views: 18733
  • Message 4 of 4

Re: p1m option "Hide sensitive notification content" switched to "Show all notificati

2017-09-06, 21:07 PM

I'll have someone test it again. I'll inform you once there's an update. 

 

-Venice 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms