Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: L, R and SL series Laptops
All Forum Topics
Options

12 Posts

07-22-2008

Split

52 Signins

213 Page Views

  • Posts: 12
  • Registered: ‎07-22-2008
  • Location: Split
  • Views: 213
  • Message 1 of 5

R61i Vista - no Wireless in Device Manager

2008-07-22, 13:14 PM

Few months ago I've bought Lenovo TP R61i 8918 DMG, cleaned it and installed Vista Business. I don't remember any problems with wireless installation (I'm not sure weather I installed it before or after bluetooth, if it matters), since I used wired LAN back then, I turned off wireless with Fn+F5.

After that I upgraded my Vista with SP1. 

Few days ago I had to switch to wireless, so I checked Fn+F5 to find out wireless is missing there. Then I've found there's no wireless connection icon and "manage wireless network connections" in Network and Sharing Center. Also no Wireless in Device Manager. There is under Other Devices a "Network Controller" but I can't either reinstall it (clicking that button), and under Driver tab (Properties, Driver, Driver details icon) it says that no drivers are required or have been loaded for that device.

 

Wireless/network switch is on.

I don't have any old restore points. 

Wireless is set to ON in BIOS.

 

I tried installing then uninstalled Access Connections since I don't use it.

I tried manually installing wireless driver (7rwv10ww.exe)

Please help
Reply
Answer
Options

12 Posts

07-22-2008

Split

52 Signins

213 Page Views

  • Posts: 12
  • Registered: ‎07-22-2008
  • Location: Split
  • Views: 213

Re: R61i Vista - no Wireless in Device Manager

2008-07-22, 20:51 PM

Thanks for the greetings big fish, 

solution was actually too obvious (I spent 10 hrs reading similar problems with Lenovo wireless on different boards), I figured it out by luck:

1. fact: most of the similar problems were when people migrated from Vista to XP, or in less extent from XP to Vista (my case). 

-since neither Ath nor Int (I found only those for XP) wireless worked, I downloaded wireless drivers directly from Intel. There were three files to download, first, wireless detection tool was useless, said I don't have wireless card, second was the files, the third are 200 MB developer drivers which I don't need. Installed it and it's working so far. (I'm not sure where I got these Atheros drivers and process messed up, but now it's finally working). 

Reply

Replies(4)
Options

7651 Posts

11-24-2007

USA

5818 Signins

103093 Page Views

  • Posts: 7651
  • Registered: ‎11-24-2007
  • Location: USA
  • Views: 103093
  • Message 2 of 5

Re: R61i Vista - no Wireless in Device Manager

2008-07-22, 16:03 PM

Welcome to the forum!

 

Have you unpacked the driver from the appropriate directory after downloading it, should be something like C>Drivers>Win>Wlanint

 

Good luck and let us know.

Cheers,

George




In daily use: R60F, R500F, T61, T410

Collecting dust: T60

Enjoying retirement: A31p, T42p,

Non-ThinkPads: Panasonic CF-31 & CF-52, HP 8760W




Starting Thursday, 08/14/2014 I'll be away from the forums until further notice. Please do NOT send private messages since I won't be able to read them. Thank you.
.
Reply
Answer
Options

12 Posts

07-22-2008

Split

52 Signins

213 Page Views

  • Posts: 12
  • Registered: ‎07-22-2008
  • Location: Split
  • Views: 213
  • Message 3 of 5

Re: R61i Vista - no Wireless in Device Manager

2008-07-22, 20:51 PM

Thanks for the greetings big fish, 

solution was actually too obvious (I spent 10 hrs reading similar problems with Lenovo wireless on different boards), I figured it out by luck:

1. fact: most of the similar problems were when people migrated from Vista to XP, or in less extent from XP to Vista (my case). 

-since neither Ath nor Int (I found only those for XP) wireless worked, I downloaded wireless drivers directly from Intel. There were three files to download, first, wireless detection tool was useless, said I don't have wireless card, second was the files, the third are 200 MB developer drivers which I don't need. Installed it and it's working so far. (I'm not sure where I got these Atheros drivers and process messed up, but now it's finally working). 

0 person found this solution to be helpful.

This helped me too

Reply
Options

3 Posts

02-13-2009

The Holy Land

2 Signins

20 Page Views

  • Posts: 3
  • Registered: ‎02-13-2009
  • Location: The Holy Land
  • Views: 20
  • Message 4 of 5

Re: R61i Vista - no Wireless in Device Manager

2009-02-13, 8:44 AM

Hi,

I'm having a similar problem getting XP to detect my wireless card.

Could you please post a URL or other instructions as to exactly where you found the required drivers?

Thanks

Reply
Options

12 Posts

07-22-2008

Split

52 Signins

213 Page Views

  • Posts: 12
  • Registered: ‎07-22-2008
  • Location: Split
  • Views: 213
  • Message 5 of 5

Re: R61i Vista - no Wireless in Device Manager

2009-02-19, 18:00 PM
Hi,

 it should be somewhere here (in Intel download center, at least that's where I've found drivers that solved the problem): http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldId=17228&lang=eng , version depends on OS and wireless you have on board.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms