English Community

Software and Operating SystemPre-Installed Lenovo Software and Applications
All Forum Topics
Options

78 Posts

03-22-2009

Oregon

255 Signins

1797 Page Views

  • Posts: 78
  • Registered: ‎03-22-2009
  • Location: Oregon
  • Views: 1797
  • Message 51 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 8:30 AM

The XML and XMS files I deleted from the folder where I put the updates in were back after I ran ThinInstaler again, checked the log thing like you said and found the share info.

 

Info    2009-05-10 , 01:02:18
    at Tvsu.Engine.Process.HelpCenterIndexRepositoryProcess.PreProcess()
    Message: 'Share name' to use: C:\Users\SectorStar\Downloads\

 

Same path as where I'm telling it to go, and you saw from that pic i posted that they matched in the target area shortcut and TUR so I don't know what the deal is

Reply
Options

453 Posts

12-26-2008

Sweden

14704 Signins

67019 Page Views

  • Posts: 453
  • Registered: ‎12-26-2008
  • Location: Sweden
  • Views: 67019
  • Message 52 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 8:46 AM
And if you open (just doubleclick) the new xml file it generated you see about 20 lines for each package in the database. Do all packages say <Status>Active</Status>?

T500: Vista 32, 2.8GHz, 4GB RAM, 15.4" 1680x1050, 500GB 7200rpm, ATI Radeon HD3650 + Intel 4500MHD. T42: XP, 1.7GHz, 2GB RAM, 14.1" 1024x768, 250GB PATA, ATI Radeon 7500.

Reply
Options

78 Posts

03-22-2009

Oregon

255 Signins

1797 Page Views

  • Posts: 78
  • Registered: ‎03-22-2009
  • Location: Oregon
  • Views: 1797
  • Message 53 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 8:54 AM
When I clicked on it it just gave like 2 lines of stuff, I delted it, and ran ThinINstaler again, but now no XML Or XMS filed are reapearing 0_0 I should copy and pasted the texted before deleteting it <_<
Reply
Options

453 Posts

12-26-2008

Sweden

14704 Signins

67019 Page Views

  • Posts: 453
  • Registered: ‎12-26-2008
  • Location: Sweden
  • Views: 67019
  • Message 54 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 8:59 AM

Ok delete both files again and start UR instead and see if it rebuilds them.

Edit: go to manage repository -- update view

Message Edited by zilla on 2009-05-10 11:01 AM

T500: Vista 32, 2.8GHz, 4GB RAM, 15.4" 1680x1050, 500GB 7200rpm, ATI Radeon HD3650 + Intel 4500MHD. T42: XP, 1.7GHz, 2GB RAM, 14.1" 1024x768, 250GB PATA, ATI Radeon 7500.

Reply
Options

78 Posts

03-22-2009

Oregon

255 Signins

1797 Page Views

  • Posts: 78
  • Registered: ‎03-22-2009
  • Location: Oregon
  • Views: 1797
  • Message 55 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 9:01 AM

 

wait i see what the deal is, the XMS and XML files only reapear in the directory target folder thing AFTER you open TUR again, so now they're back and this is what it says when opened it http://img12.imageshack.us/img12/2696/thing2g.jpg

 

 

 
 

 

 

 

Message Edited by SectorStar on 05-10-2009 02:02 AM
Reply
Options

8 Posts

05-08-2009

Denmark

10 Signins

82 Page Views

  • Posts: 8
  • Registered: ‎05-08-2009
  • Location: Denmark
  • Views: 82
  • Message 56 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 9:06 AM

Allright, it finally works here. I'm not really sure I understand why, but since there are others out there with the same problem I'll describe what happened here:

Please notice, this is NOT a step by step how-to, but if you have some of the same problems and read it to the end, hopefully you should be able to make it work.

 

1. I downloaded the Update Retriever

2. I ran it, made a new directory for the repository and set the default status of downloaded updates to Active(under modify settings). I chose my machine type(4 digits - printed on a label on the bottom of the laptop), OS and language.

3. It found a lot of updates and after I had de-selected a few it ended up downloading some 2.5 GB.

4. Under manage repository -> Update view, I checked that all updates were set to Active and assigned to the right system.

5.a. I downloaded Thin Installer to ...\Program Files\ThinInstaller, ran it and got the: "no packages applicable to your system were found"-message.

5.b. After reading through the forum I tried running it as a command line, specifying the repository directory. Same message.

5.c. Then I tried unpacking the Thin Installer in the same directory as the repository and running it both directly and with a command line. Same message

6. I then did a search for the file database.xml, since this is the file the Thin Installer reads to get info on the updates and found two/three. One in the repository I created, and one in the directory where I installed Update Retriever in the sub-directory \default (a third one was also in Update Retriever, but in a \temp directory)

7. Since the Thin Installer appearantly kept reading the database.xml file from the \default directory(which was empty) I decided to move my repository to this directory via the Modify settings in Update Retriever and then import the updates from the old repository via Manage repository.

8. Then I had to assign machine type, OS and language again in Manage repository -> Update view.

9. I ran the Thin Installer from \Program Files\ThinInstaller with a command line...Same message.

10. Appearantly the URL's in the database.xml file still pointed to the old repository, so I found a file I knew needed update and changed its URL to the new repository. Save and exit, run the Thin Installer with the repository in the command line AND IT WORKS!

11. I examined the updates and realised that the update where I had changed the URL, didn't work, so I changed it back, ran Thin Installer again and this time it found the update.

 

All in all a bit confusing, but now it works. Don't know why I had to change the database.xml before Thin Installer would see it, but as I see it the key is to check that this file contains the correct info, and that the Thin Installer reads the right version of this file.

 

jepsko 

Reply
Options

453 Posts

12-26-2008

Sweden

14704 Signins

67019 Page Views

  • Posts: 453
  • Registered: ‎12-26-2008
  • Location: Sweden
  • Views: 67019
  • Message 57 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 9:11 AM
Yes, I tested it on my database and thats how it works, the recreated XML file only contains those two lines. But of course in my case all updates have already been made so the packages really do not apply.

T500: Vista 32, 2.8GHz, 4GB RAM, 15.4" 1680x1050, 500GB 7200rpm, ATI Radeon HD3650 + Intel 4500MHD. T42: XP, 1.7GHz, 2GB RAM, 14.1" 1024x768, 250GB PATA, ATI Radeon 7500.

Reply
Options

78 Posts

03-22-2009

Oregon

255 Signins

1797 Page Views

  • Posts: 78
  • Registered: ‎03-22-2009
  • Location: Oregon
  • Views: 1797
  • Message 58 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 9:13 AM

wrote:
Yes, I tested it on my database and thats how it works, the recreated XML file only contains those two lines. But of course in my case all updates have already been made so the packages really do not apply.

so what your saying is that 3.19 gigs of updates is stuff i don't need or already have and that's what it isn't working?

Message Edited by SectorStar on 05-10-2009 02:13 AM
Reply
Options

453 Posts

12-26-2008

Sweden

14704 Signins

67019 Page Views

  • Posts: 453
  • Registered: ‎12-26-2008
  • Location: Sweden
  • Views: 67019
  • Message 59 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 9:23 AM
No, not unless you manually updated your drivers after April 1 when System Update stopped working.

T500: Vista 32, 2.8GHz, 4GB RAM, 15.4" 1680x1050, 500GB 7200rpm, ATI Radeon HD3650 + Intel 4500MHD. T42: XP, 1.7GHz, 2GB RAM, 14.1" 1024x768, 250GB PATA, ATI Radeon 7500.

Reply
Options

78 Posts

03-22-2009

Oregon

255 Signins

1797 Page Views

  • Posts: 78
  • Registered: ‎03-22-2009
  • Location: Oregon
  • Views: 1797
  • Message 60 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 9:25 AM
oh for god's sake can't lenovo just give us something that works for once? well i'm tired of playing with this thing for the night. perhaps i'll mess with it in the morning if someone doesn't come forward with more solutions by then
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete