English Community

Software and Operating SystemPre-Installed Lenovo Software and Applications
All Forum Topics
Options

453 Posts

12-26-2008

Sweden

14704 Signins

67019 Page Views

  • Posts: 453
  • Registered: ‎12-26-2008
  • Location: Sweden
  • Views: 67019
  • Message 61 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 9:31 AM

I checked here and about the only thing it should have downloaded that was new after April 1 is Access Connections. So if you arn't using Access Connections and ran System Update regularly until it stopped working April 1 it might actually be correct there are no new updates on your machine.

 

I know TI updated Access Connections for me to 5.22. The installed release you can find by opening Access Connections and clicking on the ? button.

T500: Vista 32, 2.8GHz, 4GB RAM, 15.4" 1680x1050, 500GB 7200rpm, ATI Radeon HD3650 + Intel 4500MHD. T42: XP, 1.7GHz, 2GB RAM, 14.1" 1024x768, 250GB PATA, ATI Radeon 7500.

Reply
Options

78 Posts

03-22-2009

Oregon

255 Signins

1797 Page Views

  • Posts: 78
  • Registered: ‎03-22-2009
  • Location: Oregon
  • Views: 1797
  • Message 62 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 9:33 AM
well actauly the only thing i did download/update once the system update thing was discontiued was that very thing, so yeah maybe thats what the deal is
Reply
Options

453 Posts

12-26-2008

Sweden

14704 Signins

67019 Page Views

  • Posts: 453
  • Registered: ‎12-26-2008
  • Location: Sweden
  • Views: 67019
  • Message 63 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 9:57 AM

If you destroyed the larger original XML file you can rebuild it without downloading again as follows:

 

1. Open UR and go to modify settings. Specify a new directory for the UR database click next and specify your 0768 machine type again, then don't download again but instead go to manage repository -- import updates and point it to the old directory where you have your downloads

 

2. Import everything from the old directory to the new and then go to manage repository -- update view and select all and click on assign system button to assign 0768 to all packages.

 

The new directory now contains all the packages and the new rebuilt XML and XSD files.

T500: Vista 32, 2.8GHz, 4GB RAM, 15.4" 1680x1050, 500GB 7200rpm, ATI Radeon HD3650 + Intel 4500MHD. T42: XP, 1.7GHz, 2GB RAM, 14.1" 1024x768, 250GB PATA, ATI Radeon 7500.

Reply
Options

453 Posts

12-26-2008

Sweden

14704 Signins

67019 Page Views

  • Posts: 453
  • Registered: ‎12-26-2008
  • Location: Sweden
  • Views: 67019
  • Message 64 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 15:37 PM
Added a debugging tips section to the original "how to" post at the beginning of this thread.

T500: Vista 32, 2.8GHz, 4GB RAM, 15.4" 1680x1050, 500GB 7200rpm, ATI Radeon HD3650 + Intel 4500MHD. T42: XP, 1.7GHz, 2GB RAM, 14.1" 1024x768, 250GB PATA, ATI Radeon 7500.

Reply
Options

3 Posts

10-13-2008

London, England

54 Signins

346 Page Views

  • Posts: 3
  • Registered: ‎10-13-2008
  • Location: London, England
  • Views: 346
  • Message 65 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 17:25 PM

Zilla ... Thx for all your hard work on this ... but is it precisely what myself and many others feel about this change from the system update package to this Update Retriever / Thin Installer  option ... ive read thro  all of the posts / down loaded the packages ... looked at he manual ... actually scared witless about even attempting to try to make it work ... its un fathomable for the normal thinkpad user ... can some one not just write a package that makes this new thing work simply ... or is that to much to ask ?

Willers

Reply
Options

3 Posts

10-13-2008

London, England

54 Signins

346 Page Views

  • Posts: 3
  • Registered: ‎10-13-2008
  • Location: London, England
  • Views: 346
  • Message 66 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 19:48 PM
Just a note ... seem to have got it working ... downloaded all the GBs of files ... for the depository ... un ravelled what i had to put into target file for the thin installer short cut ... seemed to work ... no updates needed ... did a quick x check with the driver matrix ... amongst others had put the active protection update on manually previously .. so i guess its ok ... still not entierly convinced ... but got there ...
Reply
Options

78 Posts

03-22-2009

Oregon

255 Signins

1797 Page Views

  • Posts: 78
  • Registered: ‎03-22-2009
  • Location: Oregon
  • Views: 1797
  • Message 67 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 19:59 PM
I think the problem with this is that it's giving you EVERY update there is to download and not boterthing to check to see if you actualy need it/already have it when you run ThinInstaler
Reply
Options

453 Posts

12-26-2008

Sweden

14704 Signins

67019 Page Views

  • Posts: 453
  • Registered: ‎12-26-2008
  • Location: Sweden
  • Views: 67019
  • Message 68 of 76

Re: Home Environment - How to set up Update Retriever (UR) and Thin Installer (TI) in a home environ

2009-05-10, 20:12 PM

Willers, you are right -- this is a solution for relatively technical people and I am the first to agree with all the critique of how Lenovo has handled this. And Lenovo has said they will provide a new solution for the non-corporate customers -- I am just afraid its not really going to be much easier to use than UR+TI.

 

My advice to a relatively non-technical person is to wait and see. One doesn't really need to update drivers every month or every quarter unless one has a specific problem. The reason I got started on UR+TI was that I wanted to go from Vista 32 to Vista 64 now rather than later and to do a clean install without any tool, complex or not, was not very palatable.

 

So just wait and let the techies make all the mistakes first -- I think after the first 60 posts in this thread the "how to" has already improved with the debugging tips section based on the posted mistakes. And if in the meantime Lenovo announces a great new tool you can just forget about UR+TI.

T500: Vista 32, 2.8GHz, 4GB RAM, 15.4" 1680x1050, 500GB 7200rpm, ATI Radeon HD3650 + Intel 4500MHD. T42: XP, 1.7GHz, 2GB RAM, 14.1" 1024x768, 250GB PATA, ATI Radeon 7500.

Reply
Options

11 Posts

01-17-2009

Netherlands

17 Signins

142 Page Views

  • Posts: 11
  • Registered: ‎01-17-2009
  • Location: Netherlands
  • Views: 142
  • Message 69 of 76

Re: Neither TVUR/Thin Installer or RSS works for updating T400

2009-05-11, 16:36 PM

zilla wrote: 
It looks like TI issues an ia.exe command with a timeout parameter set, probing for regional settings, and 3 seconds later it crashes with a System.NullReferenceException. I would check the Region and Language parameter in the Control Panel that ConnectDon mentions. I see others in the forum have had problems with ia.exe and System Update.
 
Zilla, thanks for your answer. 
In UR, I changed the language to Dutch. Also, I set the directory to C:\Program Files\ThinInstaller\UpdateRetrieverDownloads. Here is a piece of the database.xml file:
 
<Package id="osv018ww_32" name="KB932045_32" description="Windows Vista Update Module KB932045 32bit">
    <FileName>osv018ww_32_2_.xml</FileName>
    <Version>1.0</Version>
    <ReleaseDate>25-1-2008</ReleaseDate>
    <Size>8330000</Size>
    <URL>https://download.lenovo.com/ibmdl/pub/ibmdl/pub/pc/pccbbs/mobiles/</URL>
    <Mode>
    </Mode>
    <Type>Quest</Type>
    <Status>Active</Status>
    <PreviousStatus>None</PreviousStatus>
    <LocalPath>\osv018ww_32\osv018ww_32_2_.xml</LocalPath>
    <Severity>Recommended</Severity>
    <DisplayLicense>NotDisplay</DisplayLicense>
    <SystemCompatibility>
      <System mtm="8741" os="Windows Vista" oslang="NL" />
    </SystemCompatibility>
  </Package>
 

What settings should I make in the Region and Languange Options in the Control Panel? Currently this are the settings: on the tab 'Formats' current format: Dutch (Netherlands). on the 'Locations' tab 'Current location' is set to Netherlands. In the 'Administrative' tab, 'Current language for non-Unicode programs' is set to Dutch (Netherlands). 

With these settings, TI still gives the same error message when it is at 3%. Also, when I type the wrong repository folder in the target field of the shortcut, TI still gives the same error. Does someone know what to do?
 

 

Message Edited by loekverhees on 05-11-2009 09:53 AM
Reply
Options

229 Posts

06-20-2008

United States

397 Signins

7343 Page Views

  • Posts: 229
  • Registered: ‎06-20-2008
  • Location: United States
  • Views: 7343
  • Message 70 of 76

Re: Neither TVUR/Thin Installer or RSS works for updating T400

2009-05-11, 17:12 PM

loekverhees wrote:

With these settings, TI still gives the same error message when it is at 3%. Also, when I type the wrong repository folder in the target field of the shortcut, TI still gives the same error. Does someone know what to do?


All your settings look good.  However, from your previous log file:

 

Message: MTM received from eGather: 8741AE5

Message: There is not entry for key Tvt.Mapping.OSeGatherer

 

What operating system, including service pack number, are you currently running?  If it's Vista with either the Beta or RC version of SP2, it's not going to work (this will be the case for the RTM version as well, at least at the time of this posting).

 

Don

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete