English Community

Software and Operating SystemPre-Installed Lenovo Software and Applications
All Forum Topics
Options

37 Posts

01-10-2012

Pennsylvania

37 Signins

187 Page Views

  • Posts: 37
  • Registered: ‎01-10-2012
  • Location: Pennsylvania
  • Views: 187
  • Message 21 of 30

Re: Lenovo Sysupdate 5 stopped working on X220

2013-03-28, 3:42 AM
Here is the relevant portion of the log file where the tvsu error shows up: Info 2013-03-25 , 11:45:23 at Tvsukernel.CustomControls.Step.<>c__DisplayClass7.b__6() Message: Setting PROCESSING status. Info 2013-03-25 , 11:45:23 at Tvsu.FileDownloader.HttpsDownload.GetProxy(ConnectionSettingsBean connBean) Message: Connection type set to DIRECT in ConnectionSettingsBean Severe 2013-03-25 , 11:45:23 at Tvsu.FileDownloader.HttpsDownload.Init(FileDownloadInfo fileInfo) Message: Debug Log: Init method:GET Severe 2013-03-25 , 11:45:24 at Tvsu.FileDownloader.HttpsDownload.doDownloadByHttps(FileDownloadInfo fileInfo, downloadingDelegate downDelegate) Message: Debug Log: doDownloadByHttps InterException is null, uri:https://download.lenovo.com/ibmdl/pub/pc/pccbbs/agent/SSClientCommon/HelloLevel_9_02_00.xml Severe 2013-03-25 , 11:45:24 at Tvsu.FileDownloader.HttpsDownload.doDownloadByHttps(FileDownloadInfo fileInfo, downloadingDelegate downDelegate) Message: Debug Log doDownloadByHttps webException message:The remote server returned an error: (404) Not Found. Severe 2013-03-25 , 11:45:24 at Tvsu.FileDownloader.HttpsDownload.doDownloadByHttps(FileDownloadInfo fileInfo, downloadingDelegate downDelegate) Message: Debug Log server path: https://download.lenovo.com/ibmdl/pub/pc/pccbbs/agent/SSClientCommon/HelloLevel_9_02_00.xml responseStatus:404 Severe 2013-03-25 , 11:45:24 at Tvsu.FileDownloader.HttpsDownload.doDownloadByHttps(FileDownloadInfo fileInfo, downloadingDelegate downDelegate) Message: Debug Log server path: https://download.lenovo.com/ibmdl/pub/pc/pccbbs/agent/SSClientCommon/HelloLevel_9_02_00.xml webException.StackTrace: at System.Net.HttpWebRequest.GetResponse() at Tvsu.FileDownloader.HttpsDownload.doDownloadByHttps(FileDownloadInfo fileInfo, downloadingDelegate downDelegate) Info 2013-03-25 , 11:45:24 at Tvsu.Engine.Process.HelloProcess.Start() Message: UDF download status is -> Failed Severe 2013-03-25 , 11:45:24 at Tvsu.Engine.Process.HelloProcess.Start() Message: Could't connect to the HelloServer, no UDF file was downloaded Info 2013-03-25 , 11:45:24 at Tvsu.Egather.EgatherManager.GetEgatherParser(String type) Message: Running egather minimal..... Info 2013-03-25 , 11:45:24 at Tvsu.Egather.EgatherExecutor.RunAsWindowsService(String directory, String command, String arguments) Message: /execute ia.exe /arguments -filename"""C:\Program Files (x86)\Lenovo\System Update\egather\sysrecomin""" -probes REGIONAL_SETTINGS GATHERER_INFORMATION SYSTEM_SUMMARY -local /directory C:\Program Files (x86)\Lenovo\System Update\egather\ /type COMMAND /timeout 300000 Info 2013-03-25 , 11:45:24 at Tvsu.Egather.EgatherExecutor.RunAsWindowsService(String directory, String command, String arguments) Message: FileName Path: C:\Program Files (x86)\Lenovo\System Update\TvsuCommandLauncher.exe Info 2013-03-25 , 11:45:24 at Tvsu.Egather.EgatherExecutor.ExecuteEgather(String fileOutput, String args) Message: RC eGatherer: 0 Severe 2013-03-25 , 11:45:24 at Tvsu.Egather.EgatherManager.GetEgatherParser(String type) Message: Unable to execute egather Severe 2013-03-25 , 11:45:24 at Tvsu.Engine.Process.HelloProcess.Start() Message: Error getting the Egather parser Exception: Message: Root element is missing. Type: System.Xml.XmlException at Tvsu.Egather.EgatherManager.GetEgatherParser(String type) at Tvsu.Engine.Process.HelloProcess.Start() Severe 2013-03-25 , 11:45:24 at Tvsu.Engine.Task.Task.StartExecution() Message: An error occurred while the task: HelloTask executed the process: HelloProcessthe message from exception isError getting the Egather parser Exception: Message: Error getting the Egather parser Type: Tvsu.Engine.Process.EgatherException at Tvsu.Engine.Task.Task.Start() at Tvsu.Engine.Task.Task.StartExecution() Info 2013-03-25 , 11:45:24 at Tvsukernel.CustomControls.Step.<>c__DisplayClass7.b__6() Message: Setting FAILED status. Info 2013-03-25 , 11:45:24 at Tvsukernel.Logic.GUIController.ShowErrorMessage(Exception e) Message: Error while gathering user information. Exception: Message: Error getting the Egather parser Type: Tvsu.Engine.Process.EgatherException at Tvsu.Engine.Task.Task.StartExecution() at Tvsu.Sdk.SuSdk.GetSystemProperties() at Tvsukernel.Logic.ProgressThread.InitSearch() Info 2013-03-25 , 11:45:24 at Tvsukernel.Dialogs.Messages.ShowStaticMessage(String message, String title, MessageType t, Boolean check) Message: Showing ERROR Message: < An error occurred while gathering user information. >
Reply
Options

37 Posts

01-10-2012

Pennsylvania

37 Signins

187 Page Views

  • Posts: 37
  • Registered: ‎01-10-2012
  • Location: Pennsylvania
  • Views: 187
  • Message 22 of 30

Re: Lenovo Sysupdate 5 stopped working on X220

2013-03-28, 4:05 AM
Here's the only other relevant log, called "service_log.txt", the only file in SUservice logs folder, which also shows a problem: Info 2013-03-25 , 11:45:28 at Tvsu.Service.Client.CommandLauncher.ExecuteCommandLine(String command) Message: The current user is an administrator, we'll install under the administrator context Info 2013-03-25 , 11:45:28 at Tvsu.Service.Common.CommandExecutor.Executor.Execute() Message: /execute ia.exe /arguments -filename"C:\Program Files (x86)\Lenovo\System Update\egather\sysrecomin" -probes REGIONAL_SETTINGS GATHERER_INFORMATION SYSTEM_SUMMARY -local /directory C:\Program Files (x86)\Lenovo\System Update\egather\ /type COMMAND /timeout 300000 Info 2013-03-25 , 11:45:28 at Tvsu.Service.Common.CommandExecutor.Executor.Execute() Message: C:\Program Files (x86)\Lenovo\System Update\egather\ ia.exe -filename"C:\Program Files (x86)\Lenovo\System Update\egather\sysrecomin" -probes REGIONAL_SETTINGS GATHERER_INFORMATION SYSTEM_SUMMARY -local COMMAND Info 2013-03-25 , 11:45:28 at Tvsu.Service.Common.CommandExecutor.Executor.ExecuteCommand(String dir, String cmd, String args, String _installType, Int64 timeOut, Boolean hide) Message: Directory 1: C:\Program Files (x86)\Lenovo\System Update\egather\ Info 2013-03-25 , 11:45:28 at Tvsu.Service.Common.CommandExecutor.Executor.ExecuteCommand(String dir, String cmd, String args, String _installType, Int64 timeOut, Boolean hide) Message: If directory 1 exists: C:\Program Files (x86)\Lenovo\System Update\egather\ Info 2013-03-25 , 11:45:28 at Tvsu.Service.Common.CommandExecutor.Executor.ExecuteCommand(String dir, String cmd, String args, String _installType, Int64 timeOut, Boolean hide) Message: The parameters directory and command stay as follows: command: ia.exe directory: C:\Program Files (x86)\Lenovo\System Update\egather\ Info 2013-03-25 , 11:45:28 at Tvsu.Service.Common.CommandExecutor.Executor.ExecuteCommand(String dir, String cmd, String args, String _installType, Int64 timeOut, Boolean hide) Message: Type hidden Fine 2013-03-25 , 11:45:28 at Tvsu.Service.Common.CommandExecutor.Executor.AddEnvironmentVariables(String fileName) Message: Add environment variables for C:\Program Files (x86)\Lenovo\System Update\egather\ia.exe Fine 2013-03-25 , 11:45:28 at Tvsu.Service.Common.CommandExecutor.Executor.AddEnvironmentVariables(String fileName) Message: C:\Program Files (x86)\Lenovo\System Update\egather\ia.exe is a 32-bit application. Info 2013-03-25 , 11:45:28 at Tvsu.Service.Common.CommandExecutor.Executor.ExecuteCommand(String dir, String cmd, String args, String _installType, Int64 timeOut, Boolean hide) Message: C:\Program Files (x86)\Lenovo\System Update\egather\ ia.exe -filename"C:\Program Files (x86)\Lenovo\System Update\egather\sysrecomin" -probes REGIONAL_SETTINGS GATHERER_INFORMATION SYSTEM_SUMMARY -local COMMAND 300000 Info 2013-03-25 , 11:45:28 at Tvsu.Service.Common.CommandExecutor.Executor.ExecuteCommand(String dir, String cmd, String args, String _installType, Int64 timeOut, Boolean hide) Message: Hidden Info 2013-03-25 , 11:45:28 at Tvsu.Service.Common.CommandExecutor.Executor.ExecuteCommand(String dir, String cmd, String args, String _installType, Int64 timeOut, Boolean hide) Message: 0 Info 2013-03-25 , 11:45:28 at Tvsu.Service.Client.CommandLauncher.ExecuteCommandLine(String command) Message: Command execution duration was: 133 Miliseconds Info 2013-03-25 , 11:45:34 at Tvsu.Service.Common.CommandExecutor.Executor.ExecuteCommand(String dir, String cmd, String args, String _installType, Int64 timeOut, Boolean hide) Message: -1 Info 2013-03-25 , 11:45:34 at Tvsu.Service.Client.CommandLauncher.ExecuteCommandLine(String command) Message: Command execution duration was: 422 Miliseconds Warning 2013-03-25 , 11:45:36 at Tvsu.Service.Server.PipeManager.Start() Message: Cannot access a disposed object. Object name: 'The Pipe Connection is disposed.'. Exception: Message: Cannot access a disposed object. Object name: 'The Pipe Connection is disposed.'. Type: System.ObjectDisposedException at Tvsu.Service.Common.NamedPipes.APipeConnection.CheckIfDisposed() at Tvsu.Service.Common.NamedPipes.APipeConnection.get_NativeHandle() at Tvsu.Service.Server.PipeManager.Start()
Reply
Options

4968 Posts

11-22-2011

US

5774 Signins

89608 Page Views

  • Posts: 4968
  • Registered: ‎11-22-2011
  • Location: US
  • Views: 89608
  • Message 23 of 30

Re: Lenovo Sysupdate 5 stopped working on X220

2013-03-28, 17:53 PM

Which version of .Netframework do you have? Trying updating to version 4.

Su requires 3.5 with SP1.

At your point of failure, SU is accessing system.XML to determine your machine type. 

Reply
Options

37 Posts

01-10-2012

Pennsylvania

37 Signins

187 Page Views

  • Posts: 37
  • Registered: ‎01-10-2012
  • Location: Pennsylvania
  • Views: 187
  • Message 24 of 30

Re: Lenovo Sysupdate 5 stopped working on X220

2013-03-28, 18:10 PM
I have .netframework4, installed on 2-16-2011 according to control panel>programs and features. Is that ok? how do I update it, if that is advisable, when I do not have functioning sysupdate?
Reply
Options

4968 Posts

11-22-2011

US

5774 Signins

89608 Page Views

  • Posts: 4968
  • Registered: ‎11-22-2011
  • Location: US
  • Views: 89608
  • Message 25 of 30

Re: Lenovo Sysupdate 5 stopped working on X220

2013-03-29, 1:02 AM

(1) I dont have the answer as to why your SU is NOT working.

(2) I would uninstall framework 4 on clone. reinstall.  It has a database that takes 15 minutes to refresh upon reboot(check task manager.. you will see). Is database corrupt, I have no idea.

(3) No one else has chimed in with your symptom.

(4) Other than 2 above, I would suggest factory install (which is NOT what you want to hear).  

(5) Su might have a bug

(6) I wont offer anymore solutions. This is a guessing game at this point.

If you search  your system for system.XML, it shows up in various places.  Mainly framework 4.

(7) run windows update after reinstall of framework 4.  My framework 4 shows install during 2010 (when i installed

     win 7). Current level is: 4.0.30319.

(8) Do you have ability to go back to original system (not the clone)? which SU is on original? did it work? 

==

You:

11:45:24 at Tvsu.Egather.EgatherExecutor.ExecuteEgather(String fileOutput, String args) Message: RC eGatherer: 0

Severe 2013-03-25 , 11:45:24 at Tvsu.Egather.EgatherManager.GetEgatherParser(Strin?g type) Message: Unable to execute egather

Severe 2013-03-25 , 11:45:24 at Tvsu.Engine.Process.HelloProcess.Start() Message: Error getting the Egather parser

Exception: Message: Root element is missing. Type: System.Xml.XmlException

at Tvsu.Egather.EgatherManager.GetEgatherParser(String type)

at Tvsu.Engine.Process.HelloProcess.Start

----edited---

 < An error occurred while gathering user information

===

ME:

Info 2013-03-27 , 07:27:38  at Tvsu.Egather.EgatherExecutor.ExecuteEgather(String fileOutput, String args)  Message: RC eGatherer: 0

Info 2013-03-27 , 07:27:38  at Tvsu.Engine.Process.HelloProcess.Start()  Message: MTM received from eGather: 9702CTO <***** MTM is machine type and model***** I do have a a57 9702-cto.

Reply
Options

37 Posts

01-10-2012

Pennsylvania

37 Signins

187 Page Views

  • Posts: 37
  • Registered: ‎01-10-2012
  • Location: Pennsylvania
  • Views: 187
  • Message 26 of 30

Re: Lenovo Sysupdate 5 stopped working on X220

2013-03-29, 2:19 AM
Thanks for your efforts. I believe the same .net is on the SSD as is on the original HDD from which I was always able to do SysUpdate. If I remove .net now, where do I go to get it? I would rather try unstall and reinstall .net than go back to factory settings and redo all my programs, etc. If I still can't get SU to work, does the Lenovo website have a tool that analyzes your system and tells you what needs to be updated? That would be cool.
Reply
Options

4968 Posts

11-22-2011

US

5774 Signins

89608 Page Views

  • Posts: 4968
  • Registered: ‎11-22-2011
  • Location: US
  • Views: 89608
  • Message 27 of 30

Re: Lenovo Sysupdate 5 stopped working on X220

2013-03-29, 23:14 PM

The Magic utility you are looking for is SU.

 

Netframe work offers Repair.  Go to progam/features, Right click framework 4. Repair.  This should just rebuild the database.

This may not fix anything. There is a problem with root element and system.xml. Seems some XML is being read, and not found/ corrupt/ etc.

 

My thesis for doing this is SU is talking to netframe system.XML to get the MTM. or other stuff, like SSD level.

Otherwise, wait for the next release.

I have no details of your clone, dont want details of your clone.   You seem happy with the clone.

==

What i do observe:

(1) clone to SDD. Su 5.0 fine. Upgrade to  5.2 install failure which is now fixed. SU 5.2 fails at gather.

(2) Did you update the firmware on your Samsung 830 SSD to current level?

Have you run windows update to become current? 

=

Previous ?

(8) Do you have ability to go back to original system (not the clone)? which SU is on original? did it work?

IF so, upgrade 5.0 to 5.2, with the suservice delete issue required.  

Reply
Options

37 Posts

01-10-2012

Pennsylvania

37 Signins

187 Page Views

  • Posts: 37
  • Registered: ‎01-10-2012
  • Location: Pennsylvania
  • Views: 187
  • Message 28 of 30

Re: Lenovo Sysupdate 5 stopped working on X220

2013-03-30, 17:20 PM
Tnx sclexman. I have latest SU version. I did the repair of netframe as you suggested. I uninstalled and reinstalled SU. Still the same problem! I am beginning to thing that the problem may be between me and the Lenovo server or at the Lenovo server. Take a look at the extracts below from tvsu log files I have checked: 1. Severe 2013-03-25 , 11:45:24 at Tvsu.FileDownloader.HttpsDownload.doDownloadByHttps(FileDownloadInfo fileInfo, downloadingDelegate downDelegate) Message: Debug Log server path: https://download.lenovo.com/ibmdl/pub/pc/pccbbs/agent/SSClientCommon/HelloLevel_9_02_00.xml webException.StackTrace: at System.Net.HttpWebRequest.GetResponse() at Tvsu.FileDownloader.HttpsDownload.doDownloadByHttps(FileDownloadInfo fileInfo, downloadingDelegate downDelegate) Info 2013-03-25 , 11:45:24 at Tvsu.Engine.Process.HelloProcess.Start() Message: UDF download status is -> Failed Severe 2013-03-25 , 11:45:24 at Tvsu.Engine.Process.HelloProcess.Start() Message: Could't connect to the HelloServer, no UDF file was downloaded 2. Info 2013-03-25 , 11:45:24 at Tvsu.Egather.EgatherExecutor.ExecuteEgather(String fileOutput, String args) Message: RC eGatherer: 0 Severe 2013-03-25 , 11:45:24 at Tvsu.Egather.EgatherManager.GetEgatherParser(String type) Message: Unable to execute egather Severe 2013-03-25 , 11:45:24 at Tvsu.Engine.Process.HelloProcess.Start() Message: Error getting the Egather parser Exception: Message: Root element is missing. Type: System.Xml.XmlException at Tvsu.Egather.EgatherManager.GetEgatherParser(String type) at Tvsu.Engine.Process.HelloProcess.Start() Severe 2013-03-25 , 11:45:24 at Tvsu.Engine.Task.Task.StartExecution() Message: An error occurred while the task: HelloTask executed the process: HelloProcessthe message from exception isError getting the Egather parser Exception: Message: Error getting the Egather parser Type: Tvsu.Engine.Process.EgatherException at Tvsu.Engine.Task.Task.Start() at Tvsu.Engine.Task.Task.StartExecution( 3. Info 2013-03-25 , 11:45:24 at Tvsukernel.CustomControls.Step.<>c__DisplayClass7.b__6() Message: Setting FAILED status. Info 2013-03-25 , 11:45:24 at Tvsukernel.Logic.GUIController.ShowErrorMessage(Exception e) Message: Error while gathering user information. Exception: Message: Error getting the Egather parser Type: Tvsu.Engine.Process.EgatherException at Tvsu.Engine.Task.Task.StartExecution() at Tvsu.Sdk.SuSdk.GetSystemProperties() at Tvsukernel.Logic.ProgressThread.InitSearch() Info 2013-03-25 , 11:45:24 at Tvsukernel.Dialogs.Messages.ShowStaticMessage(String message, String title, MessageType t, Boolean check) Message: Showing ERROR Message: < An error occurred while gathering user information. >
Reply
Options

4968 Posts

11-22-2011

US

5774 Signins

89608 Page Views

  • Posts: 4968
  • Registered: ‎11-22-2011
  • Location: US
  • Views: 89608
  • Message 29 of 30

Re: Lenovo Sysupdate 5 stopped working on X220

2013-03-30, 20:58 PM

You have posted the same log previously, which I have read.

Yes, there are messages in the log which would think the server is down.  Those messages caught  my attention the first time I read the log.  I have the SAME messages in my log, but that DID NOT prevent SU from running.

 

2013-03-30 , 12:47:07
 at Tvsu.FileDownloader.HttpsDownload.doDownloadByHttps(FileDownloadInfo fileInfo, downloadingDelegate downDelegate)
 Message: Debug Log doDownloadByHttps webException message:The remote server returned an error: (404) Not Found.

2013-03-30 , 12:47:07
 at Tvsu.Engine.Process.HelloProcess.Start()
 Message: UDF download status is -> Failed

2013-03-30 , 12:47:07  at Tvsu.Engine.Process.HelloProcess.Start()  Message: Could't connect to the HelloServer, no UDF file was downloaded

Info 2013-03-30 , 12:47:07  at Tvsu.Egather.EgatherManager.GetEgatherParser(String type)  Message: Running egather minimal.....

Info 2013-03-30 , 12:47:07  at Tvsu.Egather.EgatherExecutor.RunAsWindowsService(String directory, String command, String arguments)  Message:  /execute ia.exe /arguments -filename"""C:\Program Files (x86)\Lenovo\System Update\egather\sysrecomin""" -probes REGIONAL_SETTINGS GATHERER_INFORMATION SYSTEM_SUMMARY -local /directory C:\Program Files (x86)\Lenovo\System Update\egather\ /type COMMAND /timeout 300000

Info 2013-03-30 , 12:47:07  at Tvsu.Egather.EgatherExecutor.RunAsWindowsService(String directory, String command, String arguments)  Message: FileName Path: C:\Program Files (x86)\Lenovo\System Update\TvsuCommandLauncher.exe

Info 2013-03-30 , 12:47:13  at Tvsu.Egather.EgatherExecutor.ExecuteEgather(String fileOutput, String args)  Message: RC eGatherer: 0

Info 2013-03-30 , 12:47:13  at Tvsu.Engine.Process.HelloProcess.Start()  Message: MTM received from eGather: 9702CTO

===

There are several entries at microsoft.com concerning root element missing and System.XML.  What virus scan do you use? Windows essentials?  Some suggest turning the Viruscan off, then run program . There is NOT enough information in the logs to Nail down the exact problem.   You could try to run SU as administator. Some items suggest security issue accessing framework 4 datatabase.   Are you a at home user(admin), college student using some university web access? Your SSD in not currently for sale per Samsung (thus the firmware question). Current is 840.

==

You have not stated if you can recreate this issue on your old system! If it (5.02) installs fine on your old system (and runs), then there is something  SU does like on the clone.   You could check EVENT Viewer to see if any entries were logged while SU running.  Is your Firmware up to date on SSD?  I am just offering simple suggestions without going on a wild goose chase.

==

Another theory.  If Ia.exe is dependent on SU service. I will try an experiement later, and Disable my suservice. and see what happens.  

Do you have ability to go back to original system (not the clone)? which SU is on original? did it work?

Why do I ask? I am trying to find out if 5.02 fails old system and SSD. If it fails on both, Sdd upgrade is ruled out of the issue. I have been doing problem determination on mainframes for 30 years.  When the answer arrives, it is so simple, change  x to y. Your main change is HDD to SDD, does that matter? maybe. You could call the support center, but I will NOT even comment on that.

==

Never lose sleep over vendor software.

Reply
Options

37 Posts

01-10-2012

Pennsylvania

37 Signins

187 Page Views

  • Posts: 37
  • Registered: ‎01-10-2012
  • Location: Pennsylvania
  • Views: 187
  • Message 30 of 30

Re: Lenovo Sysupdate 5 stopped working on X220

2013-04-02, 5:28 AM
Thanks for your help, but I feel the problem is with Lenovo--and I will have to go to them for a fix. If there is any. I am really angry about this. Take a look at another, earlier thread, from 2011 until now, about precisely this problem with TVSU: http://forums.lenovo.com/t5/ThinkVantage-Technologies/System-Update-An-error-occurred-while-gathering-user-information/td-p/15708/page/31 I have the latest SU, freshly installed after cleaning out the previous installation and all associated files. I rebuilt the MS .net or frame or whatever it's called. The firmware for my Samsung 830 SSD is the latest. My BIOS is 1.33 and the notes for all subsequent BIOS on the Lenovo website do NOT say that any of the subsequent versions corrects any problems with TVSU. I don't want to mess around any more--I have work to do! So I will call Lenovo customer service for help. And I will cite our thread here and the other thread cited above. If Lenovo does not have a solution, they can go to hell, with their **bleep** computers.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete