Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Software and Operating SystemPre-Installed Lenovo Software and Applications
All Forum Topics
Options

6 Posts

04-25-2014

San Jose, CA

17 Signins

93 Page Views

  • Posts: 6
  • Registered: ‎04-25-2014
  • Location: San Jose, CA
  • Views: 93
  • Message 21 of 32

Re: Lenovo ThinkVantage Toolbox 5.05.0009 - SSL problem

2014-04-26, 2:01 AM

The URL in the log file (https://download.lenovo.com/ibmdl/pub/pc/pccbbs/agent/SSClientCommon/HelloLevel_9_10_00.xml) is invalid, I get "file not found".  Remember, I took your advice to set the hello level to 10.

When I go to the URL made when I substitute "09" in place of "10", I get an empty document in IE, and this error in Firefox (colored fuchsia, note the trailing "^").

XML Parsing Error: no element found

Location: https://download.lenovo.com/ibmdl/pub/pc/pccbbs/agent/SSClientCommon/HelloLevel_9_09_00.xml"
Line Number 1, Column 1:

 

^

 

When I go to the URL made when I substitute "08" in place of "10", I get a perfectly valid xml file in my browser.

 

Reply
Options

5067 Posts

11-22-2011

United States of America

5783 Signins

89698 Page Views

  • Posts: 5067
  • Registered: ‎11-22-2011
  • Location: United States of America
  • Views: 89698
  • Message 22 of 32

Re: Lenovo ThinkVantage Toolbox 5.05.0009 - SSL problem

2014-04-26, 14:05 PM

I think we are making progress. I further reviewed the log this morning.

 

(1) the handshake with the --10-- hello level. That was suggested by Lenovo for this user.  I just documented what was in the Su deployment guide.. This  is failure one (404 message on this link).

https://download.lenovo.com/ibmdl/pub/pc/pccbbs/agent/SSClientCommon/HelloLevel_9_10_00.xml

 

Sclexman stated:

 I would expect hello level to xxx 10 .xxx xml has the same effect. 

>>> It appears to cause a 404 message, avoids the self update, then continues running.

 

(2) failure two is also a 404 message for

https://download.lenovo.com/catalog//10132_Win8_DESC.xml

 

It is finding your machine model number to be 10132. Normally SU uses a 4 character model number, not 5.

 

2014-04-25 , 03:42:05  :
QOS (Quest OS): Windows 8
QOSLang (Quest language): EN
MTM: 10132 

 

 I think your machine is a H530s 10132/90AB.  The support page for this machines does not list System Update. Also, System Update readme page does not list your machine as supported.  The user guide for this machine documents OKR (One Key Rescue) with a option to Reinstall Drivers and Applications shipped with the machine.

.

 

Reply
Options

6 Posts

04-25-2014

San Jose, CA

17 Signins

93 Page Views

  • Posts: 6
  • Registered: ‎04-25-2014
  • Location: San Jose, CA
  • Views: 93
  • Message 23 of 32

Re: Lenovo ThinkVantage Toolbox 5.05.0009 - SSL problem

2014-04-26, 19:27 PM
Yes, this is an H530s. So SU is not supported on this machine?
Reply
Options

5067 Posts

11-22-2011

United States of America

5783 Signins

89698 Page Views

  • Posts: 5067
  • Registered: ‎11-22-2011
  • Location: United States of America
  • Views: 89698
  • Message 24 of 32

Re: Lenovo ThinkVantage Toolbox 5.05.0009 - SSL problem

2014-04-26, 19:54 PM

I dont see any Thinkvantage software products on the support page  for your machine.(I do see drivers listed)..  You could call the support center to get clarity on this issue.  I dont think this machine shipped with System Update installed. Wonder how you update it? (you state you downloaded SU, probably 5.03 first. not a issue, ie 5.5.8 will not  self update to 5.5.9).

===

I got my SU to self update to 5.05.0009.  ( change date 2-21-2104). I installed  version 5.5.8 manually (change date 2-14-2014).

(1) Su 5.03 is hello level 8 (and the link contains valid html) When the self update is checked, this version will download/install 5.05.0009 (this will be hello level  9, blank html. No self update at this time.)  I assume Lenovo will update the level 9 link when they want everyone to self update.

(2) If you already have 5.05.0008 installed, the hello level is 9 (and the link contains 0 bytes. No self update.)

Mystery solved.  I used regedit to change my hello level  from 9 to 8. Self updated.  <dont do this folks. 

 

Blarvitz noticed:

When I go to the URL made when I substitute "08" in place of "10", I get a perfectly valid xml file in my browser

==

The author of this post might consider using level 09 instead of 10 to avoid the 404 message and make his  test environment  act normal ( This  also avoids the self update of version SU 5.03)  . His decision.

You have 3 sets of SU to test. 5.03, 5.05.8, 5.05.9 .

 

http://www.akamai.com/dl/feature_sheets/fs_edgesuite_securecontentdelivery.pdf

Note the use of User certificates.

 

Reply
Options

191 Posts

04-21-2011

China

313 Signins

1314 Page Views

  • Posts: 191
  • Registered: ‎04-21-2011
  • Location: China
  • Views: 1314
  • Message 25 of 32

Re: Lenovo ThinkVantage Toolbox 5.05.0009 - SSL problem

2014-05-16, 7:20 AM

Hi VeeChee,

 

Did you have a try with the previous version 5.03?what is the result?Thanks.

Reply
Options

169 Posts

03-12-2012

Canada

142 Signins

1656 Page Views

  • Posts: 169
  • Registered: ‎03-12-2012
  • Location: Canada
  • Views: 1656
  • Message 26 of 32

Re: Lenovo ThinkVantage Toolbox 5.05.0009 - SSL problem

2014-05-20, 5:38 AM

Hi there,

 

Sorry but I haven't had a chance to downgrade.  I have continued to try TVSU regularly though to watch for the error.  I even excluded download.lenovo.com on our firewall, so even if there was a certificate error with that hostname, the firewall would not step in.  This has led TVSU working sometimes: one day it will work, the next it will not.  More days it doens't work than it does.

 

And right now I am in our branch office in another continent - where I also put the exclusion in place - and I get the error today.  And sure enough, I check the firewall logs and there is an SSL attempt to an IP address immediately following the SSL connection to download.lenovo.com.

 

I really think this is an issue with the Content Delivery Network.

__________________________________________________
Current: ThinkPad Tablet 2 | 64GB // ThinkPad T440s | i7-4600U | 12GB | 512GB SSD | FHD MT
Previous: ThinkPad T420s // ThinkPad T410s
Reply
Options

169 Posts

03-12-2012

Canada

142 Signins

1656 Page Views

  • Posts: 169
  • Registered: ‎03-12-2012
  • Location: Canada
  • Views: 1656
  • Message 27 of 32

Re: Lenovo ThinkVantage Toolbox 5.05.0009 - SSL problem

2014-05-20, 9:59 AM

I just did another test:

I put two PCs beside each other and tried TVSU 5.05.0009 on both of them.

- PC A was able to connect and is downloading updates right now.  Checking the firewall logs, a single SSL connection to download.lenovo.com (resolving to 184.26.196.24) is shown.  This PC is another uses - Windows 7 Enterprse.

- PC B got the error message and could not continue.  Checking the firewall logs, two SSL connections are shown: one to download.lenovo.com (resolving to 184.87.248.27), and the second directly to 184.87.248.27.  This PC is mine - Windows 8.1 Enterprise.

__________________________________________________
Current: ThinkPad Tablet 2 | 64GB // ThinkPad T440s | i7-4600U | 12GB | 512GB SSD | FHD MT
Previous: ThinkPad T420s // ThinkPad T410s
Reply
Options

191 Posts

04-21-2011

China

313 Signins

1314 Page Views

  • Posts: 191
  • Registered: ‎04-21-2011
  • Location: China
  • Views: 1314
  • Message 28 of 32

Re: Lenovo ThinkVantage Toolbox 5.05.0009 - SSL problem

2014-05-21, 9:21 AM

Hi Veehee,

 

Thanks for your testing, base on the same system udpate vesion,  result with 1 PC works,  the other fails, do you  think it's a  content server issue? or still think it's tvsu issue?BTW, we have already released the latest TVSU 5.06 on below website, could you please have a try if you are interested?Thanks.

 

http://support.lenovo.com/en_US/downloads/detail.page?LegacyDocID=MIGR-73695

Reply
Options

169 Posts

03-12-2012

Canada

142 Signins

1656 Page Views

  • Posts: 169
  • Registered: ‎03-12-2012
  • Location: Canada
  • Views: 1656
  • Message 29 of 32

Re: Lenovo ThinkVantage Toolbox 5.05.0009/5.06.0007 - SSL problem

2014-06-13, 18:37 PM

This is still troubling me.  I am using the newest version now: 5.06.0007.  I have a 0% success ratio updating at work, even though download.lenovo.com has been allowed through the firewall without any filtering applied.  It's got to be either a CDN problem, or a way that the program queries the server in Windows 8.1.  As I posted earlier, I put a Windows 7 PC beside it and it updated fine while the 8.1 PC does not.

__________________________________________________
Current: ThinkPad Tablet 2 | 64GB // ThinkPad T440s | i7-4600U | 12GB | 512GB SSD | FHD MT
Previous: ThinkPad T420s // ThinkPad T410s
Reply
Options

5067 Posts

11-22-2011

United States of America

5783 Signins

89698 Page Views

  • Posts: 5067
  • Registered: ‎11-22-2011
  • Location: United States of America
  • Views: 89698
  • Message 30 of 32

Re: Lenovo ThinkVantage Toolbox 5.05.0009/5.06.0007 - SSL problem

2014-06-13, 22:44 PM

It appears your AT at home, win7, updates ok. (clarify).

Your at work, using some  firewall software, fails the SU on win 8.1.

Yes Akami CDN using valid industry mirrors and tricks.

Download.www.Lenovo.com gets translated to a AKAMI server  web address.

I would suggest you contact your at work security software (firewall) and open a problem report.

==

Are the win7 and win 8.1 both going thru the at work network? 

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms