Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Software and Operating SystemPre-Installed Lenovo Software and Applications
All Forum Topics
Options

6 Posts

07-27-2008

Tarrytown NY, USA

6 Signins

73 Page Views

  • Posts: 6
  • Registered: ‎07-27-2008
  • Location: Tarrytown NY, USA
  • Views: 73
  • Message 1 of 20

Rescue & Recovery 4.2 hangs when backup is initiated

2008-07-27, 20:24 PM

I am running Rescue and Recovery 4.20.0512.00 on a Thinkpad T61p under Vista Ultimate SP1. Until I upgraded to 4.2 recently R&R was working fine. However, it hasn't run a successful backup since the upgrade. It just hangs, stuck at 0% progress.

 

I have seen similar posts from other people about this problem on a variety of platforms and versions of Windows, all with v4.2, but haven't found a fix. Any advice would be appreciated.

 

I have version 8 of the Client Security Solution, which is listed as a prerequisite for R&R 4.2.

 

Below are relevant entries from three log files, from a session today where I let it run for a while then killed it.

From c:\swshare\engine.log:

Sun Jul 27 13:28:01 2008 Engine: br_funcs.exe - version is '04.14.200.00'
Sun Jul 27 13:28:01 2008 Engine: DeleteSISAndExclude (delType 1, DriveLetter C, Destination 'D:\RRbackups', Level 3)
Sun Jul 27 13:28:15 2008 Engine: DeleteSISAndExclude exiting with return code 0x00000000
Sun Jul 27 13:28:16 2008 Engine: br_funcs.exe - version is '04.14.200.00'
Sun Jul 27 13:28:16 2008 Engine: DeleteSISAndExclude (delType 1, DriveLetter S, Destination 'D:\RRbackups', Level 3)
Sun Jul 27 13:28:17 2008 Engine: DeleteSISAndExclude exiting with return code 0x00000000
Sun Jul 27 13:28:19 2008 Engine: br_funcs.exe - version is '04.14.200.00'
Sun Jul 27 13:28:19 2008 Verbatim: WriteDriveContents(DriveLetter='C:', Dest='D:\RRbackups', Level=4, SleepCount=0, DeviceType=8, dwOptFlags=0x00000003)
Sun Jul 27 13:28:19 2008 SHADOW: Shadow called
Sun Jul 27 13:28:23 2008 SHADOW: Attempting to expose copy as 'C:\A'
Sun Jul 27 13:28:24 2008 SHADOW: Shadow exposed as 'C:\A\'
Sun Jul 27 13:28:24 2008 SHADOW: Shadow exits with dwRet = 0x00000000
Sun Jul 27 13:54:42 2008 ENGINE: Unable to send IOCTL_FFDRIVER_ENCRYPT_OFF
Sun Jul 27 13:54:42 2008 ENGINE: Unable to send IOCTL_FFDRIVER_ENCRYPT_OFF
Sun Jul 27 13:55:44 2008 Engine: br_funcs.exe - version is '04.14.200.00'
Sun Jul 27 13:55:44 2008 Engine: CopySAM called with pwszDestination='C:\RRbackups\common'
Sun Jul 27 13:56:13 2008 SHADOW: Shadow called
Sun Jul 27 13:56:55 2008 SHADOW: Attempting to expose copy as 'C:\B'
Sun Jul 27 13:56:58 2008 SHADOW: Shadow exposed as 'C:\B\'
Sun Jul 27 13:56:58 2008 SHADOW: Shadow exits with dwRet = 0x00000000
Sun Jul 27 13:56:59 2008 SHADOW: Shadow called
Sun Jul 27 13:57:32 2008 SHADOW: Shadow exits with dwRet = 0x00000000
Sun Jul 27 13:57:32 2008 Engine: CopySAM exiting with dwRet = 0x00000000

 

And from c:\swshare\rr.log

Sun Jul 27 11:59:35 2008 RescueRecovery: Loc=8 NoPrimary=0
Sun Jul 27 13:27:50 2008 RescueRecovery: Loc=8 NoPrimary=0
Sun Jul 27 13:27:57 2008 RescueRecovery: Running: C:\Program Files\Common Files\Lenovo\msgbox.exe /t=56 /id=65 /icon=wait
Sun Jul 27 13:27:57 2008 RescueRecovery: BackupThread Started.  There are 2 partitions to back up
Sun Jul 27 13:27:57 2008 RescueRecovery: Running: C:\Program Files\Lenovo\Rescue and Recovery\instapps.exe /capture
Sun Jul 27 13:28:01 2008 RescueRecovery: Running: C:\Program Files\Lenovo\Rescue and Recovery\br_funcs.exe delExclude drive=C: destination="D:\RRbackups" level=3
Sun Jul 27 13:28:15 2008 RescueRecovery: Running: C:\Program Files\Lenovo\Rescue and Recovery\br_funcs.exe delExclude drive=S: destination="D:\RRbackups" level=3
Sun Jul 27 13:28:19 2008 RescueRecovery: Running: C:\Program Files\Common Files\Lenovo\msgbox.exe /exit
Sun Jul 27 13:28:19 2008 RescueRecovery: Running: C:\Program Files\Lenovo\Rescue and Recovery\br_funcs.exe backup level=4 destination="D:\RRbackups" drive=C: location=8 nice=0 pw=1 uuid=0 compress encrypt
Sun Jul 27 13:54:42 2008 RescueRecovery: Unable to send ENCRYPT_OFF IOCTL: Error 1 SetFilter
Sun Jul 27 13:54:42 2008 RescueRecovery: Unable to send ENCRYPT_OFF IOCTL: Error 1 SetFilter

 

And finally c:\swshare\sfr.log

Sun Jul 27 13:54:33 2008 SFR: RRAPI_getBCDPartition(): RRSettings.get() succeeded. Value returned: S:
Sun Jul 27 13:54:33 2008 SFR: RRAPI_getWindowsFolder(): RRSettings.get() succeeded. Value returned: C:\Windows
Sun Jul 27 13:54:33 2008 SFR: GetFileFromLocalBackupFolder((null), C:\Program Files\Lenovo\Rescue and Recovery\KernelFileDigest.dat)
Sun Jul 27 13:54:33 2008 SFR: RRAPI_GetLocalBackupLocation(): Value returned: C:\RRbackups
Sun Jul 27 13:54:42 2008 SFR: CopyFile(C:\RRbackups\FR\KernelFileDigest.dat, C:\Program Files\Lenovo\Rescue and Recovery\KernelFileDigest.dat)
Sun Jul 27 13:54:42 2008 SFR: Error to copy C:\RRbackups\FR\KernelFileDigest.dat in C:\Program Files\Lenovo\Rescue and Recovery\KernelFileDigest.dat - ERROR: 5
Sun Jul 27 13:55:49 2008 SFR: GetFileFromLocalBackupFolder((null), C:\Program Files\Lenovo\Rescue and Recovery\KernelFileDigest.dat)
Sun Jul 27 13:55:49 2008 SFR: RRAPI_GetLocalBackupLocation(): Value returned: C:\RRbackups
Sun Jul 27 13:55:49 2008 SFR: CopyFile(C:\RRbackups\FR\KernelFileDigest.dat, C:\Program Files\Lenovo\Rescue and Recovery\KernelFileDigest.dat)
Sun Jul 27 13:55:49 2008 SFR: RRAPI_GetFileFromBackupFolder(): CopyFile() successful
Sun Jul 27 13:55:50 2008 SFR: StoreFileInLocalBackupFolder((null), C:\Program Files\Lenovo\Rescue and Recovery\UpdatingFiles.dat)
Sun Jul 27 13:55:50 2008 SFR: CopyFile(C:\Program Files\Lenovo\Rescue and Recovery\UpdatingFiles.dat, C:\RRbackups\FR\UpdatingFiles.dat)

 

 

Reply
Options

1 Posts

07-31-2008

NOVA

2 Signins

8 Page Views

  • Posts: 1
  • Registered: ‎07-31-2008
  • Location: NOVA
  • Views: 8
  • Message 2 of 20

Re: Rescue & Recovery 4.2 hangs when backup is initiated

2008-07-31, 0:32 AM

make sure that scheduler_proxy.exe is running. I just had this issue because I disabled the scheduler_proxy from starting up in msconfig. I re-enabled it and now its no longer stalling at 0% and unresponsive. Its actually backing up now.

 

Now if you do have scheduler_proxy.exe running, I dont know what the issue could be.

Reply
Options

6 Posts

07-27-2008

Tarrytown NY, USA

6 Signins

73 Page Views

  • Posts: 6
  • Registered: ‎07-27-2008
  • Location: Tarrytown NY, USA
  • Views: 73
  • Message 3 of 20

Re: Rescue & Recovery 4.2 hangs when backup is initiated

2008-08-09, 18:51 PM

Thanks but this is not my issue as scheduler_proxy is running. I still have the same problem -- and did I mention that when R&R hangs it hangs the whole machine, or at least the user interface?

 

I tried a number of things such as erasing all backups and starting again, reinstalling R&R and Client Security Solution, etc. Still the hang. I am out of ideas so any suggestions will be welcomed.

Reply
Options

3 Posts

04-09-2008

Toronto, Canada

11 Signins

59 Page Views

  • Posts: 3
  • Registered: ‎04-09-2008
  • Location: Toronto, Canada
  • Views: 59
  • Message 4 of 20

Re: Rescue & Recovery 4.2 hangs when backup is initiated

2008-10-02, 2:50 AM

I have a similar proble with my X61S running Win XP SP2. but I cannot nearly as far. I start Rescue and Recovery and it immediately goes to the progress screen and freezes. I suspect that a dialog box is not popping up as I get 2 hints:

When I close it down using Task Manager I get

'The system cannot  end this program as it waiting for a response from you'

 

Also , from C:\SWSHARE\rr.log there are lots of messages like this:

 

Wed Oct 01 14:41:08 2008 RescueRecovery: No user found to display dialog '0', waiting...

 

or this:

 

Mon Sep 29 18:03:11 2008 RescueRecovery: No user found to display message '104', waiting...
 

Any ideas? 

 

What is this scheduler_proxy ? How do we know it is related? I cannot find any program or service like it.

Reply
Options

2 Posts

11-27-2008

Tennessee

3 Signins

9 Page Views

  • Posts: 2
  • Registered: ‎11-27-2008
  • Location: Tennessee
  • Views: 9
  • Message 5 of 20

Re: Rescue & Recovery 4.2 hangs when backup is initiated

2008-11-27, 22:26 PM

Not sure why it hangs it 0%, but I experienced what "appeared" to be a hang and in fact, the Rescue and Recovery program was just waiting for input. It had displayed a pop-up, but it was underneath the main "Rescue and Recovery" panel.

I had what I thought was a hang at 68%. Went to bed, next day, still 68%. Tried to up the priority, etc. Same thing. Then I happened to click on minimize icon of the "Backing up your system" panel. That minimized both windows to the desktop NOT the task bar. (So DON'T use the "show desktop" button, it has to be the minimize button on the window) 

By so doing, I was able to see the pop-up that was underneath. The pop-up simply advised it couldn't backup a file because it was corrupted or locked (which is sometimes due to it being encrypted... or in use.)

Hope this helps and if not you, then someone else who has a similar issue.

- T60 XP-SP3

Reply
Options

2 Posts

12-15-2008

USA

15 Signins

109 Page Views

  • Posts: 2
  • Registered: ‎12-15-2008
  • Location: USA
  • Views: 109
  • Message 6 of 20

Re: Rescue & Recovery 4.2 hangs when backup is initiated

2008-12-16, 16:27 PM
I have experienced the same hang problem with Thinkvantage Rescue and Recovery 4.21 on my ThinkPad 61p running Windows Vista 64 Bit Business SP1, even after updating the BIOS to the latest version.  The Backup hangs at 0% and there are no error messages. 
Reply
Options

1 Posts

12-20-2008

Boston

2 Signins

30 Page Views

  • Posts: 1
  • Registered: ‎12-20-2008
  • Location: Boston
  • Views: 30
  • Message 7 of 20

Re: Rescue & Recovery 4.2 hangs when backup is initiated

2008-12-20, 19:35 PM
I am seeing the same exact issue that everyone else is experiencing.  I have a T61P with Window Vista Home Premium.  I just reinstalled everything yesterday and came across the rescue and recovery hang issue after I installed the SP1 update.  Is the feeling among the group that we should downgrade to the prior rescue and recovery version from Lenovo?  Has anyone tried this?
Reply
Options

16 Posts

12-07-2008

USA

229 Signins

912 Page Views

  • Posts: 16
  • Registered: ‎12-07-2008
  • Location: USA
  • Views: 912
  • Message 8 of 20

Re: Rescue & Recovery 4.2 hangs when backup is initiated

2008-12-20, 23:28 PM

I am also having the same problem with my new T400.  I have tried to initiate a backup several times and each time the program hangs at 0%.  Eventually the whole system locks up, though Process Lasso doesn't indicate a heavy processor load.  It looks like something is throwing a spanner into the works.  I can't even shut it down by any means.  I have to do a hard power off and restart.  Needless to say, I won't be attempting it again until someone who knows more about it finds a solution. 

 

If one was to try a previous version, where would it be found?

Reply
Options

3 Posts

04-09-2008

Toronto, Canada

11 Signins

59 Page Views

  • Posts: 3
  • Registered: ‎04-09-2008
  • Location: Toronto, Canada
  • Views: 59
  • Message 9 of 20

Re: Rescue & Recovery 4.2 hangs when backup is initiated

2008-12-21, 14:01 PM

I was assuming that the log message 'Sun Jul 27 13:54:42 2008 RescueRecovery: Unable to send ENCRYPT_OFF IOCTL: Error 1 SetFilter' was the issue but the log posted by ryengineer in this thread implies otherwise .

Reply
Options

6 Posts

07-27-2008

Tarrytown NY, USA

6 Signins

73 Page Views

  • Posts: 6
  • Registered: ‎07-27-2008
  • Location: Tarrytown NY, USA
  • Views: 73
  • Message 10 of 20

Re: Rescue & Recovery 4.2 hangs when backup is initiated

2008-12-21, 16:00 PM

I don't really know what the issue is as I haven't done any more work on the problem since I posted the first message in this thread. Looking back at that I see that I didn't mention that I am running BitLocker -- I'm not sure if that's relevant. Even so, of course R&R should work with BitLocker on.

 

I gave up on R&R for backups and in fact uninstalled it. I have been using Mozy for backups and it works very well, with the added advantage that the backup is physically far away from here instread of on the desk beside me.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms