Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Software and Operating SystemPre-Installed Lenovo Software and Applications
All Forum Topics
Options

7 Posts

11-18-2011

New York

7 Signins

49 Page Views

  • Posts: 7
  • Registered: ‎11-18-2011
  • Location: New York
  • Views: 49
  • Message 1 of 15

Rescue and Recovery

2011-11-18, 16:08 PM

Been using Rescue and Recovery for a while now - have not been able to get a successful backup in a few months now and am finally getting around to resolving it (I have Windows Backup running as a redundancy.)

 

I'm backing up to a network drive and every time I backup (scheduled or manual) it fails. It sits for about two days (br_funcs using up a huge amount of CPU cycles - thank god for multiple cores). After working for about 48 hours - it starts copying files to the C\Merge folder on the network drive. Five hours into copying files to the C\Merge folder - rescue and recovery errors out with the "The backup failed because the destination network location can no longer be reached" error message (which from what I can tell doesn't mean anything.)

 

Looking in swshare\engine.log I notice that I get the following error messages at the point of backup failure:

Fri Nov 18 03:53:45 2011 Engine: CopyDataToNewBackup failed for 'C:\Users\username\Workspaces\test.com\Work\Referenced Packages\Google AdWords\dashboards\GoogleAdWordsDashboards' - DecompressAndDecryptBuffer failed

 

Fri Nov 18 03:53:45 2011 Engine: Unable to merge contents - unable to merge C:\Users\username\Workspaces\test.com\Work\Referenced Packages\Google AdWords\dashboards\GoogleAdWordsDashboards - dwRet = 0x0000054c

 

Fri Nov 18 03:53:45 2011 Verbatim: MergeIncrementals exiting with return code 0x0000054c

 

I thought to myself - Hey - maybe these files are causing the backup to fail so I totally removed the \Work directory and all subfolders. The weird part is that I'm still getting this error message on this file even though it no longer exists - so there has to be some sort of error in merging this file from an old backup with the new backup. And it always fails on the same file.

 

After this long winded post - two questions -

1. Why does R&R take two days before it actually starts to copy any files? It's a pain to try and diagnose this thing when you have to wait 48 hours to see if what you did works. No - the network/NAS is not slow. I can copy files at a reasonable speed - 48 hours should easily allow me to copy TBs of data.

 

2. How does one get awound the  DecompressAndDecryptBuffer error messages?

Reply
Options

7 Posts

11-18-2011

New York

7 Signins

49 Page Views

  • Posts: 7
  • Registered: ‎11-18-2011
  • Location: New York
  • Views: 49
  • Message 2 of 15

Re: Rescue and Recovery

2011-11-18, 16:12 PM
I see they have out version 4.5 now - I'm going to try upgrading and I'll let everyone know if it worked any differently.
Reply
Options

7263 Posts

10-29-2009

United States of America

17930 Signins

168610 Page Views

  • Posts: 7263
  • Registered: ‎10-29-2009
  • Location: United States of America
  • Views: 168610
  • Message 3 of 15

Re: Rescue and Recovery

2011-11-18, 19:25 PM

Something in your backups has gotten corrupted.  The merge process - e.g. merging your oldest two incremental backups to make room for your new backup - is failing.  If you want to keep using R&R, I would recommend deleting all your backups (starting with the most recent backup first), and then taking a new backup.

 

As for why the merge is failing, I've heard of this 2 previous times, and both times the user had Kaspersky AV installed.  There might be some incompatibility between R&R and Kaspersky, although I have not been able to find it myself.

Reply
Options

7 Posts

11-18-2011

New York

7 Signins

49 Page Views

  • Posts: 7
  • Registered: ‎11-18-2011
  • Location: New York
  • Views: 49
  • Message 4 of 15

Re: Rescue and Recovery

2011-11-18, 19:31 PM

Don't have Kaspersky, so it can't be that but it definitly was something with one of the backups.

 

The last backup occured at around the time the initial SSD in this system failed - I'm wondering if files get written to the local drive temporarily and if so could one of them have been corrupted?

 

Installing version 4.5 causes R&R to create a new backup set and everything appears to be working now.

Reply
Options

6 Posts

11-20-2011

Near Heidelberg, Germany

12 Signins

123 Page Views

  • Posts: 6
  • Registered: ‎11-20-2011
  • Location: Near Heidelberg, Germany
  • Views: 123
  • Message 5 of 15

Re: Rescue and Recovery 4.5 / Installation failed

2011-11-20, 19:00 PM

Hi,

 

I tried to install RnR 4.5 after a clean install (XP -> Win 7 Pro x64) for my x200t with all latest drivers / updates / remarks from Lenovo and FAILED badly.

 

Error message: (Original German message: RnR kann nicht auf dem Betriebssystem installiert werden, das von einem aelteren vorinstallierten Betriebssystem aktualisiert wird) => translated to English:  RnR cannot be installed on an OS that has been upgraded from an older version of a pre-installed OS.

 

Unfortunately, I overlooked the following key sentence in the download recommendations:  :-(  => ... Therefore, the Windows Installer does not support the over install behavior from previous versions of the Rescue and Recovery program ...

 

I assume that I am not now left out without any chance to get RnR up and running for my system. And all that after a phantastsic smooth clean install of Win 7 Pro x64.

 

Does anyone here have any recommendation what to do now?

 

Thanks,

Karl

 

ThinkPad X200T (7449-C4G), 1.86GHz, 4GB RAM, 250GB ,12.1in 1280x800 LCD, Intel 4500MHD, Intel 802.11agn wireless, Vodafone WWAN, Secure chip, Fingerprint reader, Camera, 8c Li-Ion, Win7 Pro x64
Ideapad S10, 2 GB RAM, Vodafone WWAN, Camera / Veriface, Win XP
Reply
Options

9579 Posts

01-13-2008

United States of America

78275 Signins

2253875 Page Views

  • Posts: 9579
  • Registered: ‎01-13-2008
  • Location: United States of America
  • Views: 2253875
  • Message 6 of 15

Re: Rescue and Recovery 4.5 / Installation failed

2011-11-21, 5:40 AM

Does that message say that R&R can't be installed on an upgraded _OS_, or can't be used  as an upgrade to a pre-installed _R&R_?  My Deutsch is waaaay  too rusty....

 

I have R&R installed on my T400 running a clean-installed W7 Pro 64 _upgrade_.  Maybe you just need to uninstall the existing R&R if there is one, and clean install the new R&R?

 

[edit] Was this clean install from MS media, and did you let it use the entire drive?  That's my configuration.  If you still have an old Lenovo XP recovery partition on the HD, perhaps that's what the message is about.

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English

Reply
Options

6 Posts

11-20-2011

Near Heidelberg, Germany

12 Signins

123 Page Views

  • Posts: 6
  • Registered: ‎11-20-2011
  • Location: Near Heidelberg, Germany
  • Views: 123
  • Message 7 of 15

Re: Rescue and Recovery 4.5 / Installation failed

2011-11-21, 11:16 AM

Thanks!

Content-wise it says: R&R can't be used as an upgrade to a pre-installed RnR on the OLD OS. Sorry for the confusion around my translation.

The clean-install was from latest MS media (latest ISO image) and had the entire drive.

However, just found out that the old RnR back-up partition is still in place. Probably I need to delete the partition and restart the RnR install. Also tried to find the "old" RnR version but nothing available. 

 

Will keep progress posted.

Karl

 

ThinkPad X200T (7449-C4G), 1.86GHz, 4GB RAM, 250GB ,12.1in 1280x800 LCD, Intel 4500MHD, Intel 802.11agn wireless, Vodafone WWAN, Secure chip, Fingerprint reader, Camera, 8c Li-Ion, Win7 Pro x64
Ideapad S10, 2 GB RAM, Vodafone WWAN, Camera / Veriface, Win XP
Reply
Options

6 Posts

11-20-2011

Near Heidelberg, Germany

12 Signins

123 Page Views

  • Posts: 6
  • Registered: ‎11-20-2011
  • Location: Near Heidelberg, Germany
  • Views: 123
  • Message 8 of 15

Re: Rescue and Recovery 4.5 / Installation failed

2011-11-21, 11:42 AM
Unfortunately, the RnR (OEM) service partition is part of the primary partition which I cannot delete with Win 7 tools. I am also not experienced enough to do just by trial & error. Do you have an idea how I could proceed without ruining my latest efforts?
Tnx,
K
ThinkPad X200T (7449-C4G), 1.86GHz, 4GB RAM, 250GB ,12.1in 1280x800 LCD, Intel 4500MHD, Intel 802.11agn wireless, Vodafone WWAN, Secure chip, Fingerprint reader, Camera, 8c Li-Ion, Win7 Pro x64
Ideapad S10, 2 GB RAM, Vodafone WWAN, Camera / Veriface, Win XP
Reply
Options

9579 Posts

01-13-2008

United States of America

78275 Signins

2253875 Page Views

  • Posts: 9579
  • Registered: ‎01-13-2008
  • Location: United States of America
  • Views: 2253875
  • Message 9 of 15

Re: Rescue and Recovery 4.5 / Installation failed

2011-11-21, 14:41 PM

I'm not quite following.  Sorry.  Is there actually an R&R partition showing in disk management, or is R&R a bootable image file contained in the Windows partition?

 

Is there an option to uninstall R&R in Control Panel -> Uninstall a Program?

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English

Reply
Options

6 Posts

11-20-2011

Near Heidelberg, Germany

12 Signins

123 Page Views

  • Posts: 6
  • Registered: ‎11-20-2011
  • Location: Near Heidelberg, Germany
  • Views: 123
  • Message 10 of 15

Re: Rescue and Recovery 4.5 / Installation failed

2011-11-21, 15:06 PM

Sorry! I try again.

 

Disk management shows two sections within the primary partition.

1. System partition (c) NFTS

2. OEM-Partition (no name shown but it is the old R&R SERVICE partition)

 

If the OEM partition is a bootable image file I do not know but assume so. Since it still contains the old R&R back-ups down under Win XP.

 

R&R is not installed under Win 7 Pro. I checked thoroughly. Thus, my assumption is that the R&R 4.5 installer somehow checks if any available "old" R&R traces are available (note: no over install possible) and upon detection of such traces terminates the installation with an error message.

 

Since the OEM partition is part of the primary partition, I leave my fingers off.

 

Would be in interesting to know though how the official Win 7 Pro recovery CD would have handled the same problem.

 

ThinkPad X200T (7449-C4G), 1.86GHz, 4GB RAM, 250GB ,12.1in 1280x800 LCD, Intel 4500MHD, Intel 802.11agn wireless, Vodafone WWAN, Secure chip, Fingerprint reader, Camera, 8c Li-Ion, Win7 Pro x64
Ideapad S10, 2 GB RAM, Vodafone WWAN, Camera / Veriface, Win XP
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms